summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-15 05:49:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-15 05:59:18 +0100
commitad4d7c191a4eb4e697b118c7cb40356cfa47fc7f (patch)
treeb15ec7151068701f57af871a67d4fcc6ee8aaea6 /dev-python/sqlparse
parentdev-python/lxml-html-clean: Bump to 0.4.0 (diff)
downloadgentoo-ad4d7c191a4eb4e697b118c7cb40356cfa47fc7f.tar.gz
gentoo-ad4d7c191a4eb4e697b118c7cb40356cfa47fc7f.tar.bz2
gentoo-ad4d7c191a4eb4e697b118c7cb40356cfa47fc7f.zip
dev-python/sqlparse: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlparse')
-rw-r--r--dev-python/sqlparse/Manifest1
-rw-r--r--dev-python/sqlparse/sqlparse-0.5.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sqlparse/Manifest b/dev-python/sqlparse/Manifest
index 81c1f872d628..074a40567ce5 100644
--- a/dev-python/sqlparse/Manifest
+++ b/dev-python/sqlparse/Manifest
@@ -1 +1,2 @@
DIST sqlparse-0.5.1.tar.gz 84502 BLAKE2B b0569552848795053c33e616966075629ae52e61cdc6950bfbc9c4a4976a1b39d6c80f26c25ed5bbd125395f38ed495e5df7532d5f3289e8eece398acc4abaf1 SHA512 5d93e942d6a26a544827a877cb2035328f406dc8e8475e217ba75571672b6c5eaca6f87c2c76244c0dea32449c818fcca9bb8fff53679e6f0ba2bef2a6b92b6f
+DIST sqlparse-0.5.2.tar.gz 84951 BLAKE2B a270c94bc54de65f7c18549c262e40348cf7961cdd44c33dbcccdc7da59fe89ae1e746982b5f70cf859a2e16ca7721537f976ebce31f9664873c7182ebdf205d SHA512 d674996be8ef89309d73ae924904e3dbe09cfe6d9f2278d5aec43425571a8300785de96efd0936be82e49ec725668c234fd8a4a99b387832c4acce45ef0c8c62
diff --git a/dev-python/sqlparse/sqlparse-0.5.2.ebuild b/dev-python/sqlparse/sqlparse-0.5.2.ebuild
new file mode 100644
index 000000000000..2f4e3391419b
--- /dev/null
+++ b/dev-python/sqlparse/sqlparse-0.5.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="
+ https://github.com/andialbrecht/sqlparse/
+ https://pypi.org/project/sqlparse/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest