summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-13 20:30:11 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-13 21:53:25 +0200
commit4c2b952c307d710f2762bfb5c7b2ba6e14021019 (patch)
treec7a79fef9f99ea39e530a320968207da22b09b8d /dev-python/tox
parentapp-misc/tmuxp: add 1.19.1 (diff)
downloadgentoo-4c2b952c307d710f2762bfb5c7b2ba6e14021019.tar.gz
gentoo-4c2b952c307d710f2762bfb5c7b2ba6e14021019.tar.bz2
gentoo-4c2b952c307d710f2762bfb5c7b2ba6e14021019.zip
dev-python/tox: add 4.0.9
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tox')
-rw-r--r--dev-python/tox/Manifest1
-rw-r--r--dev-python/tox/tox-4.0.9.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/tox/Manifest b/dev-python/tox/Manifest
index c0099da9912a..b548d32d245d 100644
--- a/dev-python/tox/Manifest
+++ b/dev-python/tox/Manifest
@@ -1,3 +1,4 @@
DIST tox-3.27.1.gh.tar.gz 309006 BLAKE2B fa8aaa9cd5b03e54c166bb6b748290420b91498b26d2d124d9f88a64806b9ac0578c1886845b25aa024907f6a782c45609fa6c7657d9e1f538b59c2d9f0f4e14 SHA512 5f568bc6c53f871aae91928681dd6f2419b876a8e6ca925e65abae845b548ee3d00513741882875bbbacb78bf64935228d98213f940d3da8c3f788b73f177b79
DIST tox-4.0.5.gh.tar.gz 277741 BLAKE2B 19250ec4365a38a149c59de99ebd3b819cc4aba7721c076cc6700a17eb56b7c4b61d5c3b11046dc6857d082f1c04e98c6a78b8c768551468bca5a6810c4b7749 SHA512 7bc6f5479df577b66a7e43b61520995d1d31d056baf5b6297d9dc6acb19da58ed1f7d0db13930ab114417f0ad752799ac512765af18041ec800022b18676db20
DIST tox-4.0.8.gh.tar.gz 278697 BLAKE2B ef87b02d95447d52135aa745fd224f7ec1f76f5e99e37ee8dc4990a1577a5f4d2103f21d26e4b32946c20ccbc44aa7e3954e167dcf7599f548466574121ff7dd SHA512 bac13d4a74d76405c658a05eb50df258ae8f5ae8b821b36bc41d473562a0930667bf3b4eb96d873e92f89811af2a8dfd19009622efca8836f163aed53476b46a
+DIST tox-4.0.9.gh.tar.gz 279196 BLAKE2B 4e0c869a4bf28865eae50a6457875bc29012547069cdfe666fc1a8a12007fb5cff1501bf0f4c2791d38680328f2222bbbb37342bbfc6e7fc3ee4587ce6e70035 SHA512 341894cf879d48e4fbdd11271dfdff59ae5b719b02d8be46fa712b68528ad69ffe7df63639537b95e3f6dcf747dbf99b2d8daa18a87513d9c141e28cc59d6363
diff --git a/dev-python/tox/tox-4.0.9.ebuild b/dev-python/tox/tox-4.0.9.ebuild
new file mode 100644
index 000000000000..ed83ca51ba13
--- /dev/null
+++ b/dev-python/tox/tox-4.0.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="virtualenv-based automation of test activities"
+HOMEPAGE="
+ https://tox.readthedocs.io/
+ https://github.com/tox-dev/tox/
+ https://pypi.org/project/tox/
+"
+SRC_URI="
+ https://github.com/tox-dev/tox/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/cachetools-5.2[${PYTHON_USEDEP}]
+ >=dev-python/chardet-5.1[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.6[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-api-1.2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.2.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/distlib-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/flaky-3.7[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9.4[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ >=dev-python/re-assert-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/time-machine-2.8.2[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ # the minimal bounds in tox are entirely meaningless and new packaging
+ # breaks setuptools
+ sed -i -e '/packaging/s:>=22::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # devpi_process is not packaged, and has lots of dependencies
+ cat > "${T}"/devpi_process.py <<-EOF || die
+ def IndexServer(*args, **kwargs): raise NotImplementedError()
+ EOF
+
+ local -x PYTHONPATH=${T}:${PYTHONPATH}
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/tox_env/python/virtual_env/package/test_package_cmd_builder.py::test_build_wheel_external
+ )
+ local EPYTEST_IGNORE=(
+ # requires devpi*
+ tests/test_provision.py
+ )
+ if ! has_version "dev-python/time_machine[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/util/test_spinner.py
+ )
+ fi
+
+ epytest
+}