summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 12:11:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 12:11:39 +0100
commit3c110ed364db71961d3d610f35127f3aefdb30fb (patch)
treea8b880aabeaa8ec94d7214bd876664c8e00d09c9 /dev-python/translate-toolkit
parentdev-python/tiny-proxy: Remove old (diff)
downloadgentoo-3c110ed364db71961d3d610f35127f3aefdb30fb.tar.gz
gentoo-3c110ed364db71961d3d610f35127f3aefdb30fb.tar.bz2
gentoo-3c110ed364db71961d3d610f35127f3aefdb30fb.zip
dev-python/translate-toolkit: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/files/translate-toolkit-3.10.1-py312.patch36
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.10.1-r1.ebuild124
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.11.0.ebuild118
4 files changed, 0 insertions, 280 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index b0df2a44f812..a7ac0ef8bf49 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,3 +1 @@
-DIST translate-3.10.1.gh.tar.gz 1197315 BLAKE2B 8cb9f78e505a7e6c737fa39e32c731313893d9016e14e79d565f2c68baecedd8be47bc4cc715000ee8dfcf094624b9b3a68a39800ec98908684dab8e8517448e SHA512 f3355603e445a432cb69f102a2ce4a20013b3df1a4c17c60a4599b069db6a0ad5316d29d79f211a61a1eb155dd550fb2db7c98e3f36dc858c5d15118cbeae8d8
-DIST translate-3.11.0.gh.tar.gz 1197440 BLAKE2B 8443135619bfed752db883a7fab17efb2860c0cf5d42d5345be80c7b4a17c3764f56ed01f5e77c26984155f0c24e61b7f6a2ec852093b17ae2e8c62cb0abf9c0 SHA512 a542fac267a931e0b92c18fc9eef094c7ab2d78ea366b58880e63e1421dd914f06eb1618d178d8e586b0040003d3fec5aebde705b8715b773bd0e3a91b73b841
DIST translate-3.11.1.gh.tar.gz 1197476 BLAKE2B 5db1d5ab5dd79b0f85b48ca13e1a281a88d7e9e3a5502f9d5e44c3a82014aa49e28b3e283b2636f3bff79385da7e5db658b160c32275deb823625199a8932b57 SHA512 5b75e28c0baa41dc3a0fabb08e1961530bdffb2ae9d18bf40a682816b222f0bb725dbe67ba3536b9029c8d50c1c6b38eaa9f3e8fcbeb69653ef6565613013371
diff --git a/dev-python/translate-toolkit/files/translate-toolkit-3.10.1-py312.patch b/dev-python/translate-toolkit/files/translate-toolkit-3.10.1-py312.patch
deleted file mode 100644
index da0fd91520aa..000000000000
--- a/dev-python/translate-toolkit/files/translate-toolkit-3.10.1-py312.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 3217ed10bb9371ff25cb04e194e0250d42f89206 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Michal=20=C4=8Ciha=C5=99?= <michal@cihar.com>
-Date: Tue, 7 Nov 2023 08:42:56 +0100
-Subject: [PATCH] optrecurse: properly close opened files
-
-This avoids leaking file descriptors in the tests and makes sure the
-content is written at the end of conversion.
-
-Fixes #5071
----
- translate/misc/optrecurse.py | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/translate/misc/optrecurse.py b/translate/misc/optrecurse.py
-index d69666b8e8..9337c7c4ff 100644
---- a/translate/misc/optrecurse.py
-+++ b/translate/misc/optrecurse.py
-@@ -684,10 +684,17 @@ def processfile(
- tempoutput = False
- templatefile = self.opentemplatefile(options, fulltemplatepath)
- passthroughoptions = self.getpassthroughoptions(options)
-- if fileprocessor(inputfile, outputfile, templatefile, **passthroughoptions):
-+ result = fileprocessor(
-+ inputfile, outputfile, templatefile, **passthroughoptions
-+ )
-+ if fullinputpath is not None:
-+ inputfile.close()
-+ if result:
- if tempoutput:
- self.warning("writing to temporary output...")
- self.finalizetempoutputfile(options, outputfile, fulloutputpath)
-+ if fulloutputpath and os.path.isfile(fulloutputpath):
-+ outputfile.close()
- return True
- else:
- # remove the file if it is a file (could be stdout etc)
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.10.1-r1.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.10.1-r1.ebuild
deleted file mode 100644
index 507a80f7bb74..000000000000
--- a/dev-python/translate-toolkit/translate-toolkit-3.10.1-r1.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-MY_P=translate-${PV}
-DESCRIPTION="Toolkit to convert between many translation formats"
-HOMEPAGE="
- https://github.com/translate/translate/
- https://pypi.org/project/translate-toolkit/
-"
-SRC_URI="
- https://github.com/translate/translate/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="+html +ical +ini +subtitles +yaml"
-
-RDEPEND="
- app-text/iso-codes
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
- >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- sys-devel/gettext
- html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
- ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
- ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
- subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
- yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
-"
-# Technically, the test suite also has undeclared dependency
-# on dev-python/snapshottest but all the tests using it are broken
-# anyway, so we skip them.
-BDEPEND="
- test? (
- dev-python/phply[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # https://github.com/translate/translate/commit/3217ed10bb9371ff25cb04e194e0250d42f89206
- "${FILESDIR}/${P}-py312.patch"
-)
-
-distutils_enable_tests pytest
-
-src_test() {
- # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
- # correctly, so we need to reassemble all data files in a single directory
- local -x XDG_DATA_HOME=${T}/share
- cp -r translate/share "${T}/" || die
- cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Fails with network-sandbox (and even with it off but w/ softer fail)
- 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
- 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
- # all tests based on snapshottest are broken and I'm too tired
- # to figure this out
- translate/tools/test_pocount.py::test_cases
- translate/tools/test_pocount.py::test_output
- translate/tools/test_junitmsgfmt.py::test_output
- )
- local EPYTEST_IGNORE=(
- # unpackaged fluent.*
- translate/storage/test_fluent.py
- # changes directory and does not change it back, sigh
- tests/odf_xliff/test_odf_xliff.py
- )
-
- if ! use ini; then
- EPYTEST_IGNORE+=(
- translate/convert/test_ini2po.py
- translate/convert/test_po2ini.py
- )
- fi
-
- if ! use subtitles; then
- EPYTEST_IGNORE+=(
- translate/storage/test_subtitles.py
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr
- doins -r translate/share
-
- if ! use html; then
- rm "${ED}"/usr/bin/{html2po,po2html} || die
- fi
- if ! use ical; then
- rm "${ED}"/usr/bin/{ical2po,po2ical} || die
- fi
- if ! use ini; then
- rm "${ED}"/usr/bin/{ini2po,po2ini} || die
- fi
- if ! use subtitles; then
- rm "${ED}"/usr/bin/{sub2po,po2sub} || die
- fi
-}
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.11.0.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.11.0.ebuild
deleted file mode 100644
index 9bf1ba95a909..000000000000
--- a/dev-python/translate-toolkit/translate-toolkit-3.11.0.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-MY_P=translate-${PV}
-DESCRIPTION="Toolkit to convert between many translation formats"
-HOMEPAGE="
- https://github.com/translate/translate/
- https://pypi.org/project/translate-toolkit/
-"
-SRC_URI="
- https://github.com/translate/translate/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="+html +ical +ini +subtitles +yaml"
-
-RDEPEND="
- app-text/iso-codes
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
- >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- sys-devel/gettext
- html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
- ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
- ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
- subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
- yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
-"
-# Technically, the test suite also has undeclared dependency
-# on dev-python/snapshottest but all the tests using it are broken
-# anyway, so we skip them.
-BDEPEND="
- test? (
- dev-python/phply[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
- # correctly, so we need to reassemble all data files in a single directory
- local -x XDG_DATA_HOME=${T}/share
- cp -r translate/share "${T}/" || die
- cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Fails with network-sandbox (and even with it off but w/ softer fail)
- 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
- 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
- # all tests based on snapshottest are broken and I'm too tired
- # to figure this out
- tests/translate/tools/test_pocount.py::test_{cases,output}
- tests/translate/tools/test_junitmsgfmt.py::test_output
- )
- local EPYTEST_IGNORE=(
- # unpackaged fluent.*
- tests/translate/storage/test_fluent.py
- # changes directory and does not change it back, sigh
- tests/odf_xliff/test_odf_xliff.py
- )
-
- if ! use ini; then
- EPYTEST_IGNORE+=(
- translate/convert/test_ini2po.py
- translate/convert/test_po2ini.py
- )
- fi
-
- if ! use subtitles; then
- EPYTEST_IGNORE+=(
- translate/storage/test_subtitles.py
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr
- doins -r translate/share
-
- if ! use html; then
- rm "${ED}"/usr/bin/{html2po,po2html} || die
- fi
- if ! use ical; then
- rm "${ED}"/usr/bin/{ical2po,po2ical} || die
- fi
- if ! use ini; then
- rm "${ED}"/usr/bin/{ini2po,po2ini} || die
- fi
- if ! use subtitles; then
- rm "${ED}"/usr/bin/{sub2po,po2sub} || die
- fi
-}