summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-08 07:07:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-08 07:12:22 +0200
commitc2f53fb930e17f8e138af90d6b3aae7216d0417b (patch)
tree5e66ac807be95ffe5670cbeea510ace17d1af9fe /dev-python/trio
parentdev-python/towncrier: Bump to 23.6.0 (diff)
downloadgentoo-c2f53fb930e17f8e138af90d6b3aae7216d0417b.tar.gz
gentoo-c2f53fb930e17f8e138af90d6b3aae7216d0417b.tar.bz2
gentoo-c2f53fb930e17f8e138af90d6b3aae7216d0417b.zip
dev-python/trio: Strip +dev from version in snapshot
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trio')
-rw-r--r--dev-python/trio/trio-0.22.0_p20230530-r1.ebuild (renamed from dev-python/trio/trio-0.22.0_p20230530.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/trio/trio-0.22.0_p20230530.ebuild b/dev-python/trio/trio-0.22.0_p20230530-r1.ebuild
index 987eea446215..83733f7b9ec0 100644
--- a/dev-python/trio/trio-0.22.0_p20230530.ebuild
+++ b/dev-python/trio/trio-0.22.0_p20230530-r1.ebuild
@@ -52,6 +52,12 @@ distutils_enable_sphinx docs/source \
dev-python/sphinx-rtd-theme \
dev-python/towncrier
+src_prepare() {
+ # strip +dev from version, as it is breaking poorly written packages
+ sed -i -e 's:+dev::' trio/_version.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
local EPYTEST_IGNORE=(
# these tests require internet access