summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-04 12:37:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-04 13:57:28 +0200
commitca23806f61b74a79a1748a948ef94a073b9e5e2c (patch)
tree7a59df8e3f54fd4a83a0a97de8801b40e56a4b57 /dev-python/validators
parentdev-python/google-i18n-address: Bump to 3.1.1 (diff)
downloadgentoo-ca23806f61b74a79a1748a948ef94a073b9e5e2c.tar.gz
gentoo-ca23806f61b74a79a1748a948ef94a073b9e5e2c.tar.bz2
gentoo-ca23806f61b74a79a1748a948ef94a073b9e5e2c.zip
dev-python/validators: Bump to 0.34.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/validators')
-rw-r--r--dev-python/validators/Manifest1
-rw-r--r--dev-python/validators/validators-0.34.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/validators/Manifest b/dev-python/validators/Manifest
index 8e563f79af98..41fe307b9ff4 100644
--- a/dev-python/validators/Manifest
+++ b/dev-python/validators/Manifest
@@ -1 +1,2 @@
DIST validators-0.33.0.tar.gz 70741 BLAKE2B e999d1ea14e2240523537804931fc91f5eb02d4ff35b22e8a292ff8785493ce48cd14ccf0d87ce945739c3e65a79b3a7654a66412bcc41e4e37e0fd87eefad72 SHA512 611844e182319209a2f6305daf3fcfc1801d9ad32179eaa9651844df37bd3d1d42bfd1e69be1e2c4fcd811a231228bc748a12dd6583248d5b572394cb9c9d858
+DIST validators-0.34.0.tar.gz 70955 BLAKE2B 5c757c3b2a0e3557663a0eee5a08fbc43087362f492629cd9fba6f7ea7d5e99544de1a82159338d02af40f434345c3170e9b19873a890690fb0d94526e495892 SHA512 d49df68ef60734d8462c37aea7b7d274ebe4b31d768761c3da6d219d59574bb6efc444e5501073fcddffcdb3752766d19d231a63da682bf02f82739526de884a
diff --git a/dev-python/validators/validators-0.34.0.ebuild b/dev-python/validators/validators-0.34.0.ebuild
new file mode 100644
index 000000000000..ee697b081282
--- /dev/null
+++ b/dev-python/validators/validators-0.34.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python Data Validation for Humans"
+HOMEPAGE="
+ https://github.com/python-validators/validators/
+ https://pypi.org/project/validators/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires eth-hash
+ tests/crypto_addresses/test_eth_address.py
+)