summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 13:52:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 15:02:08 +0200
commit0709b87c3a89d404ec5ec94ee26ebcca82a7ba99 (patch)
tree18a8738993651e6183e568b6a2eb9c060aa341cf /dev-ros/python_qt_binding
parentapp-admin/exo: version bump to 1.14.0 - remove old (diff)
downloadgentoo-0709b87c3a89d404ec5ec94ee26ebcca82a7ba99.tar.gz
gentoo-0709b87c3a89d404ec5ec94ee26ebcca82a7ba99.tar.bz2
gentoo-0709b87c3a89d404ec5ec94ee26ebcca82a7ba99.zip
dev-ros/python_qt_binding: bump to 0.4.3
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/python_qt_binding')
-rw-r--r--dev-ros/python_qt_binding/Manifest1
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.4.3.ebuild19
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-9999.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/dev-ros/python_qt_binding/Manifest b/dev-ros/python_qt_binding/Manifest
index 5cdc0055b727..c467716f79a8 100644
--- a/dev-ros/python_qt_binding/Manifest
+++ b/dev-ros/python_qt_binding/Manifest
@@ -1,2 +1,3 @@
DIST python_qt_binding-0.3.4.tar.gz 12255 BLAKE2B bc72aa806098d460e5b884bde7664f295399555d96e10b66791e59a26d1e61dd22aabecf9b40b5d14f61c2c906c18ff3fe2cd03de6108d7d9c2c649d553ab09d SHA512 df5fc2c6a744e66d0c03089e15ce4cfb3890d8fd67d826a3832d22cf99de235e18720c59f737c3ddacefb02dac5571d64042dd862c10ea4c44835063037eb533
DIST python_qt_binding-0.3.5.tar.gz 12412 BLAKE2B ee2f2537bb1ddceb5cce0ca1963e042d10e5d011cffac25caba1a714c992d975413b7e1c4a23d5472567d4e214f482414dcfc56d499fcbcb0bd5559d7670b484 SHA512 a54ce90008d0893f236533cdda7d3520db264ba3e66b6edf18bac0d6e97975823e3900d1f265a7459813c823c9fc0bce7bb12570de1f8101b588954adeb073b4
+DIST python_qt_binding-0.4.3.tar.gz 12632 BLAKE2B 1403602262a18ce359d153234bb01ff3a6a90e91f9f4a84ddcd0551723c04c493526f51b81f750c90f78005d2c5b78cf77396ecd3132f1c505038bad8639b63d SHA512 103f791a27f8e8dad668a63c0bfc96facd93cbb043541bd036355d62c787759724fe0d66788c587c3cb68486e6d2732039d7c27f567ed48f2ecf21ce98d275af
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.4.3.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.4.3.ebuild
new file mode 100644
index 000000000000..e90e684db5bd
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.4.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild b/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
index 6aed5cfe415e..e90e684db5bd 100644
--- a/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
+++ b/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin