summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-08 19:00:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-08 19:30:13 +0200
commite5ef321bdcdc11043f0681360d9eae298a7c37de (patch)
tree5b91c77b09cd8c7f0a979a960f7e4ea5bacce291 /dev-ros/rostopic
parentdev-ros/rostopic: bump eapi (diff)
downloadgentoo-e5ef321bdcdc11043f0681360d9eae298a7c37de.tar.gz
gentoo-e5ef321bdcdc11043f0681360d9eae298a7c37de.tar.bz2
gentoo-e5ef321bdcdc11043f0681360d9eae298a7c37de.zip
dev-ros/rostopic: Remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rostopic')
-rw-r--r--dev-ros/rostopic/Manifest2
-rw-r--r--dev-ros/rostopic/files/py3.patch89
-rw-r--r--dev-ros/rostopic/files/yaml.patch71
-rw-r--r--dev-ros/rostopic/rostopic-1.14.3-r1.ebuild28
-rw-r--r--dev-ros/rostopic/rostopic-1.15.4.ebuild27
5 files changed, 0 insertions, 217 deletions
diff --git a/dev-ros/rostopic/Manifest b/dev-ros/rostopic/Manifest
index e7119a998e05..5d86517495e4 100644
--- a/dev-ros/rostopic/Manifest
+++ b/dev-ros/rostopic/Manifest
@@ -1,3 +1 @@
-DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
-DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
DIST ros_comm-1.15.7.tar.gz 1080092 BLAKE2B d5c0dd1f54eac7aa11be21bbc680f85f988cc9328382c0c675b7d5986e888be603ed82affa5f51a270974d07044debe3ecf86f5647fd59cb29e8e791a227feb9 SHA512 67dc100e8ed03a25ea228cc7d456ec2203324098f9e11c9a249299df73bfc34efc75b1221c0fb6fceb38fece627f1dc5f2c23be93c9a1c85b1075784a45ff20e
diff --git a/dev-ros/rostopic/files/py3.patch b/dev-ros/rostopic/files/py3.patch
deleted file mode 100644
index 51f5da5aa778..000000000000
--- a/dev-ros/rostopic/files/py3.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From 1933acfa8107a164ec825d3223d14589fefd1b5b Mon Sep 17 00:00:00 2001
-From: Dirk Thomas <dirk-thomas@users.noreply.github.com>
-Date: Tue, 6 Aug 2019 16:06:51 -0700
-Subject: [PATCH] more Python 3 compatibility (#1783)
-
----
- test/test_rospy/test/unit/test_genmsg_py.py | 6 +--
- tools/rosgraph/src/rosgraph/roslogging.py | 2 +-
- .../test/test_roslogging_user_logger.py | 8 +++-
- tools/roslaunch/test/unit/test_xmlloader.py | 2 +-
- tools/rosmsg/src/rosmsg/__init__.py | 2 +-
- tools/rosmsg/test/test_rosmsg_command_line.py | 46 +++++++++----------
- .../test/test_rosmsgproto_command_line.py | 20 ++++----
- .../test_rostopic_command_line_offline.py | 44 +++++++++---------
- 8 files changed, 67 insertions(+), 63 deletions(-)
-
-diff --git a/tools/rostopic/test/test_rostopic_command_line_offline.py b/tools/rostopic/test/test_rostopic_command_line_offline.py
-index 5dab1ad16..37a81faaa 100644
---- a/tools/rostopic/test/test_rostopic_command_line_offline.py
-+++ b/tools/rostopic/test/test_rostopic_command_line_offline.py
-@@ -48,9 +48,9 @@ def test_cmd_help(self):
- cmd = 'rostopic'
-
- sub = ['bw', 'echo', 'hz', 'delay', 'info', 'list', 'pub', 'type','find']
-- output = Popen([cmd], stdout=PIPE).communicate()[0]
-+ output = Popen([cmd], stdout=PIPE).communicate()[0].decode()
- self.assert_('Commands' in output)
-- output = Popen([cmd, '-h'], stdout=PIPE).communicate()[0]
-+ output = Popen([cmd, '-h'], stdout=PIPE).communicate()[0].decode()
- self.assert_('Commands' in output)
- # make sure all the commands are in the usage
- for c in sub:
-@@ -59,16 +59,16 @@ def test_cmd_help(self):
-
- for c in sub:
- output = Popen([cmd, c, '-h'], stdout=PIPE, stderr=PIPE).communicate()
-- self.assert_("usage:" in output[0].lower(), output)
-+ self.assert_("usage:" in output[0].decode().lower(), output)
- # make sure usage refers to the command
-- self.assert_("%s %s"%(cmd, c) in output[0], output)
-+ self.assert_("%s %s"%(cmd, c) in output[0].decode(), output)
-
- # test no args on commands that require args
- for c in ['bw', 'echo', 'hz', 'delay', 'info', 'pub', 'type', 'find']:
- output = Popen([cmd, c], stdout=PIPE, stderr=PIPE).communicate()
-- self.assert_("usage:" in output[0].lower() or "usage:" in output[1].lower(), output)
-+ self.assert_("usage:" in output[0].decode().lower() or "usage:" in output[1].decode().lower(), output)
- # make sure usage refers to the command
-- self.assert_("%s %s"%(cmd, c) in output[1], output)
-+ self.assert_("%s %s"%(cmd, c) in output[1].decode(), output)
-
- def test_offline(self):
- cmd = 'rostopic'
-@@ -80,19 +80,19 @@ def test_offline(self):
-
- msg = "ERROR: Unable to communicate with master!\n"
-
-- output = Popen([cmd, 'bw', 'chatter'], **kwds).communicate()
-- self.assert_(output[1].endswith(msg))
-- output = Popen([cmd, 'echo', 'chatter'], **kwds).communicate()
-- self.assert_(output[1].endswith(msg))
-- output = Popen([cmd, 'hz', 'chatter'], **kwds).communicate()
-- self.assert_(output[1].endswith(msg))
-- output = Popen([cmd, 'delay', 'chatter'], **kwds).communicate()
-- self.assert_(output[1].endswith(msg))
-- output = Popen([cmd, 'list'], **kwds).communicate()
-- self.assert_(output[1].endswith(msg))
-- output = Popen([cmd, 'pub', 'chatter', 'std_msgs/String', 'hello'], **kwds).communicate()
-- self.assert_(output[1].endswith(msg))
-- output = Popen([cmd, 'type', 'chatter'], **kwds).communicate()
-- self.assert_(output[1].endswith(msg))
-- output = Popen([cmd, 'type', 'std_msgs/String'], **kwds).communicate()
-- self.assert_(output[1].endswith(msg))
-+ output = Popen([cmd, 'bw', 'chatter'], **kwds).communicate()[1].decode()
-+ self.assert_(output.endswith(msg))
-+ output = Popen([cmd, 'echo', 'chatter'], **kwds).communicate()[1].decode()
-+ self.assert_(output.endswith(msg))
-+ output = Popen([cmd, 'hz', 'chatter'], **kwds).communicate()[1].decode()
-+ self.assert_(output.endswith(msg))
-+ output = Popen([cmd, 'delay', 'chatter'], **kwds).communicate()[1].decode()
-+ self.assert_(output.endswith(msg))
-+ output = Popen([cmd, 'list'], **kwds).communicate()[1].decode()
-+ self.assert_(output.endswith(msg))
-+ output = Popen([cmd, 'pub', 'chatter', 'std_msgs/String', 'hello'], **kwds).communicate()[1].decode()
-+ self.assert_(output.endswith(msg))
-+ output = Popen([cmd, 'type', 'chatter'], **kwds).communicate()[1].decode()
-+ self.assert_(output.endswith(msg))
-+ output = Popen([cmd, 'type', 'std_msgs/String'], **kwds).communicate()[1].decode()
-+ self.assert_(output.endswith(msg))
diff --git a/dev-ros/rostopic/files/yaml.patch b/dev-ros/rostopic/files/yaml.patch
deleted file mode 100644
index e96337b50546..000000000000
--- a/dev-ros/rostopic/files/yaml.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 29053c4832229efa7160fb944c05e3bc82e11540 Mon Sep 17 00:00:00 2001
-From: Martijn Buijs <Martijn.buijs@gmail.com>
-Date: Tue, 23 Apr 2019 18:20:12 +0200
-Subject: [PATCH] Switch to yaml.safe_load(_all) to prevent YAMLLoadWarning
- (#1688)
-
-* Switch to yaml.safe_load(_all) to prevent YAMLLoadWarning
-
-* Change all usages of yaml.load to yaml.safe_load
-
-* Extend PyYAML's SafeLoader and use it with `yaml.load`
-
-Also added convenience functions for using this loader for reuse in
-`roslaunch`
-
-* fix typo in rosparam.yaml_load_all
-
-* Modify Loader and SafeLoader in yaml module directly
-
-* Revert whitespace change
-
-* Revert unrelated change to import through global variable construction
----
- clients/rospy/src/rospy/client.py | 2 +-
- .../test/test_roslib_message.py | 2 +-
- .../client_verification/test_slave_api.py | 2 +-
- test/test_rosparam/test/check_rosparam.py | 8 ++---
- .../check_rosparam_command_line_online.py | 2 +-
- .../check_rosservice_command_line_online.py | 4 +--
- test/test_rostopic/test/test_rostopic_unit.py | 30 +++++++++----------
- tools/rosbag/src/rosbag/bag.py | 2 +-
- tools/rosgraph/src/rosgraph/roslogging.py | 2 +-
- tools/roslaunch/src/roslaunch/loader.py | 4 +--
- .../test/unit/test_roslaunch_dump_params.py | 4 +--
- tools/rosparam/src/rosparam/__init__.py | 7 ++++-
- tools/rosservice/src/rosservice/__init__.py | 4 +--
- tools/rostopic/src/rostopic/__init__.py | 6 ++--
- tools/topic_tools/scripts/relay_field | 2 +-
- 15 files changed, 43 insertions(+), 38 deletions(-)
-
-diff --git a/tools/rostopic/src/rostopic/__init__.py b/tools/rostopic/src/rostopic/__init__.py
-index ad244b0f0..41138562e 100644
---- a/tools/rostopic/src/rostopic/__init__.py
-+++ b/tools/rostopic/src/rostopic/__init__.py
-@@ -1779,7 +1779,7 @@ def _rostopic_cmd_pub(argv):
- try:
- pub_args = []
- for arg in args[2:]:
-- pub_args.append(yaml.load(arg))
-+ pub_args.append(yaml.safe_load(arg))
- except Exception as e:
- parser.error("Argument error: "+str(e))
-
-@@ -1822,7 +1822,7 @@ def bagy_iter():
- try:
- with open(filename, 'r') as f:
- # load all documents
-- data = yaml.load_all(f)
-+ data = yaml.safe_load_all(f)
- for d in data:
- yield [d]
- except yaml.YAMLError as e:
-@@ -2014,7 +2014,7 @@ def stdin_yaml_arg():
-
- if arg.strip() == '---': # End of document
- try:
-- loaded = yaml.load(buff.rstrip())
-+ loaded = yaml.safe_load(buff.rstrip())
- except Exception as e:
- sys.stderr.write("Invalid YAML: %s\n"%str(e))
- if loaded is not None:
diff --git a/dev-ros/rostopic/rostopic-1.14.3-r1.ebuild b/dev-ros/rostopic/rostopic-1.14.3-r1.ebuild
deleted file mode 100644
index 1f86a766a1ff..000000000000
--- a/dev-ros/rostopic/rostopic-1.14.3-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=tools/${PN}
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/rosbag[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-PATCHES=( "${FILESDIR}/yaml.patch" "${FILESDIR}/py3.patch" )
diff --git a/dev-ros/rostopic/rostopic-1.15.4.ebuild b/dev-ros/rostopic/rostopic-1.15.4.ebuild
deleted file mode 100644
index 647d292a6d3f..000000000000
--- a/dev-ros/rostopic/rostopic-1.15.4.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=tools/${PN}
-PYTHON_COMPAT=( python2_7 )
-
-inherit ros-catkin
-
-DESCRIPTION="Command-line tool for displaying debug information about ROS Topics"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/rosbag[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"