summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-01-31 12:55:34 +0100
committerFabian Groffen <grobian@gentoo.org>2017-01-31 12:56:16 +0100
commit3f5fdced2aeeb6d90c7a95b1bc7e0014dbaba268 (patch)
tree78238579f5ff868645c31edc7ef16a3c83a2ce89 /dev-util/cscope
parentmedia-sound/qmpdclient: x86 stable wrt bug #607740 (diff)
downloadgentoo-3f5fdced2aeeb6d90c7a95b1bc7e0014dbaba268.tar.gz
gentoo-3f5fdced2aeeb6d90c7a95b1bc7e0014dbaba268.tar.bz2
gentoo-3f5fdced2aeeb6d90c7a95b1bc7e0014dbaba268.zip
dev-util/cscope: addp Prefix changes and keywords, bug #607712
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/cscope-15.8a-r2.ebuild70
-rw-r--r--dev-util/cscope/files/cscope-15.6-darwin.patch11
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-util/cscope/cscope-15.8a-r2.ebuild b/dev-util/cscope/cscope-15.8a-r2.ebuild
new file mode 100644
index 000000000000..a62cc632bd64
--- /dev/null
+++ b/dev-util/cscope/cscope-15.8a-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools elisp-common toolchain-funcs
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://cscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2:0=
+ emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
+ eapply "${FILESDIR}/${PN}-15.6-darwin.patch"
+ eapply_user
+ mv configure.{in,ac} || die
+ eautoreconf # prevent maintainer mode later on
+}
+
+src_configure() {
+ econf --with-ncurses="${EPREFIX}"/usr
+}
+
+src_compile() {
+ emake CURSES_LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+ if use emacs; then
+ cd "${S}"/contrib/xcscope || die
+ elisp-compile *.el
+ fi
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ cd "${S}"/contrib/xcscope || die
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dobin cscope-indexer
+ fi
+
+ cd "${S}"/contrib/webcscope || die
+ docinto webcscope
+ dodoc INSTALL TODO cgi-lib.pl cscope hilite.c
+ docinto webcscope/icons
+ dodoc icons/*.gif
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cscope/files/cscope-15.6-darwin.patch b/dev-util/cscope/files/cscope-15.6-darwin.patch
new file mode 100644
index 000000000000..e755f3257efd
--- /dev/null
+++ b/dev-util/cscope/files/cscope-15.6-darwin.patch
@@ -0,0 +1,11 @@
+--- a/src/constants.h
++++ b/src/constants.h
+@@ -103,7 +103,7 @@
+ #define INCLUDES 8
+ #define FIELDS 9
+
+-#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__
++#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__ && !__MACH__
+ # define TERMINFO 0 /* no terminfo curses */
+ #else
+ # define TERMINFO 1