summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-08-04 18:52:51 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-08-04 18:53:04 +0100
commitd6932537b09df0d86b6e62da1a4750a4bdccc910 (patch)
treec52f9aea97cffa69e60a9a6deaf518a3ee142bd1 /dev-util
parentapp-office/upwork: Cleanup (diff)
downloadgentoo-d6932537b09df0d86b6e62da1a4750a4bdccc910.tar.gz
gentoo-d6932537b09df0d86b6e62da1a4750a4bdccc910.tar.bz2
gentoo-d6932537b09df0d86b6e62da1a4750a4bdccc910.zip
dev-util/radare2: bump up to 3.7.0
Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/radare2/Manifest1
-rw-r--r--dev-util/radare2/files/radare2-3.7.0-with-syscapstone-p1.patch24
-rw-r--r--dev-util/radare2/files/radare2-3.7.0-with-syscapstone-p2.patch22
-rw-r--r--dev-util/radare2/radare2-3.7.0.ebuild58
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-util/radare2/Manifest b/dev-util/radare2/Manifest
index 74a78d04d00f..082b73a3c8ea 100644
--- a/dev-util/radare2/Manifest
+++ b/dev-util/radare2/Manifest
@@ -1,2 +1,3 @@
DIST radare2-3.5.1.tar.gz 7083677 BLAKE2B 3d84e79d4e20e031b6cfdbabcf80922f977328bf7da8c2871924f9520ff87252d4df18a1239793c70f4b800bb7d5c4aef923e63c93aa15d86ae685ddda205da2 SHA512 24c2a45ed539830dcb8dc1585c27e45515c70989132f500527db0ca6795027eaa82ea54d1cd7fc73ddc49641a73148be963ade1648e92b5336d2e86335e2497a
DIST radare2-3.6.0.tar.gz 7339427 BLAKE2B 60ecd110ac4cafa38dd10f49321e984e98f189398f15196614fb096970cc2f24981ffbbd161fdd55621b65c45a8fb9f843f273bf245ac0ea2b4493981ab0477d SHA512 15c02b744892934bd0b4beeb146d8a0289244405214b62892d7e307cd42f6706aca16c1e02b6b2beb5b6869c5c5920cc291ffec8a690b5338c6973a5e1d7900e
+DIST radare2-3.7.0.tar.gz 7478494 BLAKE2B 547efda30a65783758b132f4b241039b83bb274904a1f69616e60ec83547b22da486e97df06a74cd82f855650dbc3802d31bf3cb00ebd12d956848efd4b6ff5e SHA512 8e4d1b89d0d1e717403ba0bc2ce47e2644d12303ed5391fe4b9efc11b86a0b9c9356fdea1caecabe16d88ded9577fe77c182225adf2fdbd63b2e48f9c9c9f52d
diff --git a/dev-util/radare2/files/radare2-3.7.0-with-syscapstone-p1.patch b/dev-util/radare2/files/radare2-3.7.0-with-syscapstone-p1.patch
new file mode 100644
index 000000000000..3f87d606bba4
--- /dev/null
+++ b/dev-util/radare2/files/radare2-3.7.0-with-syscapstone-p1.patch
@@ -0,0 +1,24 @@
+From 8b37ac49b609cc69b27a6b3b76fa9d8d819bae83 Mon Sep 17 00:00:00 2001
+From: pancake <pancake@nopcode.org>
+Date: Thu, 1 Aug 2019 05:23:56 +0200
+Subject: [PATCH] Add capstone dependency with the mk
+
+---
+ binr/rabin2/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/binr/rabin2/Makefile b/binr/rabin2/Makefile
+index 0ecb48629..33219020b 100644
+--- a/binr/rabin2/Makefile
++++ b/binr/rabin2/Makefile
+@@ -15,6 +15,6 @@ include ../../shlr/grub/deps.mk
+ include ../../shlr/bochs/deps.mk
+ include ../../shlr/qnx/deps.mk
+ include ../../shlr/ar/deps.mk
+-LINK+=../../shlr/capstone/libcapstone.a
++include ../../shlr/capstone.mk
+
+ LDFLAGS+=$(LINK)
+--
+2.22.0
+
diff --git a/dev-util/radare2/files/radare2-3.7.0-with-syscapstone-p2.patch b/dev-util/radare2/files/radare2-3.7.0-with-syscapstone-p2.patch
new file mode 100644
index 000000000000..1ebb74efb36d
--- /dev/null
+++ b/dev-util/radare2/files/radare2-3.7.0-with-syscapstone-p2.patch
@@ -0,0 +1,22 @@
+From 38a10d64fb33484f0e50c3d8f40a6c19c0ee37ec Mon Sep 17 00:00:00 2001
+From: Slava <slava@bacher09.org>
+Date: Sun, 4 Aug 2019 04:00:12 +0300
+Subject: [PATCH] Fix build with system capstone (--with-syscapstone) (#14753)
+
+---
+ shlr/capstone.mk | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/shlr/capstone.mk b/shlr/capstone.mk
+index b3cc42d24..f1a2de04d 100644
+--- a/shlr/capstone.mk
++++ b/shlr/capstone.mk
+@@ -1 +1,5 @@
++ifeq ($(USE_CAPSTONE),1)
++LINK+=${CAPSTONE_LDFLAGS}
++else
+ LINK+=$(SHLR)/capstone/libcapstone.a
++endif
+--
+2.22.0
+
diff --git a/dev-util/radare2/radare2-3.7.0.ebuild b/dev-util/radare2/radare2-3.7.0.ebuild
new file mode 100644
index 000000000000..5d70b601195f
--- /dev/null
+++ b/dev-util/radare2/radare2-3.7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="unix-like reverse engineering framework and commandline tools"
+HOMEPAGE="http://www.radare.org"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/radare/radare2"
+else
+ SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ssl libressl"
+
+RDEPEND="
+ dev-libs/capstone:0=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=("${FILESDIR}"/${PN}-3.7.0-with-syscapstone-p{1,2}.patch)
+
+src_configure() {
+ econf \
+ --without-libuv \
+ --with-syscapstone \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/zsh/site-functions
+ doins doc/zsh/_*
+
+ newbashcomp doc/bash_autocompletion.sh "${PN}"
+ bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
+
+ # a workaround for unstable $(INSTALL) call, bug #574866
+ local d
+ for d in doc/*; do
+ if [[ -d $d ]]; then
+ rm -rfv "$d" || die "failed to delete '$d'"
+ fi
+ done
+}