summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/barbarian-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/barbarian-bin')
-rw-r--r--games-arcade/barbarian-bin/Manifest1
-rw-r--r--games-arcade/barbarian-bin/barbarian-bin-1.01-r1.ebuild48
-rw-r--r--games-arcade/barbarian-bin/metadata.xml5
3 files changed, 54 insertions, 0 deletions
diff --git a/games-arcade/barbarian-bin/Manifest b/games-arcade/barbarian-bin/Manifest
new file mode 100644
index 000000000000..1670f0c41cb2
--- /dev/null
+++ b/games-arcade/barbarian-bin/Manifest
@@ -0,0 +1 @@
+DIST barbarian101_linux.zip 925199 SHA256 0a559b2d930b9ceb54f32e5e1adc5be176290c025a2228d3372fa5bf413322c6 SHA512 9b46c75666359ed5102a89d29e8b6afacf07ccfa6175f6df27b5acc48b0e0119106f1c1376b124ff761d373bf04145e804659b81503b2834ba09ac05fad5c4f4 WHIRLPOOL a1e42954e52e1b26ad85b928ee92a9a137f982b194b5d0d71066be0428097b721d2d38bb78767edf5ecfaf4962046f38ff1a24f85fdf7ef4edd9f977e5f79562
diff --git a/games-arcade/barbarian-bin/barbarian-bin-1.01-r1.ebuild b/games-arcade/barbarian-bin/barbarian-bin-1.01-r1.ebuild
new file mode 100644
index 000000000000..4b648b4a7570
--- /dev/null
+++ b/games-arcade/barbarian-bin/barbarian-bin-1.01-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_PN=${PN/-bin/}
+DESCRIPTION="Save Princess Mariana through one-on-one battles with demonic barbarians"
+HOMEPAGE="http://www.tdbsoft.com/"
+SRC_URI="http://www.pcpages.com/tomberrr/downloads/${MY_PN}${PV/./}_linux.zip"
+
+LICENSE="CC-BY-NC-ND-2.0"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+RESTRICT="strip"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/libstdc++-v3:5
+ amd64? ( sys-libs/libstdc++-v3:5[multilib] )
+ >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]"
+
+game_dest="${GAMES_PREFIX_OPT}/${MY_PN}"
+QA_PREBUILT="${game_dest:1}/Barbarian"
+
+S=${WORKDIR}
+
+src_install() {
+ dodir "${game_dest}"
+ cp -r gfx sounds "${D}${game_dest}/" || die
+
+ exeinto "${game_dest}"
+ doexe Barbarian
+
+ dohtml Barbarian.html
+
+ games_make_wrapper barbarian ./Barbarian "${game_dest}"
+
+ # High-score file
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}${GAMES_STATEDIR}/heroes.hoh"
+ fperms 660 "${GAMES_STATEDIR}/heroes.hoh"
+ dosym "${GAMES_STATEDIR}/heroes.hoh" "${game_dest}/heroes.hoh"
+ newicon gfx/sprites/player_attack_2_1.bmp barbarian.bmp
+ make_desktop_entry barbarian "Barbarian" /usr/share/pixmaps/barbarian.bmp
+ prepgamesdirs
+}
diff --git a/games-arcade/barbarian-bin/metadata.xml b/games-arcade/barbarian-bin/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/barbarian-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>