summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/cockatrice
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/cockatrice')
-rw-r--r--games-board/cockatrice/Manifest1
-rw-r--r--games-board/cockatrice/cockatrice-20120702.ebuild72
-rw-r--r--games-board/cockatrice/files/cockatrice-20120702-build.patch103
-rw-r--r--games-board/cockatrice/files/cockatrice-20120702-underlinking.patch29
-rw-r--r--games-board/cockatrice/metadata.xml29
5 files changed, 234 insertions, 0 deletions
diff --git a/games-board/cockatrice/Manifest b/games-board/cockatrice/Manifest
new file mode 100644
index 000000000000..12a95c416022
--- /dev/null
+++ b/games-board/cockatrice/Manifest
@@ -0,0 +1 @@
+DIST cockatrice_source_20120702.tar.gz 3790304 SHA256 a418124d3df255f2af70a20ff6b13f85361467abe4ea4216602bd3647cfc490e SHA512 119acd394dfe97de72b0be8d1ea8c6178f9d0150dcb50d1aba074c28c8d0f52f2be5758ac3943c49d11f655f02a70fc5f5a7e207b8a2631f73f7178ff17b5c35 WHIRLPOOL 1e5112519ddd0f4107778c97d4cf415959117d7e5854ad9760d50621a77a53d992678470772358c880e89ba35376cbf6abab4687969810c117d2851eae4ec70a
diff --git a/games-board/cockatrice/cockatrice-20120702.ebuild b/games-board/cockatrice/cockatrice-20120702.ebuild
new file mode 100644
index 000000000000..8664e2cabdbc
--- /dev/null
+++ b/games-board/cockatrice/cockatrice-20120702.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils eutils gnome2-utils games
+
+DESCRIPTION="An open-source multiplatform software for playing card games over a network"
+HOMEPAGE="http://cockatrice.de/"
+SRC_URI="http://cockatrice.de/files/${PN}_source_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dedicated server"
+
+DEPEND="
+ dev-libs/libgcrypt:0
+ dev-libs/protobuf
+ dev-qt/qtcore:4
+ dev-qt/qtsql:4
+ !dedicated? (
+ dev-qt/qtmultimedia:4
+ dev-qt/qtsvg:4
+ dev-qt/qtgui:4
+ )"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-underlinking.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(usex dedicated "-DWITHOUT_CLIENT=1 -DWITH_SERVER=1" "$(usex server "-DWITH_SERVER=1" "")")
+ -DCMAKE_INSTALL_BINDIR="${GAMES_BINDIR}"
+ -DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}"
+ -DDATADIR="${GAMES_DATADIR}/${PN}"
+ -DICONDIR="/usr/share/icons"
+ -DDESKTOPDIR="/usr/share/applications"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ use dedicated || gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "zonebg pictures are in ${GAMES_DATADIR}/${PN}/zonebg"
+ elog "sounds are in ${GAMES_DATADIR}/${PN}/sounds"
+ elog "you can use those directories in cockatrice settings"
+ use dedicated || gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use dedicated || gnome2_icon_cache_update
+}
diff --git a/games-board/cockatrice/files/cockatrice-20120702-build.patch b/games-board/cockatrice/files/cockatrice-20120702-build.patch
new file mode 100644
index 000000000000..6876fcd78d42
--- /dev/null
+++ b/games-board/cockatrice/files/cockatrice-20120702-build.patch
@@ -0,0 +1,103 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Aug 2 21:27:25 UTC 2012
+Subject: build system
+
+add install rule for cockatrice binary
+make paths for ICONDIR and DESKTOPDIR modifiable
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -8,7 +8,9 @@
+ add_subdirectory(oracle)
+ endif(NOT WITHOUT_CLIENT)
+
++set(DATADIR "share/cockatrice" CACHE PATH "Data dir")
++
+ FILE(GLOB sounds "${CMAKE_CURRENT_SOURCE_DIR}/sounds/*.raw")
+-INSTALL(FILES ${sounds} DESTINATION share/cockatrice/sounds)
++INSTALL(FILES ${sounds} DESTINATION ${DATADIR}/sounds)
+ FILE(GLOB zonebg "${CMAKE_CURRENT_SOURCE_DIR}/zonebg/*.*")
+-INSTALL(FILES ${zonebg} DESTINATION share/cockatrice/zonebg)
+\ No newline at end of file
++INSTALL(FILES ${zonebg} DESTINATION ${DATADIR}/zonebg)
+--- servatrice/CMakeLists.txt
++++ servatrice/CMakeLists.txt
+@@ -2,6 +2,9 @@
+ SET(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR})
+ PROJECT(servatrice)
+
++# cmake modules
++include(GNUInstallDirs)
++
+ SET(servatrice_SOURCES
+ src/main.cpp
+ src/passwordhasher.cpp
+@@ -51,3 +54,5 @@
+ COMMAND ${CMAKE_COMMAND} -DSOURCE_DIR=${CMAKE_CURRENT_SOURCE_DIR} -P ${CMAKE_CURRENT_SOURCE_DIR}/../common/getversion.cmake
+ )
+
++# install rules
++INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/servatrice DESTINATION ${CMAKE_INSTALL_BINDIR})
+--- cockatrice/CMakeLists.txt
++++ cockatrice/CMakeLists.txt
+@@ -158,7 +158,13 @@
+ )
+
+ if (UNIX AND NOT APPLE)
+- set_source_files_properties(src/main.cpp PROPERTIES COMPILE_FLAGS -DTRANSLATION_PATH=\\"${CMAKE_INSTALL_PREFIX}/share/cockatrice/translations\\")
++ if(IS_ABSOLUTE ${DATADIR})
++ set(_DATADIR ${DATADIR})
++ else()
++ set(_DATADIR ${CMAKE_INSTALL_PREFIX}/${DATADIR})
++ endif()
++
++ set_source_files_properties(src/main.cpp PROPERTIES COMPILE_FLAGS -DTRANSLATION_PATH=\\"${_DATADIR}/translations\\")
+ endif (UNIX AND NOT APPLE)
+
+ set(cockatrice_RESOURCES cockatrice.qrc)
+@@ -201,6 +207,11 @@
+ set(CMAKE_CXX_FLAGS_DEBUG "-ggdb -O0")
+ set(CMAKE_CXX_FLAGS_RELEASE "-s -O2")
+
++# paths
++set(ICONDIR share/icons CACHE STRING "icon dir")
++set(DESKTOPDIR share/applications CACHE STRING "desktop file destination")
++
++
+ QT4_WRAP_CPP(cockatrice_HEADERS_MOC ${cockatrice_HEADERS})
+ QT4_ADD_TRANSLATION(cockatrice_QM ${cockatrice_TS})
+ QT4_ADD_RESOURCES(cockatrice_RESOURCES_RCC ${cockatrice_RESOURCES})
+@@ -218,10 +229,10 @@
+
+ INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/cockatrice DESTINATION bin)
+ if (NOT WIN32 AND NOT APPLE)
+- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/resources/cockatrice.png DESTINATION share/icons/hicolor/48x48/apps)
+- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/resources/cockatrice.svg DESTINATION share/icons/hicolor/scalable/apps)
+- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/cockatrice.desktop DESTINATION share/applications)
+- INSTALL(FILES ${cockatrice_QM} DESTINATION share/cockatrice/translations)
++ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/resources/cockatrice.png DESTINATION ${ICONDIR}/hicolor/48x48/apps)
++ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/resources/cockatrice.svg DESTINATION ${ICONDIR}/hicolor/scalable/apps)
++ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/cockatrice.desktop DESTINATION ${DESKTOPDIR})
++ INSTALL(FILES ${cockatrice_QM} DESTINATION ${DATADIR}/translations)
+ ENDIF(NOT WIN32 AND NOT APPLE)
+
+ add_custom_command(
+--- oracle/CMakeLists.txt
++++ oracle/CMakeLists.txt
+@@ -1,6 +1,9 @@
+ CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+ PROJECT(oracle)
+
++# paths
++set(DESKTOPDIR share/appliactions CACHE STRING "path to .desktop files")
++
+ SET(oracle_SOURCES src/main.cpp src/oracleimporter.cpp src/window_main.cpp ../cockatrice/src/carddatabase.cpp ../cockatrice/src/settingscache.cpp)
+ SET(oracle_HEADERS src/oracleimporter.h src/window_main.h ../cockatrice/src/carddatabase.h ../cockatrice/src/settingscache.h)
+
+@@ -21,5 +24,5 @@
+
+ INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/oracle DESTINATION bin)
+ IF (NOT WIN32 AND NOT APPLE)
+- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/oracle.desktop DESTINATION share/applications)
++ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/oracle.desktop DESTINATION ${DESKTOPDIR})
+ ENDIF (NOT WIN32 AND NOT APPLE)
diff --git a/games-board/cockatrice/files/cockatrice-20120702-underlinking.patch b/games-board/cockatrice/files/cockatrice-20120702-underlinking.patch
new file mode 100644
index 000000000000..2117751c1cf5
--- /dev/null
+++ b/games-board/cockatrice/files/cockatrice-20120702-underlinking.patch
@@ -0,0 +1,29 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Aug 2 22:12:00 UTC 2012
+Subject: underlinking
+
+add -lpthread to cockatrice amd servatrice LIBS to support linkers that
+don't permit underlinking
+
+--- cockatrice/CMakeLists.txt
++++ cockatrice/CMakeLists.txt
+@@ -219,7 +219,7 @@
+ INCLUDE_DIRECTORIES(${QT_MOBILITY_MULTIMEDIAKIT_INCLUDE_DIR})
+
+ ADD_EXECUTABLE(cockatrice WIN32 MACOSX_BUNDLE ${cockatrice_SOURCES} ${cockatrice_QM} ${cockatrice_RESOURCES_RCC} ${cockatrice_HEADERS_MOC})
+-TARGET_LINK_LIBRARIES(cockatrice cockatrice_common ${QT_LIBRARIES} ${QT_MOBILITY_MULTIMEDIAKIT_LIBRARY})
++TARGET_LINK_LIBRARIES(cockatrice cockatrice_common ${QT_LIBRARIES} ${QT_MOBILITY_MULTIMEDIAKIT_LIBRARY} -lpthread)
+
+ INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/cockatrice DESTINATION bin)
+ if (NOT WIN32 AND NOT APPLE)
+--- servatrice/CMakeLists.txt
++++ servatrice/CMakeLists.txt
+@@ -46,7 +46,7 @@
+ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
+
+ ADD_EXECUTABLE(servatrice ${servatrice_SOURCES} ${servatrice_HEADERS_MOC})
+-TARGET_LINK_LIBRARIES(servatrice cockatrice_common ${QT_LIBRARIES} ${LIBGCRYPT_LIBRARY})
++TARGET_LINK_LIBRARIES(servatrice cockatrice_common ${QT_LIBRARIES} ${LIBGCRYPT_LIBRARY} -lpthread)
+
+ #add_custom_target(versionheader ALL DEPENDS version_header)
+ add_custom_command(
diff --git a/games-board/cockatrice/metadata.xml b/games-board/cockatrice/metadata.xml
new file mode 100644
index 000000000000..34eddf8911c1
--- /dev/null
+++ b/games-board/cockatrice/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ <name>Diego Elio Pettenò</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>brukie@gmx.net</email>
+ <name>Max-Wilhelm Bruker</name>
+ </maintainer>
+ <changelog>https://github.com/mbruker/Cockatrice/commits/master</changelog>
+ <doc lang="en">http://cockatrice.de/dokuwiki/doku.php</doc>
+ <bugs-to>https://github.com/mbruker/Cockatrice/issues</bugs-to>
+ </upstream>
+ <use>
+ <flag name='server'>Compile server support</flag>
+ </use>
+ <longdescription lang="en">
+ Cockatrice is an open-source multiplatform software for playing card
+ games, such as Magic: The Gathering, over a network. It is fully
+ client-server based to prevent any kind of cheating, though it supports
+ single-player games without a network interface as well. Both client
+ and server are written in Qt 4.
+ </longdescription>
+</pkgmetadata>
+