summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/simutrans
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/simutrans')
-rw-r--r--games-simulation/simutrans/Manifest2
-rw-r--r--games-simulation/simutrans/files/simutrans-0.120.0.1-Makefile.patch89
-rw-r--r--games-simulation/simutrans/metadata.xml8
-rw-r--r--games-simulation/simutrans/simutrans-0.120.0.1.ebuild54
4 files changed, 153 insertions, 0 deletions
diff --git a/games-simulation/simutrans/Manifest b/games-simulation/simutrans/Manifest
new file mode 100644
index 000000000000..03971e08e63b
--- /dev/null
+++ b/games-simulation/simutrans/Manifest
@@ -0,0 +1,2 @@
+DIST simupak64-120-0-1.zip 4051769 SHA256 02a709dfa4b0c22e0b463ebcbd9684548356de1c61566cff9c127a79990dbb78 SHA512 21badd251b9018bef55531923e23cb1935c3831784fab028febd3879384330e843329499ab08a08e71238fb92bf7db36e18ecbbc4e719a942e427f58fc634afc WHIRLPOOL 5ae84653b5a138b5a987b7ca6512994f3ba8dff48fffbb94f6fe0bf4845d5537e93734f73174eb328f20b6c9986235ae6c461c55b5efde53a4b81620a3b1da83
+DIST simutrans-src-120-0-1.zip 3909005 SHA256 010a6e3765891e1821364e54f6bcdfb2911b627ffca3acae8350e06e53113683 SHA512 6f32b6f1c12f45125de8a12c4a034387a784e21fd8cdedcf7b1daefd9174d9a94825e8f68effa2ff1436cce2e2bc8cb5707161f3fa004185ae158400840dc450 WHIRLPOOL 36155184f5806a9cfab742f26e3fc78d5d7d928f99cddabbaf36c7c90d065dab02bb174c07d9633958f8b891b0db8cc5c94e45fd4f22d917b9a037c51a99b69a
diff --git a/games-simulation/simutrans/files/simutrans-0.120.0.1-Makefile.patch b/games-simulation/simutrans/files/simutrans-0.120.0.1-Makefile.patch
new file mode 100644
index 000000000000..d1ff41f33feb
--- /dev/null
+++ b/games-simulation/simutrans/files/simutrans-0.120.0.1-Makefile.patch
@@ -0,0 +1,89 @@
+--- Makefile.orig
++++ Makefile
+@@ -81,8 +81,6 @@
+ ifeq ($(findstring $(OSTYPE), amiga haiku mac),)
+ CFLAGS += -minline-all-stringops
+ endif
+-else
+- CFLAGS += -O
+ endif
+
+ ifdef DEBUG
+@@ -101,6 +99,7 @@
+ endif
+ else
+ CFLAGS += -DNDEBUG
++ CXXFLAGS += -DNDEBUG
+ endif
+
+ ifneq ($(PROFILE),)
+@@ -114,6 +113,7 @@
+ ifneq ($(MULTI_THREAD),)
+ ifeq ($(shell expr $(MULTI_THREAD) \>= 1), 1)
+ CFLAGS += -DMULTI_THREAD
++ CXXFLAGS += -DMULTI_THREAD
+ ifeq ($(OSTYPE),mingw)
+ #use lpthreadGC2d for debug alternatively
+ LDFLAGS += -lpthreadGC2
+@@ -132,11 +132,13 @@
+ endif
+ ifneq ($(REV),)
+ CFLAGS += -DREVISION="$(REV)"
++ CXXFLAGS += -DREVISION="$(REV)"
+ endif
+ endif
+ endif
+
+ CFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
++CXXFLAGS += -Wall -W -Wcast-qual -Wpointer-arith -Wcast-align $(FLAGS)
+ CCFLAGS += -Wstrict-prototypes
+
+
+@@ -492,6 +494,7 @@
+ SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS)
+ endif
+
+@@ -523,6 +526,7 @@
+ SDL_LDFLAGS := $(shell $(SDL2_CONFIG) --libs)
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS)
+ endif
+
+@@ -538,6 +542,7 @@
+ SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS) -lSDL_mixer
+ endif
+
+@@ -564,6 +569,7 @@
+ SDL_LDFLAGS := $(shell $(SDL_CONFIG) --libs)
+ endif
+ CFLAGS += $(SDL_CFLAGS)
++ CXXFLAGS += $(SDL_CFLAGS)
+ LIBS += $(SDL_LDFLAGS) -lglew32
+ ifeq ($(OSTYPE),mingw)
+ LIBS += -lopengl32
+@@ -579,6 +585,7 @@
+ endif
+
+ CFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
++CXXFLAGS += -DCOLOUR_DEPTH=$(COLOUR_DEPTH)
+
+ ifneq ($(findstring $(OSTYPE), cygwin mingw),)
+ SOURCES += simres.rc
+@@ -586,7 +593,6 @@
+ endif
+
+ CCFLAGS += $(CFLAGS)
+-CXXFLAGS += $(CFLAGS)
+
+ BUILDDIR ?= build/$(CFG)
+ PROGDIR ?= $(BUILDDIR)
diff --git a/games-simulation/simutrans/metadata.xml b/games-simulation/simutrans/metadata.xml
new file mode 100644
index 000000000000..72ba0c97685e
--- /dev/null
+++ b/games-simulation/simutrans/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">simutrans</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-simulation/simutrans/simutrans-0.120.0.1.ebuild b/games-simulation/simutrans/simutrans-0.120.0.1.ebuild
new file mode 100644
index 000000000000..ffd446d6df6f
--- /dev/null
+++ b/games-simulation/simutrans/simutrans-0.120.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils games
+
+MY_PV=${PV/0./}
+MY_PV=${MY_PV//./-}
+DESCRIPTION="A free Transport Tycoon clone"
+HOMEPAGE="http://www.simutrans.com/"
+SRC_URI="mirror://sourceforge/simutrans/simutrans-src-${MY_PV}.zip
+ mirror://sourceforge/simutrans/simupak64-${MY_PV}.zip"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[sound,video]
+ sys-libs/zlib
+ app-arch/bzip2
+ media-libs/libpng:0
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ strip-flags # bug #293927
+ echo "BACKEND=mixer_sdl
+COLOUR_DEPTH=16
+OSTYPE=linux
+VERBOSE=1" > config.default || die
+
+ # make it look in the install location for the data
+ sed -i \
+ -e "s:argv\[0\]:\"${GAMES_DATADIR}/${PN}/\":" \
+ simmain.cc || die
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ rm -f simutrans/{simutrans,*.txt}
+}
+
+src_install() {
+ newgamesbin build/default/sim ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r simutrans/*
+ dodoc documentation/*
+ doicon simutrans.ico
+ make_desktop_entry simutrans Simutrans /usr/share/pixmaps/simutrans.ico
+ prepgamesdirs
+}