summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-16 08:45:34 +0100
committerSam James <sam@gentoo.org>2024-07-16 08:45:34 +0100
commit29e6638615c6ae297d0af887b7644e76a766fd1a (patch)
tree8d07ded79a812175cb54241a0839d89828f0ce27 /games-util
parentmedia-sound/supercollider: fix build w/ boost-1.85 (diff)
downloadgentoo-29e6638615c6ae297d0af887b7644e76a766fd1a.tar.gz
gentoo-29e6638615c6ae297d0af887b7644e76a766fd1a.tar.bz2
gentoo-29e6638615c6ae297d0af887b7644e76a766fd1a.zip
games-util/xboxdrv: fix build w/ boost-1.85
Thanks to Bugs Bugs for the patch on the bug. It's kind of a stub but it's only for a debug message so not so bad until we can package the fork mentioned in the bug. Closes: https://bugs.gentoo.org/932747 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.8-boost-1.85.patch12
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8_p20190118-r3.ebuild7
2 files changed, 16 insertions, 3 deletions
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.8-boost-1.85.patch b/games-util/xboxdrv/files/xboxdrv-0.8.8-boost-1.85.patch
new file mode 100644
index 000000000000..77e910ababa3
--- /dev/null
+++ b/games-util/xboxdrv/files/xboxdrv-0.8.8-boost-1.85.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/932747#c4
+--- a/src/controller.cpp
++++ b/src/controller.cpp
+@@ -98,7 +98,7 @@ Controller::set_active(bool v)
+ {
+ if (m_is_active != v)
+ {
+- log_debug("activation status: " << v << " " << m_activation_cb);
++ log_debug("activation status: " << v << " " << "unknown");
+ m_is_active = v;
+ if (m_activation_cb)
+ {
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8_p20190118-r3.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118-r3.ebuild
index 45fe2ace917b..4a0f4935dcc0 100644
--- a/games-util/xboxdrv/xboxdrv-0.8.8_p20190118-r3.ebuild
+++ b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118-r3.ebuild
@@ -37,9 +37,10 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}/"xboxdrv-0.8.8-some-boost-fix.patch
- "${FILESDIR}/"xboxdrv-0.8.8-Update-SConstruct-to-python3.patch
- "${FILESDIR}/"xboxdrv-0.8.8-Updating-python-code-to-python3.patch
+ "${FILESDIR}/xboxdrv-0.8.8-some-boost-fix.patch"
+ "${FILESDIR}/xboxdrv-0.8.8-Update-SConstruct-to-python3.patch"
+ "${FILESDIR}/xboxdrv-0.8.8-Updating-python-code-to-python3.patch"
+ "${FILESDIR}/xboxdrv-0.8.8-boost-1.85.patch"
)
CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"