summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-31 20:49:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-01 22:17:20 +0100
commit258817baa9925324d0d1783ae289b1c2c8ecc1da (patch)
tree8b59c0fe03a44a0fbe5da963f5205858dae71781 /kde-frameworks/purpose
parentkde-frameworks/kxmlgui: 5.249.0 version bump (diff)
downloadgentoo-258817baa9925324d0d1783ae289b1c2c8ecc1da.tar.gz
gentoo-258817baa9925324d0d1783ae289b1c2c8ecc1da.tar.bz2
gentoo-258817baa9925324d0d1783ae289b1c2c8ecc1da.zip
kde-frameworks/purpose: 5.249.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.249.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index e9076790bd4c..626bcaf9dd23 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,3 +1,4 @@
DIST purpose-5.113.0.tar.xz 179544 BLAKE2B 9c9cf7d17f2c8b270f23052553796ea7403260bab11186ff846d840503efc9ae5fdc1d70730605584f7f14ea1aa9f7258864458f2b813b4ed7e01a466f818bbd SHA512 df7f2b3164caa474100731eb360318c2a6bb8301aeb0729fab3824d95f123ece00e74032c2533ce477c92717c116404ed56f7c320320557c29a5036ecf135f7e
DIST purpose-5.114.0.tar.xz 179776 BLAKE2B 19cbc2744ef9e40a53aef90da9511c9d7a342f35b95e3ff0c8a090fdbaa84c44de94c71ff81c8d40e05dfbf52191d3a9440c54c3e1a12f6f11391d693fbfac81 SHA512 f56be72e5690da06e35cf339b9d45030f651cf1312a7e1ced850dcc137b06f5227533fa1276e4458fac22d3ff8ffef61d503732ce95957e9ea98cdac6916120f
DIST purpose-5.248.0.tar.xz 174628 BLAKE2B f544f5307b5a8af755af47836724cb0c70ce075666bab29129cd22649da651e1d2a33a1b6b1488d1897efb444bcdd59c45dbac7f44eabdb0bf63eaa7c8c07493 SHA512 e043091e8d628d7e8b274184bd18de06a7d78aab463c553191c580fd897d7e991c848ef16b96ab25879dd64f2b3bc8ee6d9b60c34b3c7c94714fef77649cdae8
+DIST purpose-5.249.0.tar.xz 174540 BLAKE2B 4f43501631161b23f8e64c3b42ff839b64f4fb618e03c5fa20c4cb2bd26271b6113bee803d57cb4c1bbecbc0e2e000963581ba872c226ecde8d02a96192df405 SHA512 9efa22bbd12297c082ab697202980c586b32d11276b8d682176385a654177f9def23e6ea227da6f43a1b45e10da04cedc323f5039d75694de4201c9fcdd1c527
diff --git a/kde-frameworks/purpose/purpose-5.249.0.ebuild b/kde-frameworks/purpose/purpose-5.249.0.ebuild
new file mode 100644
index 000000000000..7b5b624383dd
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.249.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.0
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="bluetooth kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kio-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/prison-${PVCUT}*:6
+ kaccounts? (
+ kde-apps/kaccounts-integration:6
+ >=net-libs/accounts-qt-1.16_p20220803[qt6]
+ )
+"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5[-kf6compat(-)]
+ >=kde-frameworks/kdeclarative-${PVCUT}:6
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:6 )
+ kaccounts? ( >=net-libs/accounts-qml-0.7_p20231028[qt6] )
+"
+BDEPEND="kaccounts? ( dev-util/intltool )"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts6)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}