summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-24 11:09:38 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-24 11:33:43 -0400
commite9442312b1c8be8a28f2c96a7f65a9bc69d737c6 (patch)
treeeb0ead57fc8583803ea4c714cae36943eb521aa9 /media-gfx
parentmedia-gfx/eog: Version bump to 43.0 (diff)
downloadgentoo-e9442312b1c8be8a28f2c96a7f65a9bc69d737c6.tar.gz
gentoo-e9442312b1c8be8a28f2c96a7f65a9bc69d737c6.tar.bz2
gentoo-e9442312b1c8be8a28f2c96a7f65a9bc69d737c6.zip
media-gfx/eog-plugins: Version bump to 42.2
Closes: https://bugs.gentoo.org/858089 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-42.2.ebuild78
-rw-r--r--media-gfx/eog-plugins/files/42.2-build-Use-correct-variables.patch79
3 files changed, 158 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 0a0dc370d04d..3467a3748b47 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1 +1,2 @@
DIST eog-plugins-42.1.tar.xz 131656 BLAKE2B e561e7b31daf950c1e1c1e1038bf40101b658583160439f7fd9050b52da2f6dd943105e1e1eeaefff7ed2aa759f8b96aad0a65130daba038733967db37158bfc SHA512 4688cb9cce044137717521a3ff2f769f960f12ec8b3f711971f276334f91915c8a3142aff2feb3d24d2eeb86223f040e9b699a1136e7fc7e96202a06b1cda1a8
+DIST eog-plugins-42.2.tar.xz 131708 BLAKE2B 7df06ca7d4d10e068b6d758ec3c29fe8cb7a2037755bab55536f1cd3581790f7a1288a9530f256df3d2adbf6d7f8c893907fa962be8adb77510cab8e9684298c SHA512 7508231c1a6b365acfedd73b37911d5ac4194e6b5c4f5d80be27529ec749774d61ddc75288f8678d879f0cc2d9117a5f725092efe30403b5b3e145c77fa3030d
diff --git a/media-gfx/eog-plugins/eog-plugins-42.2.ebuild b/media-gfx/eog-plugins/eog-plugins-42.2.ebuild
new file mode 100644
index 000000000000..7bbd98c06f65
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-42.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins https://gitlab.gnome.org/GNOME/eog-plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-1.14.1:=
+ >=media-gfx/eog-41.0
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/glib[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/appstream-glib )"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-build-Use-correct-variables.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif plugin_exif-display)
+ $(meson_use python plugin_export-to-folder)
+ -Dplugin_fit-to-width=true
+ $(meson_use python plugin_fullscreenbg)
+ -Dplugin_light-theme=true
+ $(meson_use map plugin_map)
+ $(meson_use python plugin_maximize-windows)
+ $(meson_use picasa plugin_postasa)
+ -Dplugin_postr=false
+ $(meson_use python plugin_pythonconsole)
+ -Dplugin_send-by-mail=true
+ $(meson_use python plugin_slideshowshuffle)
+ )
+ meson_src_configure
+}
diff --git a/media-gfx/eog-plugins/files/42.2-build-Use-correct-variables.patch b/media-gfx/eog-plugins/files/42.2-build-Use-correct-variables.patch
new file mode 100644
index 000000000000..5bf08c190392
--- /dev/null
+++ b/media-gfx/eog-plugins/files/42.2-build-Use-correct-variables.patch
@@ -0,0 +1,79 @@
+https://gitlab.gnome.org/GNOME/eog-plugins/-/merge_requests/8
+
+From 00d734931a911e072c22b60028f361ee3f6cad14 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Sat, 24 Sep 2022 11:25:25 -0400
+Subject: [PATCH] build: Use correct variables
+
+Bug: https://bugs.gentoo.org/858089
+---
+ plugins/fit-to-width/meson.build | 2 +-
+ plugins/light-theme/meson.build | 2 +-
+ plugins/map/meson.build | 4 ++--
+ plugins/send-by-mail/meson.build | 2 +-
+ 4 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/plugins/fit-to-width/meson.build b/plugins/fit-to-width/meson.build
+index 37732d1..e9654c0 100644
+--- a/plugins/fit-to-width/meson.build
++++ b/plugins/fit-to-width/meson.build
+@@ -46,7 +46,7 @@ if appstream_util.found()
+ args: [
+ 'validate',
+ '--nonet',
+- exifdisplay_appdata.full_path(),
++ fittowidth_appdata.full_path(),
+ ]
+ )
+ endif
+diff --git a/plugins/light-theme/meson.build b/plugins/light-theme/meson.build
+index 044b08a..fb86cdc 100644
+--- a/plugins/light-theme/meson.build
++++ b/plugins/light-theme/meson.build
+@@ -46,7 +46,7 @@ if appstream_util.found()
+ args: [
+ 'validate',
+ '--nonet',
+- exifdisplay_appdata.full_path(),
++ lighttheme_appdata.full_path(),
+ ]
+ )
+ endif
+diff --git a/plugins/map/meson.build b/plugins/map/meson.build
+index d969e96..c8f5c41 100644
+--- a/plugins/map/meson.build
++++ b/plugins/map/meson.build
+@@ -36,7 +36,7 @@ i18n.merge_file(
+ install_dir: pluginlibdir,
+ )
+
+-exifdisplay_appdata = i18n.merge_file(
++map_appdata = i18n.merge_file(
+ input: 'eog-map.appdata.xml.in',
+ output: '@BASENAME@',
+ po_dir: src_root / 'po',
+@@ -52,7 +52,7 @@ if appstream_util.found()
+ args: [
+ 'validate',
+ '--nonet',
+- exifdisplay_appdata.full_path(),
++ map_appdata.full_path(),
+ ]
+ )
+ endif
+diff --git a/plugins/send-by-mail/meson.build b/plugins/send-by-mail/meson.build
+index f7eb0fb..7bba7a1 100644
+--- a/plugins/send-by-mail/meson.build
++++ b/plugins/send-by-mail/meson.build
+@@ -47,7 +47,7 @@ if appstream_util.found()
+ args: [
+ 'validate',
+ '--nonet',
+- exifdisplay_appdata.full_path(),
++ sendbymail_appdata.full_path(),
+ ]
+ )
+ endif
+--
+2.35.1
+