summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-22 16:42:14 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-22 17:32:14 +0000
commit4906ebc5a0e9377426f0f73b83a539bdc4c9c753 (patch)
treea9939c9bcb4e7c869c4dd1dab666f3f4423da3b4 /media-video
parentmedia-libs/libsdl2: Bump to version 2.0.14 (diff)
downloadgentoo-4906ebc5a0e9377426f0f73b83a539bdc4c9c753.tar.gz
gentoo-4906ebc5a0e9377426f0f73b83a539bdc4c9c753.tar.bz2
gentoo-4906ebc5a0e9377426f0f73b83a539bdc4c9c753.zip
media-video/obs-studio: migrate to lua-single.eclass
Based on the work of Gergely Nagy <ngg@ngg.hu> from https://github.com/gentoo/gentoo/pull/18156, however browser source support has been removed (according to the PR comments chiitoo has not decided yet which of the competing implementations he prefers) and IUSE=luajit has been renamed to just "lua" (as done elsewhere, in order to avoid confusion between luajit and lua_single_target_luajit). Closes: https://bugs.gentoo.org/752768 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/obs-studio/obs-studio-25.0.8-r100.ebuild154
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild25
2 files changed, 169 insertions, 10 deletions
diff --git a/media-video/obs-studio/obs-studio-25.0.8-r100.ebuild b/media-video/obs-studio/obs-studio-25.0.8-r100.ebuild
new file mode 100644
index 000000000000..4651e60274e9
--- /dev/null
+++ b/media-video/obs-studio/obs-studio-25.0.8-r100.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+LUA_COMPAT=( luajit )
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit cmake lua-single python-single-r1 xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/obsproject/obs-studio.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/obsproject/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Software for Recording and Streaming Live Video Content"
+HOMEPAGE="https://obsproject.com"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa fdk imagemagick jack lua nvenc pulseaudio python speex +ssl truetype v4l vlc"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+BDEPEND="
+ lua? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+"
+DEPEND="
+ >=dev-libs/jansson-2.5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ media-libs/x264:=
+ media-video/ffmpeg:=[x264]
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib
+ virtual/udev
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ alsa? ( media-libs/alsa-lib )
+ fdk? ( media-libs/fdk-aac:= )
+ imagemagick? ( media-gfx/imagemagick:= )
+ jack? ( virtual/jack )
+ lua? ( ${LUA_DEPS} )
+ nvenc? ( >=media-video/ffmpeg-4[video_cards_nvidia] )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? ( ${PYTHON_DEPS} )
+ speex? ( media-libs/speexdsp )
+ ssl? ( net-libs/mbedtls:= )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype
+ )
+ v4l? ( media-libs/libv4l )
+ vlc? ( media-video/vlc:= )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-25.0.8-gcc-10-build.patch" )
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DDISABLE_ALSA=$(usex !alsa)
+ -DDISABLE_FREETYPE=$(usex !truetype)
+ -DDISABLE_JACK=$(usex !jack)
+ -DDISABLE_LIBFDK=$(usex !fdk)
+ -DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
+ -DDISABLE_SPEEXDSP=$(usex !speex)
+ -DDISABLE_V4L2=$(usex !v4l)
+ -DDISABLE_VLC=$(usex !vlc)
+ -DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
+ -DOBS_MULTIARCH_SUFFIX=${libdir#lib}
+ -DUNIX_STRUCTURE=1
+ -DWITH_RTMPS=$(usex ssl)
+ )
+
+ if [[ ${PV} != *9999 ]]; then
+ mycmakeargs+=(
+ -DOBS_VERSION_OVERRIDE=${PV}
+ )
+ fi
+
+ if use lua || use python; then
+ mycmakeargs+=(
+ -DDISABLE_LUA=$(usex !lua)
+ -DDISABLE_PYTHON=$(usex !python)
+ -DENABLE_SCRIPTING=yes
+ )
+ else
+ mycmakeargs+=( -DENABLE_SCRIPTING=no )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ #external plugins may need some things not installed by default, install them here
+ insinto /usr/include/obs/UI/obs-frontend-api
+ doins UI/obs-frontend-api/obs-frontend-api.h
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ if ! use alsa && ! use pulseaudio; then
+ elog
+ elog "For the audio capture features to be available,"
+ elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
+ elog "be enabled."
+ elog
+ fi
+
+ if ! has_version "sys-apps/dbus"; then
+ elog
+ elog "The 'sys-apps/dbus' package is not installed, but"
+ elog "could be used for disabling hibernating, screensaving,"
+ elog "and sleeping. Where it is not installed,"
+ elog "'xdg-screensaver reset' is used instead"
+ elog "(if 'x11-misc/xdg-utils' is installed)."
+ elog
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index c8ccd0308e53..47cfd612079b 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -4,9 +4,10 @@
EAPI=7
CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+LUA_COMPAT=( luajit )
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-single-r1 xdg-utils
+inherit cmake lua-single python-single-r1 xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -22,11 +23,14 @@ HOMEPAGE="https://obsproject.com"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex +ssl truetype v4l vlc"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="+alsa fdk imagemagick jack lua nvenc pulseaudio python speex +ssl truetype v4l vlc"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
BDEPEND="
- luajit? ( dev-lang/swig )
+ lua? ( dev-lang/swig )
python? ( dev-lang/swig )
"
DEPEND="
@@ -58,7 +62,7 @@ DEPEND="
fdk? ( media-libs/fdk-aac:= )
imagemagick? ( media-gfx/imagemagick:= )
jack? ( virtual/jack )
- luajit? ( dev-lang/luajit:2 )
+ lua? ( ${LUA_DEPS} )
nvenc? ( >=media-video/ffmpeg-4[video_cards_nvidia] )
pulseaudio? ( media-sound/pulseaudio )
python? ( ${PYTHON_DEPS} )
@@ -74,6 +78,7 @@ DEPEND="
RDEPEND="${DEPEND}"
pkg_setup() {
+ use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
}
@@ -94,15 +99,15 @@ src_configure() {
-DWITH_RTMPS=$(usex ssl)
)
- if [ "${PV}" != "9999" ]; then
+ if [[ ${PV} != *9999 ]]; then
mycmakeargs+=(
-DOBS_VERSION_OVERRIDE=${PV}
)
fi
- if use luajit || use python; then
+ if use lua || use python; then
mycmakeargs+=(
- -DDISABLE_LUA=$(usex !luajit)
+ -DDISABLE_LUA=$(usex !lua)
-DDISABLE_PYTHON=$(usex !python)
-DENABLE_SCRIPTING=yes
)
@@ -110,11 +115,11 @@ src_configure() {
mycmakeargs+=( -DENABLE_SCRIPTING=no )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
#external plugins may need some things not installed by default, install them here
insinto /usr/include/obs/UI/obs-frontend-api
doins UI/obs-frontend-api/obs-frontend-api.h