summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-05-09 11:33:15 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-09 11:35:59 +0200
commitb253f47698aeeeb58aa2fd3ccf00cdaa4e7bbd4b (patch)
tree0236c957a58c64bb8949b98b14ab67ce268cfad4 /net-analyzer/ospd-openvas
parentdev-lang/python-exec: Bump to 2.4.9 (diff)
downloadgentoo-b253f47698aeeeb58aa2fd3ccf00cdaa4e7bbd4b.tar.gz
gentoo-b253f47698aeeeb58aa2fd3ccf00cdaa4e7bbd4b.tar.bz2
gentoo-b253f47698aeeeb58aa2fd3ccf00cdaa4e7bbd4b.zip
net-analyzer/ospd-openvas: fix systemd service and conf location
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer/ospd-openvas')
-rw-r--r--net-analyzer/ospd-openvas/ospd-openvas-21.4.4-r3.ebuild (renamed from net-analyzer/ospd-openvas/ospd-openvas-21.4.4-r2.ebuild)9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-analyzer/ospd-openvas/ospd-openvas-21.4.4-r2.ebuild b/net-analyzer/ospd-openvas/ospd-openvas-21.4.4-r3.ebuild
index 83fcc3b84069..e6e08ba90a4d 100644
--- a/net-analyzer/ospd-openvas/ospd-openvas-21.4.4-r2.ebuild
+++ b/net-analyzer/ospd-openvas/ospd-openvas-21.4.4-r3.ebuild
@@ -39,6 +39,9 @@ src_prepare() {
# https://github.com/greenbone/ospd-openvas/pull/649
sed -i '/^Group=gvm/d' config/ospd-openvas.service || die
+
+ # https://github.com/greenbone/ospd-openvas/pull/653
+ sed -i 's;/usr/local/bin/;/usr/bin/;' config/ospd-openvas.service || die
}
python_compile() {
@@ -54,9 +57,11 @@ python_install() {
dodoc "${FILESDIR}"/redis.conf.example
- insinto /etc/openvas
+ insinto /etc/gvm
doins config/${PN}.conf
- fowners -R gvm:gvm /etc/openvas
+ if ! use prefix; then
+ fowners -R gvm:gvm /etc/gvm
+ fi
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
newconfd "${FILESDIR}/${PN}.confd" "${PN}"