summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-07 09:54:25 +0100
committerSam James <sam@gentoo.org>2023-06-07 10:09:20 +0100
commit8938df17c2987dc14bb153b06398a1ec2871f527 (patch)
tree94c2e7099f30c39d2270f3b6236882f850ee2fbb /net-analyzer
parenteapi8-dosym.eclass: Fix another corner case of strange input (diff)
downloadgentoo-8938df17c2987dc14bb153b06398a1ec2871f527.tar.gz
gentoo-8938df17c2987dc14bb153b06398a1ec2871f527.tar.bz2
gentoo-8938df17c2987dc14bb153b06398a1ec2871f527.zip
net-analyzer/sec: add 2.9.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sec/Manifest1
-rw-r--r--net-analyzer/sec/sec-2.9.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/sec/Manifest b/net-analyzer/sec/Manifest
index 3658065a2cdc..8f748aa1a964 100644
--- a/net-analyzer/sec/Manifest
+++ b/net-analyzer/sec/Manifest
@@ -1 +1,2 @@
DIST sec-2.9.1.tar.gz 153305 BLAKE2B 0bbc70f786badb24153f4f124aaedbf6f34970556630ee3e8763e7854dc1765d0eb8f7d10efce119ca936eade2af8064188f3372e63f7977240a0b10327269a3 SHA512 c6764cf660ad969d260e4993c38809580e448a9d941d1a763c1b70630c5d55a7f215feb6b0fa50cbf23d68fb442e34f0d270d03e1172850d63d64042a689ac90
+DIST sec-2.9.2.tar.gz 153482 BLAKE2B d2f099b034b2ab59b4abdea0d824fc63e2d340d56b4f43324e2e477e0f33b433b5f54e4172c873e1579b544504a2a5f1ba20a3c8468eab43e4587c9efc54446b SHA512 441c543f9abcfff46c5cd86c9be8fd5c57fef988519f2c9f431b715717e0500ce1b89365e16c0d3b6e76369cf5ee5f6d5318b32e4374c614ec0083833021f17c
diff --git a/net-analyzer/sec/sec-2.9.2.ebuild b/net-analyzer/sec/sec-2.9.2.ebuild
new file mode 100644
index 000000000000..e6658bf788e6
--- /dev/null
+++ b/net-analyzer/sec/sec-2.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple Event Correlator"
+HOMEPAGE="https://simple-evcorr.github.io/ https://github.com/simple-evcorr/sec"
+SRC_URI="https://github.com/simple-evcorr/sec/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+
+RDEPEND="
+ >=dev-lang/perl-5.8.0
+ virtual/perl-JSON-PP
+"
+
+src_install() {
+ dobin sec
+
+ dodoc ChangeLog README
+ docinto contrib
+ dodoc contrib/{itostream.c,convert.pl,swatch2sec.pl}
+
+ newman sec.man sec.1
+
+ newinitd "${FILESDIR}"/sec.init.d sec
+ newconfd "${FILESDIR}"/sec.conf.d sec
+}