summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-25 14:32:20 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-25 14:33:11 +0100
commit74800c3d91917043844287d83fd60e49b671b754 (patch)
tree8d46cfd0568a2fa86780f692ad66cb9cd9975316 /net-im/rocketchat-desktop-bin
parentdev-python/pytest-shell-utilities: Revert new package (diff)
downloadgentoo-74800c3d91917043844287d83fd60e49b671b754.tar.gz
gentoo-74800c3d91917043844287d83fd60e49b671b754.tar.bz2
gentoo-74800c3d91917043844287d83fd60e49b671b754.zip
net-im/rocketchat-desktop-bin: add version 3.7.8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im/rocketchat-desktop-bin')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.8.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 06dd6fd14b95..5f6d840a03df 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.7.7.x86_64.rpm 88749684 BLAKE2B 18e5f0cbd6a7dc7885f7a956a3ce8be6973c69120780fec96d1e12d9c4c25972d070b37d211947e744d3ca486d0117fe0754db232ad067b9a6f81a0185b44cff SHA512 3ebd78f20ae4a7a1458039f786444474f0fc52715f1238d5c1e806982d517d5582f963028f67abf279ba50f36212bb25e114346e4e8611a7546c61a17a3395a4
+DIST rocketchat-3.7.8.x86_64.rpm 72461320 BLAKE2B 33cd4dd39c966761fb79c09002247924d1d59490c75c41c5941b8ecbc0a4fc7f05e3210388bea06a502cc01416e026cdf3ea38c81fdfc7a743e6b22a7e6fd302 SHA512 13d529ee32c2945b77e45220568a290c74a15d99fb49f1c595a78d2acd91a16556ea73fced2667ddbee6a986bf57677e2a0fab82eb0723e8f62a49a0e990588e
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.8.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.8.ebuild
new file mode 100644
index 000000000000..194a95979a80
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.8.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}