summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2023-02-26 18:37:41 -0800
committerJoonas Niilola <juippis@gentoo.org>2023-03-08 15:43:45 +0200
commit38170f3850411e75ec88aa94ce2210f63ed3b6d0 (patch)
tree79c1573e32f628649f792801f697e659b35ed164 /net-irc
parentnet-irc/inspircd: drop 3.14.0-r1 (diff)
downloadgentoo-38170f3850411e75ec88aa94ce2210f63ed3b6d0.tar.gz
gentoo-38170f3850411e75ec88aa94ce2210f63ed3b6d0.tar.bz2
gentoo-38170f3850411e75ec88aa94ce2210f63ed3b6d0.zip
net-irc/atheme-services: Add 7.2.12-r4
Bug: https://bugs.gentoo.org/895470 Signed-off-by: Wade Cline <wadecline@hotmail.com> Closes: https://github.com/gentoo/gentoo/pull/29821 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/atheme-services/atheme-services-7.2.12-r4.ebuild92
-rw-r--r--net-irc/atheme-services/files/atheme-services.service15
2 files changed, 107 insertions, 0 deletions
diff --git a/net-irc/atheme-services/atheme-services-7.2.12-r4.ebuild b/net-irc/atheme-services/atheme-services-7.2.12-r4.ebuild
new file mode 100644
index 000000000000..1868e2015273
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-7.2.12-r4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-functions systemd
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="https://github.com/atheme/atheme"
+SRC_URI="https://github.com/atheme/atheme/releases/download/v${PV}/${PN}-v${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
+S="${WORKDIR}/${PN}-v${PV}"
+
+RDEPEND="
+ acct-group/atheme-services
+ acct-user/atheme-services
+ >=dev-libs/libmowgli-2.1.0:2
+ virtual/libcrypt:=
+ cracklib? ( sys-libs/cracklib )
+ ldap? ( net-nds/openldap:= )
+ perl? ( dev-lang/perl:= )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+# 'dev-vcs/git' required as per bug #665802
+BDEPEND="
+ dev-vcs/git
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.2.10_p2-configure-logdir.patch)
+
+src_configure() {
+ # perl scriping module support is also broken in 7.0.0. Yay for QA failures.
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --disable-warnings \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with cracklib) \
+ $(use_with ldap) \
+ $(use_enable nls) \
+ $(use_enable profile) \
+ $(use_with pcre) \
+ $(use_with perl) \
+ $(use_enable ssl)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ local confdest=${conf##*/}
+ newins ${conf} ${confdest%.example}
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ mv "${ED}"/usr/bin/{,atheme-}dbverify || die
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ # contributed scripts and such:
+ docinto contrib
+ dodoc contrib/*.{c,pl,php,py,rb}
+
+ use perl && perl_domodule -r contrib/Atheme{,.pm}
+
+ rm "${ED}/usr/share/doc/${PF}/WINDOWS" || die
+
+ # Bug #454840 #520490
+ rm -rf "${ED}/var/run" || die
+}
diff --git a/net-irc/atheme-services/files/atheme-services.service b/net-irc/atheme-services/files/atheme-services.service
new file mode 100644
index 000000000000..a552ead5b413
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Atheme IRC services
+After=network-online.target
+Wants=network-online.target
+
+[Service]
+RuntimeDirectory=atheme
+ExecStart=/usr/bin/atheme-services
+ExecReload=kill -HUP $MAINPID
+Type=forking
+PIDFile=/run/atheme/atheme.pid
+User=atheme-services
+
+[Install]
+WantedBy=multi-user.target