summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-30 19:40:08 +0100
committerSam James <sam@gentoo.org>2023-05-30 19:40:18 +0100
commite7fd1ad3b98eefd030d9437a74b6c645487fbaa6 (patch)
treeb7f9379ad89d2e8d628def4fd33132ab470fe89b /net-libs/libssh2
parentdev-python/watchfiles: Enable py3.12 (diff)
downloadgentoo-e7fd1ad3b98eefd030d9437a74b6c645487fbaa6.tar.gz
gentoo-e7fd1ad3b98eefd030d9437a74b6c645487fbaa6.tar.bz2
gentoo-e7fd1ad3b98eefd030d9437a74b6c645487fbaa6.zip
net-libs/libssh2: add 1.11.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libssh2')
-rw-r--r--net-libs/libssh2/Manifest1
-rw-r--r--net-libs/libssh2/files/libssh2-1.11.0-mansyntax_sh.patch10
-rw-r--r--net-libs/libssh2/libssh2-1.11.0.ebuild59
-rw-r--r--net-libs/libssh2/libssh2-9999.ebuild9
4 files changed, 76 insertions, 3 deletions
diff --git a/net-libs/libssh2/Manifest b/net-libs/libssh2/Manifest
index 95b30d057e33..db369a27d8b1 100644
--- a/net-libs/libssh2/Manifest
+++ b/net-libs/libssh2/Manifest
@@ -1 +1,2 @@
DIST libssh2-1.10.0.tar.gz 965044 BLAKE2B 0e6f571cc723e0050bf7ba7492f361ef222547dcbc311019cb6762f01405b4906e0418207a7d484c5170bee5e6f666827a7ea0d0cf233f684f999f896ce0b415 SHA512 e064ee1089eb8e6cd5fa2617f4fd8ff56c2721c5476775a98bdb68c6c4ee4d05c706c3bb0eb479a27a8ec0b17a8a5ef43e1d028ad3f134519aa582d3981a3a30
+DIST libssh2-1.11.0.tar.xz 686796 BLAKE2B 36903798c72f7261d9e997254169c10a4e69166017445276de8b0066fff15cd4dae4119a8d6cbbab8859d765b2d7f34f2911bbaf83c8d6ac5d1feead6b5de64e SHA512 6d50c71b778ca0f769fcc9d2cc257ab669cd0b6c35e8b0e047b6b38aea10638974cc591ba27c25bb7dd523020b4a8a62e2c1ae368287d9dc254d5e24d4a7cee7
diff --git a/net-libs/libssh2/files/libssh2-1.11.0-mansyntax_sh.patch b/net-libs/libssh2/files/libssh2-1.11.0-mansyntax_sh.patch
new file mode 100644
index 000000000000..8d8e93cda47e
--- /dev/null
+++ b/net-libs/libssh2/files/libssh2-1.11.0-mansyntax_sh.patch
@@ -0,0 +1,10 @@
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -63,7 +63,6 @@ if(SH_EXECUTABLE)
+ mark_as_advanced(SSHD_EXECUTABLE)
+ endif()
+
+- add_test(NAME mansyntax COMMAND ${SH_EXECUTABLE} -c "${CMAKE_CURRENT_SOURCE_DIR}/mansyntax.sh")
+ endif()
+
+ add_library(runner STATIC ${librunner_la_SOURCES})
diff --git a/net-libs/libssh2/libssh2-1.11.0.ebuild b/net-libs/libssh2/libssh2-1.11.0.ebuild
new file mode 100644
index 000000000000..2f60c46c3928
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.11.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="https://www.libssh2.org"
+SRC_URI="https://www.libssh2.org/download/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="gcrypt mbedtls test zlib"
+REQUIRED_USE="?? ( gcrypt mbedtls )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ !gcrypt? (
+ mbedtls? ( net-libs/mbedtls:0=[${MULTILIB_USEDEP}] )
+ !mbedtls? (
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
+ )
+ )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.11.0-mansyntax_sh.patch
+)
+
+multilib_src_configure() {
+ local crypto_backend=OpenSSL
+ if use gcrypt; then
+ crypto_backend=Libgcrypt
+ elif use mbedtls; then
+ crypto_backend=mbedTLS
+ fi
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING=$(usex test)
+ -DCRYPTO_BACKEND=${crypto_backend}
+ -DENABLE_ZLIB_COMPRESSION=$(usex zlib)
+ -DRUN_SSHD_TESTS=OFF
+ -DRUN_DOCKER_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.a' -delete || die
+}
diff --git a/net-libs/libssh2/libssh2-9999.ebuild b/net-libs/libssh2/libssh2-9999.ebuild
index 7aa0edfae11e..290d28ce2558 100644
--- a/net-libs/libssh2/libssh2-9999.ebuild
+++ b/net-libs/libssh2/libssh2-9999.ebuild
@@ -12,9 +12,9 @@ EGIT_REPO_URI="https://github.com/libssh2/libssh2"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="gcrypt mbedtls zlib"
+IUSE="gcrypt mbedtls test zlib"
REQUIRED_USE="?? ( gcrypt mbedtls )"
-RESTRICT="test"
+RESTRICT="!test? ( test )"
RDEPEND="
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
@@ -29,7 +29,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-1.8.0-mansyntax_sh.patch
+ "${FILESDIR}"/${PN}-1.11.0-mansyntax_sh.patch
)
multilib_src_configure() {
@@ -42,8 +42,11 @@ multilib_src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING=$(usex test)
-DCRYPTO_BACKEND=${crypto_backend}
-DENABLE_ZLIB_COMPRESSION=$(usex zlib)
+ -DRUN_SSHD_TESTS=OFF
+ -DRUN_DOCKER_TESTS=OFF
)
cmake_src_configure
}