summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-02-19 15:40:30 -0500
committerCraig Andrews <candrews@gentoo.org>2023-02-19 15:43:53 -0500
commit5ced10b3df6a847902e9bb6d532ecf46ba815a3d (patch)
tree97250d825c02731286f6a4d0ed54a7edc42631a5 /net-libs/nghttp3
parentnet-proxy/haproxy: fix musl support in all available versions (diff)
downloadgentoo-5ced10b3df6a847902e9bb6d532ecf46ba815a3d.tar.gz
gentoo-5ced10b3df6a847902e9bb6d532ecf46ba815a3d.tar.bz2
gentoo-5ced10b3df6a847902e9bb6d532ecf46ba815a3d.zip
net-libs/nghttp3: add USE=static-libs
Closes: https://bugs.gentoo.org/895354 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/nghttp3-0.8.0-r1.ebuild40
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild3
2 files changed, 42 insertions, 1 deletions
diff --git a/net-libs/nghttp3/nghttp3-0.8.0-r1.ebuild b/net-libs/nghttp3/nghttp3-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..719966f4eab6
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-0.8.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
index 3685e3ee33ca..719966f4eab6 100644
--- a/net-libs/nghttp3/nghttp3-9999.ebuild
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
LICENSE="MIT"
SLOT="0/0"
-IUSE="test"
+IUSE="static-libs test"
BDEPEND="virtual/pkgconfig"
DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
@@ -28,6 +28,7 @@ RESTRICT="!test? ( test )"
multilib_src_configure() {
local mycmakeargs=(
-DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
-DENABLE_EXAMPLES=OFF
-DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
)