summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-04 03:49:13 +0000
committerSam James <sam@gentoo.org>2023-01-04 04:31:57 +0000
commitc0248a88bb85e2d2c1067954eeb768e1eadfcd0d (patch)
tree178e1d3e1601dba795ac6fe3c27232b8e74981ad /net-proxy
parentnet-proxy/torsocks: drop 2.3.0 (diff)
downloadgentoo-c0248a88bb85e2d2c1067954eeb768e1eadfcd0d.tar.gz
gentoo-c0248a88bb85e2d2c1067954eeb768e1eadfcd0d.tar.bz2
gentoo-c0248a88bb85e2d2c1067954eeb768e1eadfcd0d.zip
net-proxy/torsocks: fix build w/ clang 16
Closes: https://bugs.gentoo.org/881077 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/torsocks/Manifest2
-rw-r--r--net-proxy/torsocks/files/torsocks-2.4.0-clang16.patch13
-rw-r--r--net-proxy/torsocks/torsocks-2.4.0-r1.ebuild (renamed from net-proxy/torsocks/torsocks-2.4.0.ebuild)6
3 files changed, 19 insertions, 2 deletions
diff --git a/net-proxy/torsocks/Manifest b/net-proxy/torsocks/Manifest
index b9bfe25373d6..3af31a60f5ef 100644
--- a/net-proxy/torsocks/Manifest
+++ b/net-proxy/torsocks/Manifest
@@ -1 +1 @@
-DIST torsocks-2.4.0.tar.gz 118991 BLAKE2B e1817c3bbf10f83431292c644d7187e40b62c5f223784074b3f9c082d8d75243090e226ffebb6fd81805fbd887588790833adc4ab8923e8116585c0a29255ad0 SHA512 7d625ce3a4600f87b86ae9ac79dfd206e7709cb0bafe0b7afcf33a6f1825f968cc63ad3e23c584582b244647bdeafbfdbfc54f7c81e521b0a3d278a1483ce86e
+DIST torsocks-2.4.0-r1.tar.gz 118991 BLAKE2B e1817c3bbf10f83431292c644d7187e40b62c5f223784074b3f9c082d8d75243090e226ffebb6fd81805fbd887588790833adc4ab8923e8116585c0a29255ad0 SHA512 7d625ce3a4600f87b86ae9ac79dfd206e7709cb0bafe0b7afcf33a6f1825f968cc63ad3e23c584582b244647bdeafbfdbfc54f7c81e521b0a3d278a1483ce86e
diff --git a/net-proxy/torsocks/files/torsocks-2.4.0-clang16.patch b/net-proxy/torsocks/files/torsocks-2.4.0-clang16.patch
new file mode 100644
index 000000000000..3bedd71dc736
--- /dev/null
+++ b/net-proxy/torsocks/files/torsocks-2.4.0-clang16.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/881077
+https://gitlab.torproject.org/tpo/core/torsocks/-/issues/40014
+https://lists.torproject.org/pipermail/tor-dev/2022-December/014790.html
+--- a/src/common/config-file.h
++++ b/src/common/config-file.h
+@@ -109,6 +109,7 @@ int conf_file_set_allow_inbound(const char *val, struct configuration *config);
+ int conf_file_set_allow_outbound_localhost(const char *val, struct
+ configuration *config);
+ int conf_file_set_isolate_pid(const char *val, struct configuration *config);
++int conf_file_set_enable_ipv6(const char *val, struct configuration *config);
+
+ int conf_apply_socks_auth(struct configuration *config);
+
diff --git a/net-proxy/torsocks/torsocks-2.4.0.ebuild b/net-proxy/torsocks/torsocks-2.4.0-r1.ebuild
index 94ad25e9ef98..7efc2f3d402c 100644
--- a/net-proxy/torsocks/torsocks-2.4.0.ebuild
+++ b/net-proxy/torsocks/torsocks-2.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,6 +21,10 @@ IUSE="static-libs"
DEPEND=""
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.0-clang16.patch
+)
+
src_prepare() {
# Disable tests requiring network access.
local test