summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-voip/openmcu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-voip/openmcu')
-rw-r--r--net-voip/openmcu/Manifest1
-rw-r--r--net-voip/openmcu/files/openmcu-2.2.1-deque.patch10
-rw-r--r--net-voip/openmcu/files/openmcu-2.2.1-path.patch48
-rw-r--r--net-voip/openmcu/files/openmcu.confd6
-rw-r--r--net-voip/openmcu/files/openmcu.ini13
-rw-r--r--net-voip/openmcu/files/openmcu.rc621
-rw-r--r--net-voip/openmcu/metadata.xml10
-rw-r--r--net-voip/openmcu/openmcu-2.2.5.ebuild73
8 files changed, 182 insertions, 0 deletions
diff --git a/net-voip/openmcu/Manifest b/net-voip/openmcu/Manifest
new file mode 100644
index 000000000000..3fcadadd72da
--- /dev/null
+++ b/net-voip/openmcu/Manifest
@@ -0,0 +1 @@
+DIST h323plus-app-v1_23_0.tar.gz 610103 SHA256 faff110e5d23d5578da9d9126581d3a6001338c0dfcb051925e83e1a513e91b2 SHA512 cdb9c587cc857c64440fc9f9d8e1a08e2c9ae00c2070a8d4678e65ca951124c1b4423c24cf795c3f810bd4694f05536b981ca20377755a2c19908de56498dbd0 WHIRLPOOL 462fcc4dcb19d0b4e48967b9d5f6c6676a7c7023472bd28cffe26307a59a5bc33cccd0d1d79acae9fcdd808e0e423f07ada5208c976752df422ae9e31e7a4255
diff --git a/net-voip/openmcu/files/openmcu-2.2.1-deque.patch b/net-voip/openmcu/files/openmcu-2.2.1-deque.patch
new file mode 100644
index 000000000000..742d35a8c17c
--- /dev/null
+++ b/net-voip/openmcu/files/openmcu-2.2.1-deque.patch
@@ -0,0 +1,10 @@
+--- filemembers.h.old 2009-02-10 22:48:49.000000000 -0500
++++ filemembers.h 2009-02-10 22:49:00.000000000 -0500
+@@ -80,6 +80,7 @@
+
+ #include "config.h"
+
++#include <deque>
+ #include <ptlib/sound.h>
+ #include <opalwavfile.h>
+ #include "conference.h"
diff --git a/net-voip/openmcu/files/openmcu-2.2.1-path.patch b/net-voip/openmcu/files/openmcu-2.2.1-path.patch
new file mode 100644
index 000000000000..48ae0364a8c6
--- /dev/null
+++ b/net-voip/openmcu/files/openmcu-2.2.1-path.patch
@@ -0,0 +1,48 @@
+diff -u openmcu_v2_2_1.orig/main.cxx openmcu_v2_2_1/main.cxx
+--- openmcu_v2_2_1.orig/main.cxx 2006-06-09 00:39:59.000000000 -0400
++++ openmcu_v2_2_1/main.cxx 2009-02-10 23:09:49.000000000 -0500
+@@ -54,9 +54,9 @@
+ #include <ptlib.h>
+ #include "mcu.h"
+
+-static const char DefaultConnectingWAVFile[] = "connecting.wav";
+-static const char DefaultEnteringWAVFile[] = "entering.wav";
+-static const char DefaultLeavingWAVFile[] = "leaving.wav";
++static const char DefaultConnectingWAVFile[] = "/usr/share/openmcu/sounds/connecting.wav";
++static const char DefaultEnteringWAVFile[] = "/usr/share/openmcu/sounds/entering.wav";
++static const char DefaultLeavingWAVFile[] = "/usr/share/openmcu/sounds/leaving.wav";
+
+ static const char ConnectingWAVFileKey[] = "Connecting WAV File";
+ static const char EnteringWAVFileKey[] = "Entering WAV File";
+diff -u openmcu_v2_2_1.orig/mcu.cxx openmcu_v2_2_1/mcu.cxx
+--- openmcu_v2_2_1.orig/mcu.cxx 2006-07-14 01:28:01.000000000 -0400
++++ openmcu_v2_2_1/mcu.cxx 2009-02-10 23:11:43.000000000 -0500
+@@ -83,7 +83,7 @@
+ static const char DefaultRoomKey[] = "Default room";
+ static const char DefaultRoomTimeLimitKey[] = "Room time limit";
+
+-static const char DefaultCallLogFilename[] = "mcu_log.txt";
++static const char DefaultCallLogFilename[] = "/var/log/openmcu/openmcu.log";
+ static const char DefaultRoom[] = "room101";
+
+ #if OPENMCU_VIDEO
+@@ -154,8 +154,8 @@
+ #endif
+ exeDir.Change();
+
+- httpNameSpace.AddResource(new PHTTPDirectory("data", "data"));
+- httpNameSpace.AddResource(new PServiceHTTPDirectory("html", "html"));
++ httpNameSpace.AddResource(new PHTTPDirectory("data", "/usr/share/openmcu/data"));
++ httpNameSpace.AddResource(new PServiceHTTPDirectory("html", "/usr/share/openmcu/html"));
+
+ manager = CreateConferenceManager();
+ endpoint = CreateEndPoint(*manager);
+@@ -229,7 +229,7 @@
+
+ #if P_SSL
+ // SSL certificate file.
+- PString certificateFile = cfg.GetString(HTTPCertificateFileKey, "server.pem");
++ PString certificateFile = cfg.GetString(HTTPCertificateFileKey, "/etc/openmcu/server.pem");
+ rsrc->Add(new PHTTPStringField(HTTPCertificateFileKey, 25, certificateFile));
+ if (!SetServerCertificate(certificateFile, TRUE)) {
+ PSYSTEMLOG(Fatal, "MCU\tCould not load certificate \"" << certificateFile << '"');
diff --git a/net-voip/openmcu/files/openmcu.confd b/net-voip/openmcu/files/openmcu.confd
new file mode 100644
index 000000000000..ad54babfabce
--- /dev/null
+++ b/net-voip/openmcu/files/openmcu.confd
@@ -0,0 +1,6 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+OPTIONS="-u openmcu -g openmcu"
diff --git a/net-voip/openmcu/files/openmcu.ini b/net-voip/openmcu/files/openmcu.ini
new file mode 100644
index 000000000000..7dbdac551989
--- /dev/null
+++ b/net-voip/openmcu/files/openmcu.ini
@@ -0,0 +1,13 @@
+[Parameters]
+Password=i9Vp7LN+X5Y=
+Log Level=2
+HTTP Certificate=/etc/openmcu/server.pem
+HTTP Port=1420
+Gatekeeper Mode=No gatekeeper
+Interface Array Size=0
+Default room=room101
+Connecting WAV File=/usr/share/openmcu/sounds/connecting.wav
+Entering WAV File=/usr/share/openmcu/sounds/entering.wav
+Leaving WAV File=/usr/share/openmcu/sounds/leaving.wav
+Call log filename=/var/log/openmcu/mcu_log.txt
+
diff --git a/net-voip/openmcu/files/openmcu.rc6 b/net-voip/openmcu/files/openmcu.rc6
new file mode 100644
index 000000000000..444d5bbe793b
--- /dev/null
+++ b/net-voip/openmcu/files/openmcu.rc6
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting H.323 Conferencing service"
+ start-stop-daemon --start --quiet --pidfile /var/run/openmcu/openmcu.pid \
+ --exec /usr/sbin/openmcu -- ${OPTIONS} -d -p /var/run/openmcu/openmcu.pid -i /etc/openmcu/openmcu.ini
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping H.323 Conferencing service"
+ start-stop-daemon --stop --quiet --pidfile /var/run/openmcu/openmcu.pid
+ eend $?
+}
diff --git a/net-voip/openmcu/metadata.xml b/net-voip/openmcu/metadata.xml
new file mode 100644
index 000000000000..375a3ff73a28
--- /dev/null
+++ b/net-voip/openmcu/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">h323plus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-voip/openmcu/openmcu-2.2.5.ebuild b/net-voip/openmcu/openmcu-2.2.5.ebuild
new file mode 100644
index 000000000000..d67e71073608
--- /dev/null
+++ b/net-voip/openmcu/openmcu-2.2.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+MY_PN=h323plus-app
+MY_PV=1_23_0
+DESCRIPTION="Simple Multi Conference Unit using H.323"
+HOMEPAGE="http://www.h323plus.org/"
+SRC_URI="mirror://sourceforge/h323plus/${MY_PN}-v${MY_PV}.tar.gz"
+
+LICENSE="MPL-1.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/ptlib:=
+ net-libs/h323plus:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/applications/${PN}
+
+src_prepare() {
+ # set path for various files
+ epatch "${FILESDIR}"/${PN}-2.2.1-path.patch
+}
+
+src_compile() {
+ emake OPENH323DIR=/usr/share/openh323
+}
+
+src_install() {
+ dosbin obj_*_*_*/${PN}
+
+ keepdir /usr/share/${PN}/data /usr/share/${PN}/html
+
+ # needed for daemon
+ keepdir /var/log/${PN} /var/run/${PN}
+
+ insinto /usr/share/${PN}/sounds
+ doins *.wav
+
+ insinto /etc/${PN}
+ doins server.pem
+ doins "${FILESDIR}"/${PN}.ini
+
+ doman ${PN}.1
+
+ dodoc ReadMe.txt
+
+ newinitd "${FILESDIR}"/${PN}.rc6 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_preinst() {
+ enewgroup openmcu
+ enewuser openmcu -1 -1 /dev/null openmcu
+}
+
+pkg_postinst() {
+ einfo "Setting permissions..."
+ chown -R openmcu:openmcu "${ROOT}"etc/openmcu
+ chmod -R u=rwX,g=rX,o= "${ROOT}"etc/openmcu
+ chown -R openmcu:openmcu "${ROOT}"var/{log,run}/openmcu
+ chmod -R u=rwX,g=rX,o= "${ROOT}"var/{log,run}/openmcu
+
+ echo
+ elog "This patched version of openmcu stores it's configuration"
+ elog "in \"/etc/openmcu/openmcu.ini\""
+}