summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-05-10 18:14:17 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-05-10 18:14:17 -0500
commit3f3bc387ebcd1c7c5687f52de20a8f522281c750 (patch)
tree4b16b04f99472b882c291fab572ff26fd4b9dae8 /net-vpn/tailscale
parentnet-analyzer/nmap: Stabilize 7.95 amd64, #931695 (diff)
downloadgentoo-3f3bc387ebcd1c7c5687f52de20a8f522281c750.tar.gz
gentoo-3f3bc387ebcd1c7c5687f52de20a8f522281c750.tar.bz2
gentoo-3f3bc387ebcd1c7c5687f52de20a8f522281c750.zip
net-vpn/tailscale: add 1.66.1
Closes: https://bugs.gentoo.org/930433 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn/tailscale')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.66.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index eb5cae476362..a5ddcb1dc2a6 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -6,3 +6,5 @@ DIST tailscale-1.58.2-deps.tar.xz 397235964 BLAKE2B 3273320edb277d8f6527b6048f62
DIST tailscale-1.58.2.tar.gz 2361679 BLAKE2B 1aa66710677ba7c648782db9f67ce8cf565812b08610bb078bcd78ee2d695601fcb2f681102eb7a1232b6c4057ba5e1fed1d26b375cec793f0fbce65aff38755 SHA512 3370af3c0214544d15196063f798e17e7c35566cf4d01628faa1e26ba1a5885834b0f3d2862e3009a81ff9f4298cdd3f826fc5d09f23568c30c64bc6f0400f6b
DIST tailscale-1.60.0-deps.tar.xz 382250200 BLAKE2B 199d78fdccd0502dbf2d7e9e3cb50660a83d1187e35e50cd5f648970927fdf5c1df98682e8366d108603a1163df32fdc523041b8fe36dabfb2d13f0951357b16 SHA512 7fa1f21d42ddc85a98ad420104e17183b9c615010e8f13ca971f3488d382c6b7a8595006062e09f6438eeeaa6559a4e35eab3b053e85a66c5dfa9924d1aa5258
DIST tailscale-1.60.0.tar.gz 2440764 BLAKE2B f6c6ee3e378ddc37dbe67a74b1ff2b1cf5b9cbe720f6a38b3292f6fc7874b2712f00d7ba2e647a12c7b29edb2ca131605226af5fd56200b8fa7c6005e6eba778 SHA512 81c96c6f64d4141894673be7d524bacae7485f9c1d63fde5dcea952573daafc87c9f5b5fa17ceabe8e88a4d61b4f939822228fb2a310bd8522ca15f7cb9c3a60
+DIST tailscale-1.66.1-deps.tar.xz 166468968 BLAKE2B ff69b69cfb9e46ea9a8b0267f5c14068cf715dff04167d9994630b03813790a8d305362508d6d77501eb6b41d0b44a68b5c447e29f0fc41ae343e303068ed584 SHA512 d923ab191c7986f90c78e85a8399910f1a94225223778fb92c11207ae144d149cf583f5c2fd5fb006802fc916ab73cc48f657c65960d570d9f98a7ddd47e32c6
+DIST tailscale-1.66.1.tar.gz 2634211 BLAKE2B cbf90ee36545fa8ba302f872948dc92e735bfe690451428540bee10399d1db1cdbf050949a5f3dbc69a77596b6a6d94724eb43bf9a4ee78a5cee9ada03889a3e SHA512 46e226c651abd5dee248e49fcf40a0cea9de72fe9e330015299acd9ec1fc83e1f192948c26b803f0fe3404558471b374391f3cf9155ecb2257a2563f79f3278b
diff --git a/net-vpn/tailscale/tailscale-1.66.1.ebuild b/net-vpn/tailscale/tailscale-1.66.1.ebuild
new file mode 100644
index 000000000000..a11d49b98146
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.66.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="66"
+VERSION_SHORT="1.66.1"
+VERSION_LONG="1.66.1-t88e23b6cf"
+VERSION_GIT_HASH="88e23b6cfd4b9a9cad5ce858b73ece1f07970fee"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="net-firewall/iptables"
+BDEPEND=">=dev-lang/go-1.22"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.Long=${VERSION_LONG}
+ -X tailscale.com/version.Short=${VERSION_SHORT}
+ -X tailscale.com/version.GitCommit=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}