summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/spectools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/spectools')
-rw-r--r--net-wireless/spectools/Manifest2
-rw-r--r--net-wireless/spectools/metadata.xml24
-rw-r--r--net-wireless/spectools/spectools-2011.08.1-r2.ebuild71
-rw-r--r--net-wireless/spectools/spectools-2011.08.1_p20140618.ebuild70
-rw-r--r--net-wireless/spectools/spectools-9999.ebuild70
5 files changed, 237 insertions, 0 deletions
diff --git a/net-wireless/spectools/Manifest b/net-wireless/spectools/Manifest
new file mode 100644
index 000000000000..f63672baaeca
--- /dev/null
+++ b/net-wireless/spectools/Manifest
@@ -0,0 +1,2 @@
+DIST spectools-2011-08-R1.tar.gz 196001 SHA256 ce981cd2b86c6246dc7cb9c0166b85e586e5f5835d3ed147e8901ef18f00220e SHA512 92c80b34049055cec6d677db165fb2d06d75fbff9f04d41ab81fa57900f639936e6a9a01f06165aea863b35760964016f0984f17816859d054bc9d14353e847b WHIRLPOOL 89af3aa1f1e4033de3051bc6dd5b2d6f013c1270d588768fcfc08830a420f3ab3507494b0f5575b830a9d88abc885600e551ad78bc9931ab5bd061e74d7d27c8
+DIST spectools-2011-08-R1_p20140618.tar.xz 143644 SHA256 a4c22bc1be0b66dfeaeff37004e08ef4927d443a7e67bc893627d0569f6f3a2f SHA512 bf39953dc94815af1b670f079f7660d46cc8449adb379d0fc2755de5785c936730114aa66127f9cbd86f9a08b506382f5ec56f863d50d7d39f2597ba9b122330 WHIRLPOOL 7be4b1209b0a72a67b102f75ede813c3680d1222478bb507755af836b9ede6a2db4bf93ce2b5300d1aa16d0c422865924164fb021015651f750711a055e4700d
diff --git a/net-wireless/spectools/metadata.xml b/net-wireless/spectools/metadata.xml
new file mode 100644
index 000000000000..97e99311c4f5
--- /dev/null
+++ b/net-wireless/spectools/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ <description>maintainer, has access to all hardware as needed</description>
+ </maintainer>
+ <maintainer>
+ <email>steev@gentoo.org</email>
+ <name>Steev Klimaszewski</name>
+ <description>co-maintainer, CC him on bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ <description>Maintainer, has 1st gen WiSpy hardware for testing</description>
+ </maintainer>
+<use>
+ <flag name="debug">Build the raw output client for spectools. (for developers)</flag>
+ <flag name="ncurses">Build the ncurses based client for spectools</flag>
+ <flag name="gtk">Build the gtk-2 based client for spectools</flag>
+</use>
+</pkgmetadata>
diff --git a/net-wireless/spectools/spectools-2011.08.1-r2.ebuild b/net-wireless/spectools/spectools-2011.08.1-r2.ebuild
new file mode 100644
index 000000000000..bcb85310eac2
--- /dev/null
+++ b/net-wireless/spectools/spectools-2011.08.1-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit udev toolchain-funcs
+
+MY_PN=${PN}
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+MY_P="${MY_PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://www.kismetwireless.net/code/svn/tools/${PN}"
+ inherit subversion
+ KEYWORDS=""
+else
+ SRC_URI="http://www.kismetwireless.net/code/${MY_P}.tar.gz"
+ KEYWORDS="amd64 arm ppc x86"
+fi
+
+DESCRIPTION="Spectrum Analyzer for Meta-Geek Wi-Spy and GSG Ubertooth hardware"
+HOMEPAGE="http://www.kismetwireless.net/spectools/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ncurses gtk"
+
+RDEPEND="virtual/libusb:0
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# Upstream has still not migrated to the libusb-1 line.
+# Maemo: Add hildon and bbus
+
+# Please note that upstream removed the --with-gtk-version option
+# and GTK is now automagical. GTK1 support was also removed.
+src_compile() {
+ emake depend
+
+ emake spectool_net spectool_raw
+
+ if use ncurses; then
+ emake spectool_curses
+ fi
+
+ if use gtk; then
+ emake spectool_gtk
+ fi
+
+ #if use maemo; then
+ # emake spectool_hildon usbcontrol \
+ # || die "emake spectool_hildon usbcontrol failed"
+ #fi
+}
+
+src_install() {
+ dobin spectool_net spectool_raw
+ use ncurses && dobin spectool_curses
+ use gtk && dobin spectool_gtk
+
+ udev_dorules 99-wispy.rules
+ dodoc README
+
+ #if use maemo; then
+ # dobin spectool_hildon
+ # dosbin usbcontrol
+ #fi
+}
diff --git a/net-wireless/spectools/spectools-2011.08.1_p20140618.ebuild b/net-wireless/spectools/spectools-2011.08.1_p20140618.ebuild
new file mode 100644
index 000000000000..b30e6ce1f2e8
--- /dev/null
+++ b/net-wireless/spectools/spectools-2011.08.1_p20140618.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit udev toolchain-funcs
+
+MY_PN=${PN}
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+MY_P="${MY_PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://www.kismetwireless.net/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+DESCRIPTION="Spectrum Analyzer for Meta-Geek Wi-Spy and GSG Ubertooth hardware"
+HOMEPAGE="http://www.kismetwireless.net/spectools/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug +ncurses +gtk"
+
+RDEPEND="virtual/libusb:0
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# Upstream has still not migrated to the libusb-1 line.
+# Maemo: Add hildon and bbus
+
+# Please note that upstream removed the --with-gtk-version option
+# and GTK is now automagical. GTK1 support was also removed.
+src_compile() {
+ emake depend
+
+ emake spectool_net
+
+ use debug && emake spectool_raw
+
+ use ncurses && emake spectool_curses
+
+ use gtk && emake spectool_gtk
+
+ #if use maemo; then
+ # emake spectool_hildon usbcontrol \
+ # || die "emake spectool_hildon usbcontrol failed"
+ #fi
+}
+
+src_install() {
+ dobin spectool_net
+ use debug && dobin spectool_raw
+ use ncurses && dobin spectool_curses
+ use gtk && dobin spectool_gtk
+
+ udev_dorules 99-wispy.rules
+ dodoc README
+
+ #if use maemo; then
+ # dobin spectool_hildon
+ # dosbin usbcontrol
+ #fi
+}
diff --git a/net-wireless/spectools/spectools-9999.ebuild b/net-wireless/spectools/spectools-9999.ebuild
new file mode 100644
index 000000000000..e5c5de4b3fc6
--- /dev/null
+++ b/net-wireless/spectools/spectools-9999.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit udev toolchain-funcs
+
+MY_PN=${PN}
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+MY_P="${MY_PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://www.kismetwireless.net/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="http://www.kismetwireless.net/code/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+DESCRIPTION="Spectrum Analyzer for Meta-Geek Wi-Spy and GSG Ubertooth hardware"
+HOMEPAGE="http://www.kismetwireless.net/spectools/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug +ncurses +gtk"
+
+RDEPEND="virtual/libusb:0
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+# Upstream has still not migrated to the libusb-1 line.
+# Maemo: Add hildon and bbus
+
+# Please note that upstream removed the --with-gtk-version option
+# and GTK is now automagical. GTK1 support was also removed.
+src_compile() {
+ emake depend
+
+ emake spectool_net
+
+ use debug && emake spectool_raw
+
+ use ncurses && emake spectool_curses
+
+ use gtk && emake spectool_gtk
+
+ #if use maemo; then
+ # emake spectool_hildon usbcontrol \
+ # || die "emake spectool_hildon usbcontrol failed"
+ #fi
+}
+
+src_install() {
+ dobin spectool_net
+ use debug && dobin spectool_raw
+ use ncurses && dobin spectool_curses
+ use gtk && dobin spectool_gtk
+
+ udev_dorules 99-wispy.rules
+ dodoc README
+
+ #if use maemo; then
+ # dobin spectool_hildon
+ # dosbin usbcontrol
+ #fi
+}