summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/gasgano
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/gasgano')
-rw-r--r--sci-astronomy/gasgano/Manifest3
-rw-r--r--sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild41
-rw-r--r--sci-astronomy/gasgano/gasgano-2.4.5.ebuild41
-rw-r--r--sci-astronomy/gasgano/metadata.xml14
4 files changed, 99 insertions, 0 deletions
diff --git a/sci-astronomy/gasgano/Manifest b/sci-astronomy/gasgano/Manifest
new file mode 100644
index 000000000000..25330f65aee9
--- /dev/null
+++ b/sci-astronomy/gasgano/Manifest
@@ -0,0 +1,3 @@
+DIST VLT-PRO-ESO-19000-1932-V4.pdf 818369 SHA256 d370d6a57bed3cb7e47bb322e4cde5e314d37c6110e5370ea3099d241355ed68 SHA512 272da18caee1bb1b5228df76a7f09411120be39a4b421b79d48e0bfc09972f250322a718bf380d7a83c3a528151260139efdcd8d2482c6a36ad45d727d93cce1 WHIRLPOOL f13320ab0beaf5302eab56882ba7a8185543254e05cd1dada10a2fbc1652f45f74a20f326e703d9837d9abdee7499dbdfb7bdf1bd963f84937c6c24c3823b3f3
+DIST gasgano-2.4.3.tar.gz 4985401 SHA256 d7873fb7b5429a8711e10c080f0377b8aa10600c700ac8b6c3023c5f808e5fe5 SHA512 1376bbd75754fbb68353c67da73f25a22e6af6a83be1ac5f263743eacaf9339b853e2b17e52580c1a3434e8d60a9a4bcbf8136d492fd722e554f2d81a5199c2c WHIRLPOOL 249a322a39924c7dea1a41ffcd441eafd0cf159e630c4cce715d9dd868705994c07340d3c3603b80dc2d80a1e870560450e65d5366477f4f53cdf1bc4712990f
+DIST gasgano-2.4.5.tar.gz 8676773 SHA256 0ef5ca420b0e9e1f29df001d34a832746f58d77da7790f2da767457df12d816d SHA512 fab93f5240808129d432000ea47c3d3b9b0520c43baea2858459a4e9e6cbe75deb8df73199d716c62b71a11147844f09ea89a065b467ae1086d6f3fe41cdc53d WHIRLPOOL 69d76b68f5adf80a368bff13eb3bcbd8e76b54990695743bc62481ffd64513b1e9f169f4c3e167ae30e387fad578f00e5e9142b6c06d92a58d854d1ccad13ca8
diff --git a/sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild b/sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild
new file mode 100644
index 000000000000..489e2c3bc0ab
--- /dev/null
+++ b/sci-astronomy/gasgano/gasgano-2.4.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils java-pkg-2
+
+PDOC=VLT-PRO-ESO-19000-1932-V4
+
+DESCRIPTION="ESO astronomical data file organizer"
+HOMEPAGE="http://www.eso.org/sci/software/gasgano/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/${PN}/${P}.tar.gz
+ doc? ( ${HOMEPAGE}/${PDOC}.pdf )"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND="
+ >=virtual/jre-1.6
+ dev-java/gnu-regexp
+ dev-java/junit
+ dev-java/jal"
+
+src_prepare() {
+ sed -i \
+ -e "s:^BASE=\`pwd\`:BASE=${EPREFIX}/usr/share/${PN}:" \
+ -e 's:$BASE/share/:$BASE/lib/:g' \
+ bin/gasgano || die
+}
+
+src_install() {
+ dobin bin/*
+ java-pkg_dojar share/*.jar
+ insinto /usr/share/${PN}
+ doins -r config
+ make_desktop_entry gasgano "Gasgano FITS Organizer"
+ use doc && newdoc "${DISTDIR}"/${PDOC}.pdf user-manual.pdf
+}
diff --git a/sci-astronomy/gasgano/gasgano-2.4.5.ebuild b/sci-astronomy/gasgano/gasgano-2.4.5.ebuild
new file mode 100644
index 000000000000..1aaaebe0a6ae
--- /dev/null
+++ b/sci-astronomy/gasgano/gasgano-2.4.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils java-pkg-2
+
+PDOC=VLT-PRO-ESO-19000-1932-V4
+
+DESCRIPTION="ESO astronomical data file organizer"
+HOMEPAGE="http://www.eso.org/sci/software/gasgano/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/${PN}/${P}.tar.gz
+ doc? ( ${HOMEPAGE}/${PDOC}.pdf )"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND="
+ >=virtual/jre-1.6
+ dev-java/gnu-regexp
+ dev-java/junit
+ dev-java/jal"
+
+src_prepare() {
+ sed -i \
+ -e "s:^BASE=\`pwd\`:BASE=${EPREFIX}/usr/share/${PN}:" \
+ -e 's:$BASE/share/:$BASE/lib/:g' \
+ bin/gasgano || die
+}
+
+src_install() {
+ dobin bin/*
+ java-pkg_dojar share/*.jar
+ insinto /usr/share/${PN}
+ doins -r config
+ make_desktop_entry gasgano "Gasgano FITS Organizer"
+ use doc && newdoc "${DISTDIR}"/${PDOC}.pdf user-manual.pdf
+}
diff --git a/sci-astronomy/gasgano/metadata.xml b/sci-astronomy/gasgano/metadata.xml
new file mode 100644
index 000000000000..247aae21d92c
--- /dev/null
+++ b/sci-astronomy/gasgano/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ Gasgano is a Data File Organiser developed and maintained by ESO to
+ help its user community to manage and organise in a systematic way the
+ astronomical data observed and produced by all VLT compliant
+ telescopes, i.e. by telescopes which are being operated through
+ Observation Blocks. The tool also supports FITS files which are not
+ generated by those telescopes but with a limited number of
+ functionalities.
+</longdescription>
+</pkgmetadata>