summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2016-11-13 15:22:47 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2016-11-13 15:23:33 +0000
commit7e54ae3ae0acae59f83eb7004c3f546e0d23afd2 (patch)
tree97e4d4523e2daff39aeadca56953b25c301f3929 /sys-apps/epoch
parentapp-misc/gramps: remove old (diff)
downloadgentoo-7e54ae3ae0acae59f83eb7004c3f546e0d23afd2.tar.gz
gentoo-7e54ae3ae0acae59f83eb7004c3f546e0d23afd2.tar.bz2
gentoo-7e54ae3ae0acae59f83eb7004c3f546e0d23afd2.zip
sys-apps/epoch: bump 1.3.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/epoch')
-rw-r--r--sys-apps/epoch/Manifest1
-rw-r--r--sys-apps/epoch/epoch-1.3.0.ebuild75
-rw-r--r--sys-apps/epoch/files/epoch-1.3.0-fix-main.patch13
3 files changed, 89 insertions, 0 deletions
diff --git a/sys-apps/epoch/Manifest b/sys-apps/epoch/Manifest
index ee8d4bb3ccb6..438de50c84ce 100644
--- a/sys-apps/epoch/Manifest
+++ b/sys-apps/epoch/Manifest
@@ -6,3 +6,4 @@ DIST epoch-1.1.1.tar.gz 64969 SHA256 98a410ba66952bfc1c326fafd8ceeaf23262e3c3a97
DIST epoch-1.2.0.tar.gz 66380 SHA256 26147efd855a157d6774111e8171deaa7ce0f8df34ea13910d88fef54bec4b6f SHA512 d017e9f7078bd10596212769a8927f93f0ceb8a34beaf39b7708632bce55f107aa49904de68cfb9ee7aefc40ba28a455a0aecfe7c1afe838bf9e4144ea65544a WHIRLPOOL d49ec73337816b86512757f5a07ca1fbc660bb315e7a997efa36f776806f001fe73e87af4dd0ce0d5a3ba1b8683d775d9783c83072990ffc4c4f9b48dc89d4e7
DIST epoch-1.2.1.tar.gz 66718 SHA256 9ad6573ca71599f17cf6a567eef902cd1caadb5b5460764ae7bb4e16fa3a9423 SHA512 2d0c767165ec41452d1dabf338c8ea31772f1a8cd1e1dbd60c8469f2f235bb1f0cb60b467189f1fd1079dfc223b0687c1cfe5e729e1142ebc63323b1f9c0cf93 WHIRLPOOL 3c6382f6b2dfd0260f2a036403e995a7bca0b2ceb60a740c3294d736e091c6f9d21541f87a42019bfa25817135ea12bfaf59662ecd2eb85a1e126b9b2ad4c9d7
DIST epoch_1.2.2.tar.gz 229377 SHA256 3c8bdc4e3ddcaf2410f2c6082cab61f0957dfacf5c14300dadc6c22afd5bca8b SHA512 9e3e38ef95c20237a3db4f47c9464f27e893a665f0692200d89e96b12f6b2e3af9b84d951356b7b354f19ea4fbe372e2e0ba406fdfeb8819914d46cfed3024a3 WHIRLPOOL 1235b63f15435ccdfaf451aca11bd7ab07bc1e0ea148c6430e4b896d7c5838966000c85fabcc03ed86e92a28b46814db80fea528881bce0aa8653af3492d1533
+DIST epoch_1.3.0.tar.gz 70681 SHA256 80ae3faa708976dfb15d5a59f10dfc0750fca9d16f164daea771757f89ddaa08 SHA512 1e4a8bee26d8819303cbeb67265ee74e294502acfb3f5e594222bb7bdcb2d077fe19e73c40e9111a6ef9af788d767434f5a9a357430b59d6a0cac0e36a3b8f9e WHIRLPOOL 6cd76694337f79a4a6e96a4506ec14a8a16c3861d808fa3a640fa02632833e79c3063c41dc210969798329df6467b4a21a367ed9c3182609c0a3fe26fbe0f60e
diff --git a/sys-apps/epoch/epoch-1.3.0.ebuild b/sys-apps/epoch/epoch-1.3.0.ebuild
new file mode 100644
index 000000000000..70f783dd539e
--- /dev/null
+++ b/sys-apps/epoch/epoch-1.3.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils linux-info
+
+MY_PV="${PV/rc/RC}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity"
+HOMEPAGE="http://universe2.us/epoch.html"
+SRC_URI="http://universe2.us/${PN}_${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~PROC_FS"
+
+ [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-1.3.0-fix-main.patch
+}
+
+src_compile() {
+ NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
+}
+
+newepochins() {
+ local type="$1"
+
+ cd ${type} || die "Cannot change directory."
+ for file in * ; do
+ if [[ "${file}" != "epoch" ]] ; then
+ new${type} ${file} epoch-${file}
+ fi
+ done
+ cd .. || die "Cannot change directory."
+}
+
+src_install() {
+ cd built || die "Cannot change directory."
+
+ dosbin sbin/epoch
+
+ # For now, rename to epoch-* until we can blend in with a standard approach.
+ newepochins bin
+ newepochins sbin
+
+ insinto /etc/epoch/
+ newins "${FILESDIR}"/${PN}-1.0_rc1-epoch.conf epoch.conf
+}
+
+pkg_postinst() {
+ elog "Make sure to provide /run and /tmp tmpfs mounts using /etc/fstab."
+ elog ""
+ elog "An example epoch configuration is provided at /etc/epoch/epoch.conf"
+ elog "which starts a minimal needed to use Gentoo."
+ elog ""
+ elog "To use epoch, add this kernel parameter: init=/usr/sbin/epoch-init"
+ elog ""
+ elog "Additional information about epoch is available at"
+ elog "${HOMEPAGE} and configuration documentation at"
+ elog "http://universe2.us/epochconfig.html which is useful reading material."
+ elog ""
+ elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
+}
diff --git a/sys-apps/epoch/files/epoch-1.3.0-fix-main.patch b/sys-apps/epoch/files/epoch-1.3.0-fix-main.patch
new file mode 100644
index 000000000000..b158ae2e3396
--- /dev/null
+++ b/sys-apps/epoch/files/epoch-1.3.0-fix-main.patch
@@ -0,0 +1,13 @@
+--- src/main.c.orig 2016-11-13 15:11:58.511021203 +0000
++++ src/main.c 2016-11-13 15:12:21.096021358 +0000
+@@ -1142,8 +1142,9 @@ static ReturnCode HandleEpochCommand(int
+ ShutdownMemBus(false); //We're done with membus now.
+
+ char Compare[WARNING + 1][MEMBUS_MSGSIZE] = { MEMBUS_CODE_FAILURE " ", MEMBUS_CODE_ACKNOWLEDGED " ", MEMBUS_CODE_WARNING " "};
++ int Inc;
+
+- for (int Inc = 0; Inc < sizeof Compare / sizeof *Compare; ++Inc)
++ for (Inc = 0; Inc < sizeof Compare / sizeof *Compare; ++Inc)
+ {
+ strcat(Compare[Inc], ArgIs("merge") ? MEMBUS_CODE_CFMERGE : MEMBUS_CODE_CFUMERGE);
+ strcat(Compare[Inc], " ");