summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2024-09-08 14:28:34 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-09-14 11:53:48 +0200
commitf32a2550ebe5f5affdd2db5c80b06ccb8f55f411 (patch)
tree149e25bfe5065a9730f96baac8030376b11751e0 /sys-apps/hd-idle
parentapp-forensics/yara: drop 4.5.0 (diff)
downloadgentoo-f32a2550ebe5f5affdd2db5c80b06ccb8f55f411.tar.gz
gentoo-f32a2550ebe5f5affdd2db5c80b06ccb8f55f411.tar.bz2
gentoo-f32a2550ebe5f5affdd2db5c80b06ccb8f55f411.zip
sys-apps/hd-idle: fix systemd dropin file install location
Closes: https://bugs.gentoo.org/937799 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/38522 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-apps/hd-idle')
-rw-r--r--sys-apps/hd-idle/hd-idle-1.05-r4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/hd-idle/hd-idle-1.05-r4.ebuild b/sys-apps/hd-idle/hd-idle-1.05-r4.ebuild
new file mode 100644
index 000000000000..2c7680147484
--- /dev/null
+++ b/sys-apps/hd-idle/hd-idle-1.05-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd
+
+DESCRIPTION="Utility for spinning down hard disks after a period of idle time"
+HOMEPAGE="https://hd-idle.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tgz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+CONFIG_CHECK="~PROC_FS"
+
+DOCS=( debian/changelog README )
+
+src_install() {
+ default
+ systemd_newunit "${FILESDIR}"/hd-idle.service ${PN}.service
+ systemd_install_serviced "${FILESDIR}"/hd-idle-service-dropin.conf ${PN}.service
+ newinitd "${FILESDIR}"/hd-idle-init hd-idle
+ newconfd "${FILESDIR}"/hd-idle-conf hd-idle
+
+ elog "The systemd unit file for hd-idle no longer sources ${EPREFIX}/etc/conf.d/hd-idle ."
+ elog "Configuration is still done via ${EPREFIX}/etc/conf.d/hd-idle for OpenRC systems"
+ elog "while for systemd systems, a systemd drop-in file located at"
+ elog "${EPREFIX}/etc/systemd/system/hd-idle.service.d/00gentoo.conf"
+ elog "is used for configuration."
+}