summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-13 23:34:48 +0000
committerMarek Szuba <marecki@gentoo.org>2021-11-13 23:34:48 +0000
commitfc1569545be66c72ab9f189fb547a8345e668def (patch)
treedde5babc531407d54c9d25010129150bd911fea3 /sys-auth
parentsys-auth/solo-python: correct PyPI project name in metadata (diff)
downloadgentoo-fc1569545be66c72ab9f189fb547a8345e668def.tar.gz
gentoo-fc1569545be66c72ab9f189fb547a8345e668def.tar.bz2
gentoo-fc1569545be66c72ab9f189fb547a8345e668def.zip
sys-auth/solo-python: add 0.0.31
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/solo-python/Manifest1
-rw-r--r--sys-auth/solo-python/solo-python-0.0.31.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-auth/solo-python/Manifest b/sys-auth/solo-python/Manifest
index 005109374d51..a7aac6559f29 100644
--- a/sys-auth/solo-python/Manifest
+++ b/sys-auth/solo-python/Manifest
@@ -1 +1,2 @@
DIST solo-python-0.0.30.tar.gz 34932 BLAKE2B 6787d9c6e102cd2cb5579be0cb3ffbbe76b3ae90f4fa6891b6a1ca3e76436568a949daa6796fc17c9868d10d5de3b0dd377619936eccb0d436a284a35efa40a9 SHA512 bba63e598ef585ef49e98f3ec2a79911cf8af3fc38c9407bd91b7500dc55bf84f365664e6f80ff0ed3553ce93f5d61ba11c5301e8b36d6000c7a922857adaa5e
+DIST solo-python-0.0.31.tar.gz 34959 BLAKE2B abc7bb014bb6eedcd0178cb600c626ca6e2b4773083916db698c0dd9639208206da010470f77813074137667afb5c6725311c3406762a8ab5a029e9966b227d6 SHA512 e8c81524b6d10bc38898b19e35ab2f7b95bea7906553de9e0598fc160b5b9b61f4f8b40e2238631738e1b69ef52652af1b3e84aa0a3552126929c4512210c1fa
diff --git a/sys-auth/solo-python/solo-python-0.0.31.ebuild b/sys-auth/solo-python/solo-python-0.0.31.ebuild
new file mode 100644
index 000000000000..cdac36e7295b
--- /dev/null
+++ b/sys-auth/solo-python/solo-python-0.0.31.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool and library for SoloKeys"
+HOMEPAGE="https://github.com/solokeys/solo-python"
+SRC_URI="https://github.com/solokeys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND=">=dev-python/click-7.1.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ >=dev-python/fido2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # For some reason the version file gets omitted by src_install (a bug in pyproject2setuppy?),
+ # and in any case there is no advantage to using one once a specific version has been released.
+ sed -i -e "s/^__version__ = open(.\+$/__version__ = '${PV}'/" solo/__init__.py || die "Failed to set the version number"
+ distutils-r1_src_prepare
+}