summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-27 11:50:39 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-27 12:20:37 +0100
commitb612b70dd282eb7c1f02a912474a7ed204aa107a (patch)
treee45c0060adb48f37049651596515a38209865254 /sys-block
parentsys-boot/milo: [QA] Do not install 'LICENSE' (diff)
downloadgentoo-b612b70dd282eb7c1f02a912474a7ed204aa107a.tar.gz
gentoo-b612b70dd282eb7c1f02a912474a7ed204aa107a.tar.bz2
gentoo-b612b70dd282eb7c1f02a912474a7ed204aa107a.zip
sys-block/qla-fc-firmware: Port to EAPI 6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/qla-fc-firmware/Manifest2
-rw-r--r--sys-block/qla-fc-firmware/qla-fc-firmware-20101015.ebuild16
2 files changed, 10 insertions, 8 deletions
diff --git a/sys-block/qla-fc-firmware/Manifest b/sys-block/qla-fc-firmware/Manifest
index 8136783cfd5c..bfb03dc085e1 100644
--- a/sys-block/qla-fc-firmware/Manifest
+++ b/sys-block/qla-fc-firmware/Manifest
@@ -1 +1 @@
-DIST qla-fc-firmware-20101015.tar.bz2 3237889 SHA256 e2951f8a130350ca38990afb60d16c4ea3262de5f9a7d9a75c88db04095bb6cb SHA512 19cd38a2a146cc3147840a2c87c0f44996896ff1b1961d1d858d054db890d6808c89bfe93e82a54536933180da3b8cc8e54a5f57d9c9edcb3129a11dbd394342 WHIRLPOOL 02e523b03e193b8473f89eab3de1914a92e67a4ddea324629b0ccf14fd0227b66d17587567f821262a2d535ca49e612b503eebdc198429eaa39b201669c6eb56
+DIST qla-fc-firmware-20101015.tar.bz2 3237889 BLAKE2B cc20a4fcebd851ef3aac09a89f431be0852cf10ec736a09cede0e96632c9282dffe23c230a718e3864bef86fbf15772c3e513746126df2ecda0366833ee91eea SHA512 19cd38a2a146cc3147840a2c87c0f44996896ff1b1961d1d858d054db890d6808c89bfe93e82a54536933180da3b8cc8e54a5f57d9c9edcb3129a11dbd394342
diff --git a/sys-block/qla-fc-firmware/qla-fc-firmware-20101015.ebuild b/sys-block/qla-fc-firmware/qla-fc-firmware-20101015.ebuild
index 67ef202859f6..520977c3787e 100644
--- a/sys-block/qla-fc-firmware/qla-fc-firmware-20101015.ebuild
+++ b/sys-block/qla-fc-firmware/qla-fc-firmware-20101015.ebuild
@@ -1,9 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
DESCRIPTION="QLogic Linux Fibre Channel HBA Firmware for ql2xxx cards"
HOMEPAGE="ftp://ftp.qlogic.com/outgoing/linux/firmware/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
LICENSE="qlogic-fibre-channel-firmware"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
@@ -13,8 +16,6 @@ IUSE=""
DEPEND=""
RDEPEND="!sys-kernel/linux-firmware"
-FW_BASENAME="ql2100_fw.bin ql2200_fw.bin ql2300_fw.bin ql2322_fw.bin ql2400_fw.bin ql2500_fw.bin ql6312_fw.bin"
-
src_install() {
# We must install this, say QLogic's people.
# They have claimed to me that the /license/ directory isn't sufficient, as
@@ -31,9 +32,10 @@ src_install() {
# Please see README.* as to why we do not use the MID/MIDX versions by
# default if they are newer.
# TODO: Provide a means to get them for people that really want them.
- for f in ${FW_BASENAME} ; do
- doins ${f}.*
- latest_f="$(ls ${f}.* |grep -v MID | sort -n | tail -n1)"
- dosym ${latest_f} /lib/firmware/${f}
+ local f fw_basename=( ql2100_fw.bin ql2200_fw.bin ql2300_fw.bin ql2322_fw.bin ql2400_fw.bin ql2500_fw.bin ql6312_fw.bin )
+ for f in "${fw_basename[@]}"; do
+ doins "${f}".*
+ latest_f="$(ls ${f}.* | grep -v MID | sort -n | tail -n1)"
+ dosym "${latest_f}" /lib/firmware/"${f}"
done
}