summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2021-10-27 13:25:41 -0400
committerMike Frysinger <vapier@gentoo.org>2021-10-27 13:25:51 -0400
commitd5cd05195c8193816d6800bc44c4875baa72c804 (patch)
treee6b98f0139a872656d7902172cbc5cc05bbf3e5d /sys-devel/crossdev/crossdev-20211027.ebuild
parentdev-python/google-api-python-client: Bump to 2.28.0 (diff)
downloadgentoo-d5cd05195c8193816d6800bc44c4875baa72c804.tar.gz
gentoo-d5cd05195c8193816d6800bc44c4875baa72c804.tar.bz2
gentoo-d5cd05195c8193816d6800bc44c4875baa72c804.zip
sys-devel/crossdev: version bump to 20211027
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'sys-devel/crossdev/crossdev-20211027.ebuild')
-rw-r--r--sys-devel/crossdev/crossdev-20211027.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/crossdev/crossdev-20211027.ebuild b/sys-devel/crossdev/crossdev-20211027.ebuild
new file mode 100644
index 000000000000..0c2fe30139d5
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20211027.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}