summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2015-08-09 15:16:47 -0400
committerMike Pagano <mpagano@gentoo.org>2015-08-09 15:16:47 -0400
commitf93b8a0a001a90b5bbc100a3d632d41669e35305 (patch)
tree60f55b009a13a016f7eb8334293335e8a9d6f1dd /sys-kernel/linux-docs
parentapp-editors/vim-qt: subslot perl dependency wrt bug #553160 (diff)
downloadgentoo-f93b8a0a001a90b5bbc100a3d632d41669e35305.tar.gz
gentoo-f93b8a0a001a90b5bbc100a3d632d41669e35305.tar.bz2
gentoo-f93b8a0a001a90b5bbc100a3d632d41669e35305.zip
sys-kernel/linux-docs: Add 4.1.4 linux docs.
Package-Manager: portage-2.2.20
Diffstat (limited to 'sys-kernel/linux-docs')
-rw-r--r--sys-kernel/linux-docs/Manifest1
-rw-r--r--sys-kernel/linux-docs/linux-docs-4.1.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/Manifest b/sys-kernel/linux-docs/Manifest
index 6143212acd14..5ef909cb7458 100644
--- a/sys-kernel/linux-docs/Manifest
+++ b/sys-kernel/linux-docs/Manifest
@@ -4,3 +4,4 @@ DIST linux-3.14.22.tar.xz 78451580 SHA256 77a0c7a41b1fc4232a959c539e48f98071769c
DIST linux-3.16.6.tar.xz 80524980 SHA256 31e9dcffd79933040b8a91d36ac1d75fa4ad554656665c3d9c8fbd9fa73006f2 SHA512 ef850b73d28f3432d55389a251bf4244c464af52ff02ed87a5707ff4467932b7b8f12182017f73e73671ae893b44e17e4f4414b023848b8ba4869b1cd3ac6086 WHIRLPOOL a23c1503bdaf3ffe2bc1ea2351d2a0612d20f6d144d5a2d2595fc051ac2292da84d91053c64f4391b91bcc46edf0fe0bee49329ff8ca70beafc04e50e4c0571b
DIST linux-3.17.1.tar.xz 80315188 SHA256 2c9c002cf9618962883d82ba3e1caaea29af4ea37147a82bad422afdc8d21dc2 SHA512 89c38d7b9dcc3f3de65b1f46266e1d02a2444316fac53fa70b49f6a01b42f420d87a0dcdd2a5730d7fb0453ace77e4b7ced5b80dcee5eaf65d8619bf0c1c93ec WHIRLPOOL e2eacae2ac42ea1e24d517ebd2f8b0ee06d9936fbf590e606236b66ab5b7634de6c63c01abbe01fcae5492d19d792fea453b907668aefb405a314301f5f7ea4e
DIST linux-3.4.104.tar.xz 67176948 SHA256 8bf42d8befdd61a296546dfb626eca7c108b7c3eb0c284f4bd4273c628e1c275 SHA512 a8d86b0fa9bbb602262f8e4155870a5e33224597030d6b6777480ea81127564d9bf94389d8adb59c8e9cec2f586f59031968d33ec3b6b82c10e13924c303872b WHIRLPOOL 95cb16ceab4899689145385c5acbe4cf46682e9f5258dc99b6b890347c06aba903858a0fd98d9d34a264a9db46c54e9fa6da0821bb33bd3a2a3fb6a82ba7f451
+DIST linux-4.1.4.tar.xz 83015496 SHA256 3ee2f2bdcb8ecf729fc7ed0545a6a2292f2853bd0eb259bc4124265a6ad4909f SHA512 a87b9692fe6f17c562c60a82640d26278ec6c6ce90c433b184162f216733e6a228ebb5a5d167e787bb260dcf90edc99413cf0e282744ed682539b171b1e616c3 WHIRLPOOL 666ed8c4cde164dd20264d49b4b3800a599ac020563c8181e5265639efe82406cb09663c86c83c228bdfc5d03b0364e058ac365c490cc0e066c49d42b0821967
diff --git a/sys-kernel/linux-docs/linux-docs-4.1.4.ebuild b/sys-kernel/linux-docs/linux-docs-4.1.4.ebuild
new file mode 100644
index 000000000000..8131eab685df
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-4.1.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="mirror://kernel/linux/kernel/v4.x/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE="html"
+DEPEND="app-text/docbook-sgml-utils
+ app-text/xmlto
+ sys-apps/sed
+ ~app-text/docbook-xml-dtd-4.1.2"
+RDEPEND=""
+
+src_prepare() {
+
+ sed -i \
+ -e "s:db2:docbook2:g" \
+ -e "s:/usr/local/man:${D}/usr/share/man:g" \
+ "${S}"/Documentation/DocBook/Makefile
+
+ # fix for parallel build as per bug #248337
+ sed -i \
+ -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
+ "${S}"/Makefile
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ emake mandocs || die "make mandocs failed"
+
+ if use html; then
+ emake htmldocs || die "make htmldocs failed"
+ fi
+}
+
+src_install() {
+ local file
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make installmandocs || die "make installmandocs failed"
+
+ if use html; then
+ # There is no subdirectory named "index"
+ dohtml Documentation/DocBook/index.html
+ rm Documentation/DocBook/index.html
+ for file in Documentation/DocBook/*.html; do
+ dohtml -r ${file/\.html/}
+ done
+ fi
+}