summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/cronutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/cronutils')
-rw-r--r--sys-process/cronutils/Manifest1
-rw-r--r--sys-process/cronutils/cronutils-1.5.ebuild23
-rw-r--r--sys-process/cronutils/metadata.xml18
3 files changed, 42 insertions, 0 deletions
diff --git a/sys-process/cronutils/Manifest b/sys-process/cronutils/Manifest
new file mode 100644
index 000000000000..793987022115
--- /dev/null
+++ b/sys-process/cronutils/Manifest
@@ -0,0 +1 @@
+DIST cronutils-1.5.tar.gz 8262 SHA256 3a358a73d945222a9d650190f5c038e771b2102cf5b7bda3863965eca873003c SHA512 24992f5f325b703e5c9b231744e320dacb442bb81725f49aefcf6376134e345254445cbf0f0a3c8353aa7ef77027b8f15709972b1332fe70e6e31e5aba5b688d WHIRLPOOL f277dc23738beab40d77adfc011533e80331eea22f86348d6a216cfebb52bd53662dc9389a65ec9f71f55bb2474f97dd030ffb8e5c8a14d6c8e1b075fb64f5aa
diff --git a/sys-process/cronutils/cronutils-1.5.ebuild b/sys-process/cronutils/cronutils-1.5.ebuild
new file mode 100644
index 000000000000..fd2375ef6127
--- /dev/null
+++ b/sys-process/cronutils/cronutils-1.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities to assist running batch processing jobs"
+HOMEPAGE="http://code.google.com/p/cronutils/"
+SRC_URI="http://cronutils.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="-D_XOPEN_SOURCE=500 ${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr install
+}
diff --git a/sys-process/cronutils/metadata.xml b/sys-process/cronutils/metadata.xml
new file mode 100644
index 000000000000..23f23b2beb69
--- /dev/null
+++ b/sys-process/cronutils/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <longdescription lang="en">
+ Utilities to assist running batch processing jobs.
+
+ * runalarm: Limit the run time of a process.
+ * runlock: Prevent concurrent runs of a process.
+ * runstat: Export statistics about a process's execution.
+ </longdescription>
+ <upstream>
+ <remote-id type="google-code">cronutils</remote-id>
+ </upstream>
+</pkgmetadata>