summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_scgi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_scgi')
-rw-r--r--www-apache/mod_scgi/Manifest1
-rw-r--r--www-apache/mod_scgi/files/20_mod_scgi.conf33
-rw-r--r--www-apache/mod_scgi/files/mod_scgi-1.14-apache-2.4.patch49
-rw-r--r--www-apache/mod_scgi/metadata.xml5
-rw-r--r--www-apache/mod_scgi/mod_scgi-1.14-r1.ebuild33
-rw-r--r--www-apache/mod_scgi/mod_scgi-1.14.ebuild30
6 files changed, 151 insertions, 0 deletions
diff --git a/www-apache/mod_scgi/Manifest b/www-apache/mod_scgi/Manifest
new file mode 100644
index 000000000000..5dedcd1ad0ca
--- /dev/null
+++ b/www-apache/mod_scgi/Manifest
@@ -0,0 +1 @@
+DIST scgi-1.14.tar.gz 29406 SHA256 0cde41e4ae58ea666f17f6b1984e8ed8ebaff92cabac4b1b36f86bc47eb18e75 SHA512 148986aab3a5579b7dd7d15583990844149b799df32221b4d2c354b11361f79727087d63ddd54227d2aae937253997774e521606c7baea6b808b9efef025a01a WHIRLPOOL 969babed626fba1280f46eee7c620c9d42da1ffdabbf7752b849a26704f214773f07aae41849c873ba22f8bdc0c4c7f54455c130ec2992a943accfb328a183c5
diff --git a/www-apache/mod_scgi/files/20_mod_scgi.conf b/www-apache/mod_scgi/files/20_mod_scgi.conf
new file mode 100644
index 000000000000..1b7b5962748d
--- /dev/null
+++ b/www-apache/mod_scgi/files/20_mod_scgi.conf
@@ -0,0 +1,33 @@
+<IfDefine SCGI>
+LoadModule scgi_module modules/mod_scgi.so
+
+# Apache2 example
+#<Location "/dynamic">
+# SetHandler scgi-handler
+# SCGIServer localhost:4000
+# SCGIHandler On
+# Options -Multiviews
+#</Location>
+#<LocationMatch "^/(dynamic|login)($|/)">
+# SetHandler scgi-handler
+# SCGIServer localhost:4000
+# SCGIHandler On
+# Options -Multiviews
+#</Location>
+#<Location "/foo">
+# SCGIServer localhost:4000
+# SCGIHandler On
+# Options -Multiviews
+#</Location>
+#<Location "/bar">
+# SCGIServer localhost:4001
+# SCGIHandler On
+# SCGIServerTimeout 10
+# Options -Multiviews
+#</Location>
+#<Location "/bar/images">
+# SCGIHander Off
+#</Location>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_scgi/files/mod_scgi-1.14-apache-2.4.patch b/www-apache/mod_scgi/files/mod_scgi-1.14-apache-2.4.patch
new file mode 100644
index 000000000000..8c1240b18c31
--- /dev/null
+++ b/www-apache/mod_scgi/files/mod_scgi-1.14-apache-2.4.patch
@@ -0,0 +1,49 @@
+--- a/apache2/mod_scgi.c
++++ b/apache2/mod_scgi.c
+@@ -135,16 +135,16 @@
+ return DECLINED;
+ }
+
+-static void log_err(const char *file, int line, request_rec *r,
++static void log_err(const char *file, int line, int index, request_rec *r,
+ apr_status_t status, const char *msg)
+ {
+- ap_log_rerror(file, line, APLOG_ERR, status, r, "scgi: %s", msg);
++ ap_log_rerror(file, line, index, APLOG_ERR, status, r, "scgi: %s", msg);
+ }
+
+-static void log_debug(const char *file, int line, request_rec *r, const
++static void log_debug(const char *file, int line, int index, request_rec *r, const
+ char *msg)
+ {
+- ap_log_rerror(file, line, APLOG_DEBUG, APR_SUCCESS, r, msg);
++ ap_log_rerror(file, line, index, APLOG_DEBUG, APR_SUCCESS, r, "%s", msg);
+ }
+
+ static char *http2env(apr_pool_t *p, const char *name)
+@@ -312,7 +312,7 @@
+ int i;
+ apr_status_t rv = 0;
+ apr_port_t port = 0;
+- GET_PORT(port, r->connection->remote_addr);
++ GET_PORT(port, r->useragent_addr);
+
+ log_debug(APLOG_MARK,r, "sending headers");
+ t = apr_table_make(r->pool, 40);
+@@ -324,14 +324,14 @@
+ buf = "0";
+ add_header(t, "CONTENT_LENGTH", buf);
+ add_header(t, "SCGI", SCGI_PROTOCOL_VERSION);
+- add_header(t, "SERVER_SOFTWARE", ap_get_server_version());
++ add_header(t, "SERVER_SOFTWARE", ap_get_server_banner());
+ add_header(t, "SERVER_PROTOCOL", r->protocol);
+ add_header(t, "SERVER_NAME", ap_get_server_name(r));
+ add_header(t, "SERVER_ADMIN", r->server->server_admin);
+ add_header(t, "SERVER_ADDR", r->connection->local_ip);
+ add_header(t, "SERVER_PORT", apr_psprintf(r->pool, "%u",
+ ap_get_server_port(r)));
+- add_header(t, "REMOTE_ADDR", r->connection->remote_ip);
++ add_header(t, "REMOTE_ADDR", r->useragent_ip);
+ add_header(t, "REMOTE_PORT", apr_psprintf(r->pool, "%d", port));
+ add_header(t, "REMOTE_USER", r->user);
+ add_header(t, "REQUEST_METHOD", r->method);
diff --git a/www-apache/mod_scgi/metadata.xml b/www-apache/mod_scgi/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_scgi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_scgi/mod_scgi-1.14-r1.ebuild b/www-apache/mod_scgi/mod_scgi-1.14-r1.ebuild
new file mode 100644
index 000000000000..7a738c4c6430
--- /dev/null
+++ b/www-apache/mod_scgi/mod_scgi-1.14-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit apache-module eutils
+
+DESCRIPTION="Apache module for a replacement of the CGI protocol, similar to FastCGI"
+HOMEPAGE="http://python.ca/scgi/ http://pypi.python.org/pypi/scgi"
+SRC_URI="http://python.ca/scgi/releases/scgi-${PV}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+DEPEND="~www-apps/scgi-${PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/scgi-${PV}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_FILE="${S}/apache2/.libs/${PN}.so"
+APACHE2_MOD_CONF="20_mod_scgi"
+APACHE2_MOD_DEFINE="SCGI"
+
+DOCFILES="PKG-INFO LICENSE.txt CHANGES.txt apache2/README.txt"
+
+need_apache2_4
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-apache-2.4.patch
+}
diff --git a/www-apache/mod_scgi/mod_scgi-1.14.ebuild b/www-apache/mod_scgi/mod_scgi-1.14.ebuild
new file mode 100644
index 000000000000..7427c41fb490
--- /dev/null
+++ b/www-apache/mod_scgi/mod_scgi-1.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit apache-module
+
+DESCRIPTION="Apache module for a replacement of the CGI protocol, similar to FastCGI"
+HOMEPAGE="http://python.ca/scgi/ http://pypi.python.org/pypi/scgi"
+SRC_URI="http://python.ca/scgi/releases/scgi-${PV}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~amd64 hppa ~ppc x86"
+IUSE=""
+
+DEPEND="~www-apps/scgi-${PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/scgi-${PV}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_FILE="${S}/apache2/.libs/${PN}.so"
+APACHE2_MOD_CONF="20_mod_scgi"
+APACHE2_MOD_DEFINE="SCGI"
+
+DOCFILES="PKG-INFO LICENSE.txt CHANGES.txt apache2/README.txt"
+
+need_apache2_2