summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/x11vnc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/x11vnc')
-rw-r--r--x11-misc/x11vnc/Manifest2
-rw-r--r--x11-misc/x11vnc/files/x11vnc-0.9.13-shm-cleanup.patch35
-rw-r--r--x11-misc/x11vnc/files/x11vnc-0.9.13-warnings.patch42
-rw-r--r--x11-misc/x11vnc/metadata.xml23
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.13-r1.ebuild76
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.13.ebuild74
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.13_p20150111.ebuild56
7 files changed, 308 insertions, 0 deletions
diff --git a/x11-misc/x11vnc/Manifest b/x11-misc/x11vnc/Manifest
new file mode 100644
index 000000000000..4a60226b5686
--- /dev/null
+++ b/x11-misc/x11vnc/Manifest
@@ -0,0 +1,2 @@
+DIST 82eb9752485db87c9c6d3d6bb4aa1ae7ac81174a.zip 1830730 SHA256 fc6a28df089e47b68931019ce038b6e2fcd78e93de7f6984a22262252d01c16f SHA512 0fa4f7b52442793ec1bd82c74f9d092c69262e4f1fa93584fef17bbe0e5cbde08bc5ad0924631801bb43b41d90c37077a317c61511553f98698096eab05791eb WHIRLPOOL f1a45b549fb6ff9bea2eb4e3719b5dd43a78f6f418c61691cebab313d56761147d928648e103c654309575bec7c716a6f1cd1ef7a9b484c09edee37233cb0ce7
+DIST x11vnc-0.9.13.tar.gz 2853769 SHA256 f6829f2e629667a5284de62b080b13126a0736499fe47cdb447aedb07a59f13b SHA512 7b24e495f29122032e1c8ced7f7d8e0a56a2a8263e761a50725320742c99a0fcd5680d13038dd5d47e1c05d3b889d0caa13ba0b1aeda6fa42d5fb5ef3c43f908 WHIRLPOOL d812b257e70d6caccc6669c7fca89cacc590b5908c7877f62bdd14a159b0712b5b60e8587b6a385a5a68c46e15296ab838b07196786ac354fccb0759725685c4
diff --git a/x11-misc/x11vnc/files/x11vnc-0.9.13-shm-cleanup.patch b/x11-misc/x11vnc/files/x11vnc-0.9.13-shm-cleanup.patch
new file mode 100644
index 000000000000..0d5d78bdae0d
--- /dev/null
+++ b/x11-misc/x11vnc/files/x11vnc-0.9.13-shm-cleanup.patch
@@ -0,0 +1,35 @@
+fix that is already in upstream x11vnc-0.9.14 dev
+
+from ChromiumOS:
+
+x11vnc: Fix shm close on early shutdown.
+
+Global structures {scanline,fullscreen,scanrect}_shm are initialized to
+zero, including the .shmid field. This creates problems when shutdown /
+clean_shm is called before these structures are properly initialized in
+initialize_polling_images. shm_delete will be called on the structure,
+and since the shmid isn't -1, shmctl(id, IPC_RMID...) will be called for
+id=0. id=0 is in fact a valid shmid, and it might belong to some other
+shared memory for some other processes, creating many potential problems.
+
+Fix is to initialize shmid to -1 to indicate that it is in fact
+uninitialized.
+
+https://chromium-review.googlesource.com/37971
+
+--- a/x11vnc/x11vnc_defs.c
++++ b/x11vnc/x11vnc_defs.c
+@@ -82,10 +82,10 @@
+ XImage *raw_fb_image = NULL; /* the raw fb */
+
+ /* corresponding shm structures */
+-XShmSegmentInfo scanline_shm;
+-XShmSegmentInfo fullscreen_shm;
++XShmSegmentInfo scanline_shm = {.shmid = -1};
++XShmSegmentInfo fullscreen_shm = {.shmid = -1};
+ XShmSegmentInfo *tile_row_shm; /* for all possible row runs */
+-XShmSegmentInfo snaprect_shm;
++XShmSegmentInfo snaprect_shm = {.shmid = -1};
+
+ /* rfb screen info */
+ rfbScreenInfoPtr screen = NULL;
diff --git a/x11-misc/x11vnc/files/x11vnc-0.9.13-warnings.patch b/x11-misc/x11vnc/files/x11vnc-0.9.13-warnings.patch
new file mode 100644
index 000000000000..f80e83f196bc
--- /dev/null
+++ b/x11-misc/x11vnc/files/x11vnc-0.9.13-warnings.patch
@@ -0,0 +1,42 @@
+--- x11vnc-0.9.13.orig/x11vnc/remote.c
++++ x11vnc-0.9.13/x11vnc/remote.c
+@@ -5860,7 +5860,7 @@
+ }
+ if (!strcmp(p, "vncdisplay")) {
+ snprintf(buf, bufn, "aro=%s:%s", p,
+- NONUL(vnc_desktop_name));
++ vnc_desktop_name);
+ goto qry;
+ }
+ if (!strcmp(p, "icon_mode")) {
+@@ -6062,7 +6062,7 @@
+ if (!strcmp(p, "h") || !strcmp(p, "help") ||
+ !strcmp(p, "V") || !strcmp(p, "version") ||
+ !strcmp(p, "lastmod")) {
+- snprintf(buf, bufn, "aro=%s:%s", p, NONUL(lastmod));
++ snprintf(buf, bufn, "aro=%s:%s", p, lastmod);
+ goto qry;
+ }
+ if (!strcmp(p, "bg")) {
+--- x11vnc-0.9.13.orig/x11vnc/sslhelper.c
++++ x11vnc-0.9.13/x11vnc/sslhelper.c
+@@ -4041,7 +4041,7 @@
+ strncpy(last_get, rcookie, 100);
+ if (db) fprintf(stderr, "last_get: '%s'\n", last_get);
+ }
+- if (rcookie && strstr(rcookie, "VncViewer.class")) {
++ if (strstr(rcookie, "VncViewer.class")) {
+ rfbLog("\n");
+ rfbLog("helper[%d]:\n", pid);
+ rfbLog("***********************************************************\n");
+--- x11vnc-0.9.13.orig/x11vnc/userinput.c
++++ x11vnc-0.9.13/x11vnc/userinput.c
+@@ -1305,7 +1305,7 @@
+ int font_size = 15;
+ int win_y, scr_y, loc_cut = 4*font_size, y_cut = 10*font_size;
+
+- if (!xrecord_set_by_keys || !xrecord_name_info) {
++ if (!xrecord_set_by_keys) {
+ return 0;
+ }
+ if (xrecord_name_info[0] == '\0') {
diff --git a/x11-misc/x11vnc/metadata.xml b/x11-misc/x11vnc/metadata.xml
new file mode 100644
index 000000000000..65577dd2b8e6
--- /dev/null
+++ b/x11-misc/x11vnc/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <longdescription>
+ The primary goal of this program is to create a portable and
+ simple command-line server utility that allows a VNC viewer
+ to connect to an actual X display.
+ </longdescription>
+ <use>
+ <flag name="system-libvncserver">Build x11vnc against the system
+ libvncserver (experimental)</flag>
+ <flag name="tk">Support the simple tcl/tk -gui option</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">libvncserver</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/x11vnc/x11vnc-0.9.13-r1.ebuild b/x11-misc/x11vnc/x11vnc-0.9.13-r1.ebuild
new file mode 100644
index 000000000000..3993d81eeabe
--- /dev/null
+++ b/x11-misc/x11vnc/x11vnc-0.9.13-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A VNC server for real X displays"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/"
+SRC_URI="mirror://sourceforge/libvncserver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="avahi crypt fbcon +jpeg ssl system-libvncserver threads tk xinerama +zlib"
+
+RDEPEND="
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libX11
+ >=x11-libs/libXtst-1.1.0
+ x11-libs/libXdamage
+ x11-libs/libXext
+ avahi? ( >=net-dns/avahi-0.6.4 )
+ ssl? ( dev-libs/openssl )
+ system-libvncserver? ( >=net-libs/libvncserver-0.9.7[threads=,jpeg=,zlib=] )
+ !system-libvncserver? (
+ zlib? ( sys-libs/zlib )
+ jpeg? ( virtual/jpeg:0 )
+ )
+ tk? ( dev-lang/tk )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/trapproto
+ x11-proto/recordproto
+ x11-proto/xproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+pkg_setup() {
+ if use avahi && ! use threads ; then
+ ewarn "Non-native avahi support has been enabled."
+ ewarn "Native avahi support can be enabled by also enabling the threads USE flag."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-warnings.patch \
+ "${FILESDIR}"/${P}-shm-cleanup.patch
+}
+
+src_configure() {
+ # --without-v4l because of missing video4linux 2.x support wrt #389079
+ econf \
+ $(use_with system-libvncserver) \
+ $(use_with xinerama) \
+ --without-v4l \
+ $(use_with fbcon fbdev) \
+ $(use_with crypt) \
+ $(use_with ssl crypto) \
+ $(use_with ssl) \
+ $(use_with avahi) \
+ $(use_with jpeg) \
+ $(use_with zlib) \
+ $(use_with threads pthread)
+}
+
+src_install() {
+ default
+ dodoc x11vnc/{ChangeLog,README}
+ # Remove include files, which conflict with net-libs/libvncserver
+ rm -rf "${ED%/}"/usr/include
+}
diff --git a/x11-misc/x11vnc/x11vnc-0.9.13.ebuild b/x11-misc/x11vnc/x11vnc-0.9.13.ebuild
new file mode 100644
index 000000000000..c8f68aa19ea2
--- /dev/null
+++ b/x11-misc/x11vnc/x11vnc-0.9.13.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A VNC server for real X displays"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/"
+SRC_URI="mirror://sourceforge/libvncserver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="avahi crypt fbcon +jpeg ssl system-libvncserver threads tk xinerama +zlib"
+
+RDEPEND="system-libvncserver? ( >=net-libs/libvncserver-0.9.7[threads=,jpeg=,zlib=] )
+ !system-libvncserver? (
+ zlib? ( sys-libs/zlib )
+ jpeg? ( virtual/jpeg:0 )
+ )
+ ssl? ( dev-libs/openssl )
+ tk? ( dev-lang/tk )
+ avahi? ( >=net-dns/avahi-0.6.4 )
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libX11
+ >=x11-libs/libXtst-1.1.0
+ x11-libs/libXdamage
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/inputproto
+ x11-proto/trapproto
+ x11-proto/recordproto
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+pkg_setup() {
+ if use avahi && ! use threads ; then
+ ewarn "Non-native avahi support has been enabled."
+ ewarn "Native avahi support can be enabled by also enabling the threads USE flag."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-warnings.patch
+}
+
+src_configure() {
+ # --without-v4l because of missing video4linux 2.x support wrt #389079
+ econf \
+ $(use_with system-libvncserver) \
+ $(use_with avahi) \
+ $(use_with xinerama) \
+ $(use_with ssl) \
+ $(use_with ssl crypto) \
+ $(use_with crypt) \
+ --without-v4l \
+ $(use_with jpeg) \
+ $(use_with zlib) \
+ $(use_with threads pthread) \
+ $(use_with fbcon fbdev)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc x11vnc/{ChangeLog,README}
+ # Remove include files, which conflict with net-libs/libvncserver
+ rm -rf "${D}"/usr/include
+}
diff --git a/x11-misc/x11vnc/x11vnc-0.9.13_p20150111.ebuild b/x11-misc/x11vnc/x11vnc-0.9.13_p20150111.ebuild
new file mode 100644
index 000000000000..840a8a9f9c44
--- /dev/null
+++ b/x11-misc/x11vnc/x11vnc-0.9.13_p20150111.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A VNC server for real X displays"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/"
+SRC_URI="https://github.com/LibVNC/x11vnc/archive/82eb9752485db87c9c6d3d6bb4aa1ae7ac81174a.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="avahi crypt fbcon ssl xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ >=x11-libs/libXtst-1.1.0
+ avahi? ( >=net-dns/avahi-0.6.4 )
+ ssl? ( dev-libs/openssl:= )
+ >=net-libs/libvncserver-0.9.8
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/trapproto
+ x11-proto/recordproto
+ x11-proto/xproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+S="${WORKDIR}/x11vnc-82eb9752485db87c9c6d3d6bb4aa1ae7ac81174a"
+
+DOCS=(ChangeLog README)
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # --without-v4l because of missing video4linux 2.x support wrt #389079
+ econf \
+ $(use_with avahi) \
+ $(use_with crypt) \
+ $(use_with fbcon fbdev) \
+ $(use_with ssl) \
+ $(use_with ssl crypto) \
+ --without-v4l \
+ $(use_with xinerama)
+}