summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/logfury/logfury-1.0.1.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/logfury/logfury-1.0.1.ebuild b/dev-python/logfury/logfury-1.0.1.ebuild
deleted file mode 100644
index 855401fe877a..000000000000
--- a/dev-python/logfury/logfury-1.0.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1
-
-DESCRIPTION="Boilerplate library for logging method calls"
-HOMEPAGE="
- https://github.com/reef-technologies/logfury
- https://pypi.org/project/logfury/"
-SRC_URI="
- https://github.com/reef-technologies/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="
- test? (
- dev-python/testfixtures[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # remove pin for old Pythons (sic!)
- sed -i -e '/setuptools_scm/d' setup.py || die
- distutils-r1_src_prepare
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}