summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python-dbusmock/Manifest1
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.27.5.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index 5476fd45b80e..f6c9b1d55816 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,2 +1 @@
-DIST python-dbusmock-0.27.5.tar.gz 89775 BLAKE2B 316bb1ae06c894702d54b7a54d0c422a877c50fb7e8aa4a1bb3c9ac342acdec8f6adaafea86afa5aa041414a283fdd284e27b58728efa234fb8bcbbf92b25f27 SHA512 6e5f5eddfc949c610b64a766434988c142397893e088b8522e6895e31383ec3c14d2f053f9aab17f00137e883a01bf95be35326f7ca97ee8c9780d6704e7d1dc
DIST python-dbusmock-0.28.4.gh.tar.gz 86900 BLAKE2B af6ca30e15e803e66aec63d40d56d121c93e9fe253d7640111104c8e8c0ea5e0491b53f551d6b454ae7370cbbb7f8fb14c07b5be92a8425efa39e04f962311f5 SHA512 f388425ebb68c20b5110a831879bee0d7d0a3941687fd61c9975c4aaa9950b05709e7fc2a9b885c89935a915f473bb7a9b97e93ca79cf3dc6769911a66aeaea7
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.27.5.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.27.5.ebuild
deleted file mode 100644
index 36786f746994..000000000000
--- a/dev-python/python-dbusmock/python-dbusmock-0.27.5.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Easily create mock objects on D-Bus for software testing"
-HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
-SRC_URI="
- https://github.com/martinpitt/python-dbusmock/releases/download/${PV}/${P}.tar.gz
-"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # needed for unittest discovery
- > tests/__init__.py || die
- # linter tests, fragile to newer linter versions
- rm tests/test_code.py || die
-
- # Test is removed in master
- # https://github.com/martinpitt/python-dbusmock/commit/424719793c0a8e15ee05451cd58e21fb09914453
- # https://github.com/martinpitt/python-dbusmock/issues/75
- rm tests/test_accounts_service.py dbusmock/templates/accounts_service.py || die
-
- distutils-r1_src_prepare
-}