summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 4b24b9ee85b7..11cc2ac9b84e 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -9,20 +9,21 @@ DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org/
https://github.com/keepassxreboot/keepassxc/"
-if [[ "${PV}" != *9999 ]] ; then
+if [[ "${PV}" = *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="develop"
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+else
if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz
+ -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/-}"
else
SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
-
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
- [[ "${PV}" != 9999 ]] && EGIT_BRANCH="master"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
LICENSE="LGPL-2.1 GPL-2 GPL-3"
@@ -68,6 +69,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.7.4-tests.patch"
+)
+
src_prepare() {
if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
printf '%s' "${PV}" > .version || die
@@ -89,6 +94,7 @@ src_configure() {
-DWITH_XC_AUTOTYPE="$(usex autotype)"
-DWITH_XC_DOCS="$(usex doc)"
-DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_BROWSER_PASSKEYS="$(usex browser)"
-DWITH_XC_BOTAN3=ON
-DWITH_XC_FDOSECRETS=ON
-DWITH_XC_KEESHARE="$(usex keeshare)"
@@ -99,7 +105,9 @@ src_configure() {
-DWITH_XC_X11="$(usex X)"
)
if [[ "${PV}" == *_beta* ]] ; then
- mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ mycmakeargs+=(
+ -DOVERRIDE_VERSION="${PV/_/-}"
+ )
fi
cmake_src_configure
}