summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/r10k')
-rw-r--r--app-admin/r10k/Manifest2
-rw-r--r--app-admin/r10k/metadata.xml16
-rw-r--r--app-admin/r10k/r10k-1.1.3-r1.ebuild58
-rw-r--r--app-admin/r10k/r10k-1.5.1.ebuild63
4 files changed, 139 insertions, 0 deletions
diff --git a/app-admin/r10k/Manifest b/app-admin/r10k/Manifest
new file mode 100644
index 000000000000..015969f3755c
--- /dev/null
+++ b/app-admin/r10k/Manifest
@@ -0,0 +1,2 @@
+DIST r10k-1.1.3.gem 30720 SHA256 4b4732046a7478f28668dd3db08ce2527bb45c6da83ec0c604f16d09fce9b91a SHA512 9ddb06c3535c4d5f4f0d8156ddf7671f248283874ef7fab4a2e9d00534e6d165e1b7a32937ecef8043a7fb8ff1143a9dd7bc388f0d7c810de86bc369a22fb502 WHIRLPOOL ea9b3a291cc581c719c2852a0d5f268be2389ed783368a0b20c6dc81b047d5725c60956de3282a353dfefd034a4be2eadaceba1a79ee9c0c16b3afaca3be2ac8
+DIST r10k-1.5.1.gem 164864 SHA256 4dd4edfb1b69400324780784bf214a80bec3d0dbd46bc94113683904d503fdb0 SHA512 4440a893aaa6ec0337f9347b620f92afd93099465c148bfe90cd44c2c6fe29cc8411b8c225044a9547d24a8857b580dcf2ea190bf64fe9ba180d1c5c3832d1dd WHIRLPOOL b8a3a49857bc97e4b1529c4a8f33ace1e6c1cca270bd4be3669494568bbc9a0b85e15419103bbb63622aadd3ad1453e11ae63b85b9c86a67d013962f4d7b2761
diff --git a/app-admin/r10k/metadata.xml b/app-admin/r10k/metadata.xml
new file mode 100644
index 000000000000..300319a1e57b
--- /dev/null
+++ b/app-admin/r10k/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury</name>
+ </maintainer>
+ <herd>sysadmin</herd>
+ <longdescription lang="en">
+ r10k provides a general purpose toolset for deploying Puppet environments and modules. It implements the Puppetfile format and provides a native implementation of Puppet dynamic environments.
+ </longdescription>
+ <upstream>
+ <remote-id type="rubyforge">r10k</remote-id>
+ <remote-id type="github">adrienthebo/r10k</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/r10k/r10k-1.1.3-r1.ebuild b/app-admin/r10k/r10k-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..20067fbf89f4
--- /dev/null
+++ b/app-admin/r10k/r10k-1.1.3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Puppet environment and module deployment"
+HOMEPAGE="http://github.com/adrienthebo/r10k"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+git"
+
+ruby_add_rdepend "
+ >=dev-ruby/colored-1.2
+ =dev-ruby/cri-2*
+ >=dev-ruby/systemu-2.5.2
+ >=dev-ruby/log4r-1.1.10
+ dev-ruby/json"
+
+RDEPEND="${RDEPEND} git? ( >=dev-vcs/git-1.6.6 )"
+
+all_ruby_prepare() {
+ sed -i -e 's/json_pure/json/' \
+ -e '/cri/ s/2.4.0/2.4/' \
+ -e '/systemu/ s/2.5.2/2.5/' \
+ -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from 1.1.0 and are using multiple sources, please read"
+ ewarn "this. (If not, feel free to continue with your regularly scheduled day.)"
+ ewarn
+ ewarn "GH-48 (https://github.com/adrienthebo/r10k/issues/48) introduced the ability"
+ ewarn "for environments to be prefixed with the source name so that multiple sources"
+ ewarn "installed into the same directory would not overwrite each other. However"
+ ewarn "prefixing was automatically enabled and would break existing setups where"
+ ewarn "multiple sources were cloned into different directories."
+ ewarn
+ ewarn "Because this introduced a breaking change, SemVer dictates that the automatic"
+ ewarn "prefixing has to be rolled back. Prefixing can be enabled but always defaults"
+ ewarn "to off. If you are relying on this behavior you will need to update your r10k.yaml"
+ ewarn "to enable prefixing on a per-source basis."
+ ewarn
+ ewarn "Please see the issue (https://github.com/adrienthebo/r10k/issues/48) for more"
+ ewarn "information."
+}
diff --git a/app-admin/r10k/r10k-1.5.1.ebuild b/app-admin/r10k/r10k-1.5.1.ebuild
new file mode 100644
index 000000000000..6610f6121d98
--- /dev/null
+++ b/app-admin/r10k/r10k-1.5.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Puppet environment and module deployment"
+HOMEPAGE="http://github.com/adrienthebo/r10k"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+git"
+
+ruby_add_rdepend "
+ >=dev-ruby/colored-1.2
+ =dev-ruby/cri-2.7*
+ >=dev-ruby/systemu-2.5.2
+ >=dev-ruby/log4r-1.1.10
+ >=dev-ruby/faraday-0.9.0
+ >=dev-ruby/faraday_middleware-0.9.0
+ >=dev-ruby/faraday_middleware-multi_json-0.0.6
+ >=dev-ruby/multi_json-1.10
+ >=dev-ruby/semantic_puppet-0.1.1
+ dev-ruby/json"
+
+RDEPEND="${RDEPEND} git? ( >=dev-vcs/git-1.6.6 )"
+
+all_ruby_prepare() {
+ sed -i -e 's/json_pure/json/' \
+ -e '/cri/ s/2\.6\../2.7/' \
+ -e '/systemu/ s/2.5.2/2.5/' \
+ -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from 1.1.0 and are using multiple sources, please read"
+ ewarn "this. (If not, feel free to continue with your regularly scheduled day.)"
+ ewarn
+ ewarn "GH-48 (https://github.com/adrienthebo/r10k/issues/48) introduced the ability"
+ ewarn "for environments to be prefixed with the source name so that multiple sources"
+ ewarn "installed into the same directory would not overwrite each other. However"
+ ewarn "prefixing was automatically enabled and would break existing setups where"
+ ewarn "multiple sources were cloned into different directories."
+ ewarn
+ ewarn "Because this introduced a breaking change, SemVer dictates that the automatic"
+ ewarn "prefixing has to be rolled back. Prefixing can be enabled but always defaults"
+ ewarn "to off. If you are relying on this behavior you will need to update your r10k.yaml"
+ ewarn "to enable prefixing on a per-source basis."
+ ewarn
+ ewarn "Please see the issue (https://github.com/adrienthebo/r10k/issues/48) for more"
+ ewarn "information."
+}