summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/twittering-mode')
-rw-r--r--app-emacs/twittering-mode/Manifest2
-rw-r--r--app-emacs/twittering-mode/metadata.xml11
-rw-r--r--app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild43
-rw-r--r--app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild43
-rw-r--r--app-emacs/twittering-mode/twittering-mode-9999.ebuild43
5 files changed, 142 insertions, 0 deletions
diff --git a/app-emacs/twittering-mode/Manifest b/app-emacs/twittering-mode/Manifest
new file mode 100644
index 000000000000..173bf340891c
--- /dev/null
+++ b/app-emacs/twittering-mode/Manifest
@@ -0,0 +1,2 @@
+DIST twittering-mode-2.0.0.tar.gz 615223 SHA256 164f6c46eae1e8ac65c60bdd40fb315df0044a5819ef25ce5ebc639b2b4ac1cd SHA512 318768c54c99c03c7641bfeb8396fdcaf65752121da6a64e6af9c071b6c429f73e44d1698df600915c4c7042233ef96cf86c037eece21b00d8e52a01ae569601 WHIRLPOOL 4b686e543a3b9ba0bc176141f6f6908a02cbd4c81984c5518092d489613595697d6bed1c7abc29675fcaa50b8fb961c413da5f69ee4640072b8755a8d81b5817
+DIST twittering-mode-3.0.0.tar.gz 1363235 SHA256 4848c4df0aad547d77412d04ad5f2c5c690a853cc39605a0a220fdfe828e350a SHA512 c696a8f31abcf6944c127575719d3e9b24a2bfb6271e0193e2a6faa8137c6468c7686b88d1e4ec0c3cc3b833e26853b435726d1acb422e9f37d3c0334e278494 WHIRLPOOL f926861a842bd1325f103ae2f0178b543e6a3c8cc366fbbbaf71005d200927c9d9286edd302517897099020e30708f835e97483723fb20023714f168e606b7c8
diff --git a/app-emacs/twittering-mode/metadata.xml b/app-emacs/twittering-mode/metadata.xml
new file mode 100644
index 000000000000..3da2601fe3c2
--- /dev/null
+++ b/app-emacs/twittering-mode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<maintainer>
+ <email>naota@gentoo.org</email>
+</maintainer>
+<upstream>
+ <remote-id type="sourceforge">twmode</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
new file mode 100644
index 000000000000..c79b9ea0e1ed
--- /dev/null
+++ b/app-emacs/twittering-mode/twittering-mode-2.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp elisp-common eutils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/hayamiz/twittering-mode.git"
+ inherit git-2
+ SRC_URI=""
+ KEYWORDS=""
+ IUSE="doc"
+else
+ SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RESTRICT="test"
+ IUSE=""
+fi
+
+DESCRIPTION="Emacs major mode for Twitter"
+HOMEPAGE="http://twmode.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="app-crypt/gnupg"
+
+src_compile() {
+ elisp-compile twittering-mode.el || die
+ [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ elisp-install ${PN} twittering-mode.el *.elc || die
+}
diff --git a/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild b/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
new file mode 100644
index 000000000000..c79b9ea0e1ed
--- /dev/null
+++ b/app-emacs/twittering-mode/twittering-mode-3.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp elisp-common eutils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/hayamiz/twittering-mode.git"
+ inherit git-2
+ SRC_URI=""
+ KEYWORDS=""
+ IUSE="doc"
+else
+ SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RESTRICT="test"
+ IUSE=""
+fi
+
+DESCRIPTION="Emacs major mode for Twitter"
+HOMEPAGE="http://twmode.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="app-crypt/gnupg"
+
+src_compile() {
+ elisp-compile twittering-mode.el || die
+ [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ elisp-install ${PN} twittering-mode.el *.elc || die
+}
diff --git a/app-emacs/twittering-mode/twittering-mode-9999.ebuild b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
new file mode 100644
index 000000000000..c79b9ea0e1ed
--- /dev/null
+++ b/app-emacs/twittering-mode/twittering-mode-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp elisp-common eutils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/hayamiz/twittering-mode.git"
+ inherit git-2
+ SRC_URI=""
+ KEYWORDS=""
+ IUSE="doc"
+else
+ SRC_URI="mirror://sourceforge/twmode/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RESTRICT="test"
+ IUSE=""
+fi
+
+DESCRIPTION="Emacs major mode for Twitter"
+HOMEPAGE="http://twmode.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="app-crypt/gnupg"
+
+src_compile() {
+ elisp-compile twittering-mode.el || die
+ [ "${PV}" = "9999" ] && use doc && emake -C doc/manual
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ [ "${PV}" = "9999" ] && use doc && dodoc doc/manual/twmode/twmode.html
+ elisp-install ${PN} twittering-mode.el *.elc || die
+}