summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/go-etcd')
-rw-r--r--dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild6
-rw-r--r--dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild4
-rw-r--r--dev-db/go-etcd/go-etcd-2.0.0.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild b/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild
index 798b7e5544c3..e7ea9c19b91f 100644
--- a/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild
+++ b/dev-db/go-etcd/go-etcd-0_p20141013-r1.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils
+inherit eutils vcs-clean
+
GO_PN=github.com/coreos/${PN}
DESCRIPTION="Go client library for etcd"
+
HOMEPAGE="https://github.com/coreos/go-etcd"
EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
diff --git a/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild b/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild
index 78e82a0d6773..8080eefda579 100644
--- a/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild
+++ b/dev-db/go-etcd/go-etcd-2.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -6,6 +6,8 @@ EAPI=5
GO_PN=github.com/coreos/${PN}
EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"
+inherit vcs-clean
+
DESCRIPTION="Go client library for etcd"
HOMEPAGE="https://github.com/coreos/go-etcd"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
diff --git a/dev-db/go-etcd/go-etcd-2.0.0.ebuild b/dev-db/go-etcd/go-etcd-2.0.0.ebuild
index cec9a8d32864..b47229902f49 100644
--- a/dev-db/go-etcd/go-etcd-2.0.0.ebuild
+++ b/dev-db/go-etcd/go-etcd-2.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils
+inherit eutils vcs-clean
GO_PN=github.com/coreos/${PN}
EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"