summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/julia/files/julia-1.0.0-fix_build_system.patch')
-rw-r--r--dev-lang/julia/files/julia-1.0.0-fix_build_system.patch27
1 files changed, 19 insertions, 8 deletions
diff --git a/dev-lang/julia/files/julia-1.0.0-fix_build_system.patch b/dev-lang/julia/files/julia-1.0.0-fix_build_system.patch
index 1ed19d6e06e8..028a2f7e08cc 100644
--- a/dev-lang/julia/files/julia-1.0.0-fix_build_system.patch
+++ b/dev-lang/julia/files/julia-1.0.0-fix_build_system.patch
@@ -1,8 +1,8 @@
diff --git a/Make.inc b/Make.inc
-index 8e0df61..5747a1c 100644
+index 8cb2c1014..d3be9de8e 100644
--- a/Make.inc
+++ b/Make.inc
-@@ -181,7 +181,7 @@ USE_GPL_LIBS ?= 1
+@@ -178,7 +178,7 @@ USE_GPL_LIBS ?= 1
# Directories where said libraries get installed to
prefix ?= $(BUILDROOT)/julia-$(JULIA_COMMIT)
bindir := $(prefix)/bin
@@ -11,7 +11,7 @@ index 8e0df61..5747a1c 100644
libexecdir := $(prefix)/libexec
datarootdir := $(prefix)/share
docdir := $(datarootdir)/doc/julia
-@@ -413,7 +413,7 @@ ifneq ($(OS), WINNT)
+@@ -410,7 +410,7 @@ ifneq ($(OS), WINNT)
JCXXFLAGS += -pedantic
endif
DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
@@ -20,7 +20,7 @@ index 8e0df61..5747a1c 100644
endif
ifeq ($(USECLANG),1)
-@@ -424,7 +424,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+@@ -421,7 +421,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
JCPPFLAGS := -fasynchronous-unwind-tables
JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
@@ -29,7 +29,7 @@ index 8e0df61..5747a1c 100644
ifeq ($(OS), Darwin)
ifeq ($(USE_LIBCPP), 1)
MACOSX_VERSION_MIN := 10.8
-@@ -453,7 +453,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+@@ -450,7 +450,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
JCPPFLAGS :=
JCXXFLAGS := -pipe $(fPIC) -fno-rtti
DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
@@ -39,7 +39,7 @@ index 8e0df61..5747a1c 100644
ifeq ($(USECCACHE), 1)
diff --git a/doc/Makefile b/doc/Makefile
-index 89b7988..c3125fd 100644
+index 89b79880d..c3125fde1 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -29,7 +29,7 @@ deps: UnicodeData.txt
@@ -52,10 +52,10 @@ index 89b7988..c3125fd 100644
cleanall: clean
diff --git a/src/Makefile b/src/Makefile
-index 20da34d..84eae21 100644
+index 257152d24..240a4a350 100644
--- a/src/Makefile
+++ b/src/Makefile
-@@ -88,16 +88,7 @@ UV_HEADERS += uv/*.h
+@@ -85,16 +85,7 @@ UV_HEADERS += uv/*.h
endif
PUBLIC_HEADER_TARGETS := $(addprefix $(build_includedir)/julia/,$(notdir $(PUBLIC_HEADERS)) $(UV_HEADERS))
@@ -73,3 +73,14 @@ index 20da34d..84eae21 100644
COMMON_LIBS := -L$(build_shlibdir) -L$(build_libdir) $(LIBUV) $(LIBUTF8PROC) $(NO_WHOLE_ARCHIVE) $(LLVMLINK) $(OSLIBS)
DEBUG_LIBS := $(WHOLE_ARCHIVE) $(BUILDDIR)/flisp/libflisp-debug.a $(WHOLE_ARCHIVE) $(BUILDDIR)/support/libsupport-debug.a $(COMMON_LIBS)
+
+--- a/base/Makefile 2018-08-10 23:56:13.825429621 -0400
++++ b/base/Makefile 2018-08-10 23:43:29.461769645 -0400
+@@ -207,7 +207,6 @@
+ ln -sf "$$REALPATH" "$@"
+ ifneq ($(USE_SYSTEM_LLVM),0)
+ ifneq ($(USE_LLVM_SHLIB),0)
+-SYMLINK_SYSTEM_LIBRARIES += symlink_libLLVM
+ endif
+ endif
+