summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_deriving_yojson')
-rw-r--r--dev-ml/ppx_deriving_yojson/Manifest1
-rw-r--r--dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving_yojson/Manifest b/dev-ml/ppx_deriving_yojson/Manifest
index 3474db68ca3e..4124abe6e102 100644
--- a/dev-ml/ppx_deriving_yojson/Manifest
+++ b/dev-ml/ppx_deriving_yojson/Manifest
@@ -1 +1,2 @@
DIST ppx_deriving_yojson-3.6.1.tar.gz 19477 BLAKE2B f7b4e34e1c5ca77af6dbe6f4639c00a3b47076e2cf1f79b157a4c8f9aef34ec0e95e2c6c805fe9d0f9fa0ec72ea0672696b7e7a21d0a7d93764fad2e8d89a15a SHA512 b1bf04f77e1c1a887352b21cfd43a67d37de9f61a70f89d06828c7d9611027711a600b22e4bbc95ab128511a48fce3ae1a1c7a655f25c4bb2b6944444cea4989
+DIST ppx_deriving_yojson-3.7.0.tar.gz 20027 BLAKE2B f89bae5542ab551da13bbfdf4bb3da359e0bad65b1700bcdcfefd4dc42b70c5c17133bfbe8ef9cbcac7b5d2630b95b81de95510a9152260874911bb72fb659ec SHA512 6aa8b3a6e60afd1ce68995bad6776c975b3640303b2049233e661c46300abea1f48916d4e876412de49f35744f31b99c29736e2bb974e1b4a494b0932bbd6e80
diff --git a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild
new file mode 100644
index 000000000000..d8677fbe1e82
--- /dev/null
+++ b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="JSON codec generator for OCaml"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving_yojson/"
+SRC_URI="https://github.com/ocaml-ppx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/ppxlib-0.26.0:=
+ dev-ml/ppx_deriving:=
+ dev-ml/result:=
+ dev-ml/yojson:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"