summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-9999.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-9999.ebuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
index 57cbb8ced996..e258fe5491b9 100644
--- a/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-9999.ebuild
@@ -35,15 +35,8 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" "${FILESDIR}/argparse.patch" "${FILESDIR}/ros_packages.patch" )
python_test() {
nosetests -s --tests test || die
}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Avoid recursing in the whole hierarchy
- dodir /usr/
- touch "${ED}/usr/CATKIN_IGNORE"
-}