summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/git-review')
-rw-r--r--dev-python/git-review/Manifest1
-rw-r--r--dev-python/git-review/git-review-2.3.0.ebuild34
-rw-r--r--dev-python/git-review/git-review-9999.ebuild16
3 files changed, 45 insertions, 6 deletions
diff --git a/dev-python/git-review/Manifest b/dev-python/git-review/Manifest
index 53e95fdd7ef2..38968e5a481a 100644
--- a/dev-python/git-review/Manifest
+++ b/dev-python/git-review/Manifest
@@ -1 +1,2 @@
DIST git-review-2.2.0.tar.gz 64905 BLAKE2B a08b489bb4b53a9cc6510b11238bc947334a187e0ec7dad7e1240cf3efb110a5310cfe4f3278af9311108fcb0b915a9d1eabdd2aeabab3fed0a939cba9f88ae2 SHA512 9a33f6a1e60b0679b248db818a2a4559b4ee6a6b765f2e6a16fd566fd85587be363f837da2118e75bd3e6d54ba3dcc177d3d678d927d75cca6d8ad6ed4e8d4f7
+DIST git-review-2.3.0.tar.gz 66005 BLAKE2B b074811614093058525ec817770d9d1d0d0adc4f154ec7a8882406c1954672063e3cd58df28d0ce17735b5a135f0a6be97657207e16dbe8b7719e9b6f77aea28 SHA512 841ea039e73e2571ee01ba08781d82c5ee0c136be092d2f7ff44e59284f2e77d57537ef5aef3eaf24a0f93f63106fd2404e1ec89745a723386944b5e0b32faf0
diff --git a/dev-python/git-review/git-review-2.3.0.ebuild b/dev-python/git-review/git-review-2.3.0.ebuild
new file mode 100644
index 000000000000..16e5454edee8
--- /dev/null
+++ b/dev-python/git-review/git-review-2.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to submit code to Gerrit"
+HOMEPAGE="https://git.openstack.org/cgit/openstack-infra/git-review"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/opendev/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ >=dev-python/pbr-4.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i -e '/manpages/,+1d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/git-review/git-review-9999.ebuild b/dev-python/git-review/git-review-9999.ebuild
index bd9c8e269e6b..16e5454edee8 100644
--- a/dev-python/git-review/git-review-9999.ebuild
+++ b/dev-python/git-review/git-review-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
-DISTUTILS_USE_SETUPTOOLS=
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -19,10 +20,13 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
-DEPEND=">=dev-python/pbr-4.1.0[${PYTHON_USEDEP}]"
-RDEPEND=">=dev-python/requests-1.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/pbr-4.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+"
python_prepare_all() {
sed -i -e '/manpages/,+1d' setup.cfg || die