summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/muon')
-rw-r--r--dev-util/muon/files/muon-0.1.0-test-Wincompatible-function-pointer-types.patch28
-rw-r--r--dev-util/muon/muon-0.1.0-r1.ebuild1
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/muon/files/muon-0.1.0-test-Wincompatible-function-pointer-types.patch b/dev-util/muon/files/muon-0.1.0-test-Wincompatible-function-pointer-types.patch
new file mode 100644
index 000000000000..cdf0ebd5ceff
--- /dev/null
+++ b/dev-util/muon/files/muon-0.1.0-test-Wincompatible-function-pointer-types.patch
@@ -0,0 +1,28 @@
+From 5362fa8b5182c72d4d58b6569e65c0bdd988320e Mon Sep 17 00:00:00 2001
+From: Stone Tickle <lattis@mochiro.moe>
+Date: Sat, 17 Dec 2022 20:23:59 -0500
+Subject: [PATCH] fix signature of thread entrypoint function
+
+---
+https://git.sr.ht/~lattis/muon/commit/5362fa8b5182c72d4d58b6569e65c0bdd988320e
+https://bugs.gentoo.org/885567
+
+ tests/project/common/94 threads/threadprog.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/project/common/94 threads/threadprog.c b/tests/project/common/94 threads/threadprog.c
+index 7bfb7c44..787b8472 100644
+--- a/tests/project/common/94 threads/threadprog.c
++++ b/tests/project/common/94 threads/threadprog.c
+@@ -22,7 +22,7 @@ int main(void) {
+ #include<pthread.h>
+ #include<stdio.h>
+
+-void* main_func(void) {
++void *main_func(void *_) {
+ printf("Printing from a thread.\n");
+ return NULL;
+ }
+--
+2.34.5
+
diff --git a/dev-util/muon/muon-0.1.0-r1.ebuild b/dev-util/muon/muon-0.1.0-r1.ebuild
index e3277363ba42..8873dd97ce3d 100644
--- a/dev-util/muon/muon-0.1.0-r1.ebuild
+++ b/dev-util/muon/muon-0.1.0-r1.ebuild
@@ -43,6 +43,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/muon-0.1.0-fix-potential-overflow.patch"
+ "${FILESDIR}/muon-0.1.0-test-Wincompatible-function-pointer-types.patch"
)
python_check_deps() {