summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/gargoyle/Manifest1
-rw-r--r--games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch31
-rw-r--r--games-engines/gargoyle/gargoyle-2011.1-r1.ebuild118
3 files changed, 0 insertions, 150 deletions
diff --git a/games-engines/gargoyle/Manifest b/games-engines/gargoyle/Manifest
index 63d013dc8748..6e8c1f0c0fd4 100644
--- a/games-engines/gargoyle/Manifest
+++ b/games-engines/gargoyle/Manifest
@@ -1,2 +1 @@
-DIST gargoyle-2011.1-sources.zip 11291660 BLAKE2B aac47c41bd02e772c4717dfdeae8678105f72704641ea3df39105d412afe61734cc43f863b9556e38ea34287259df9f4d72ae93b3092d0372434b9f59f99483d SHA512 65159580cf3494944f841c44320135580557258e37ad5523ae3ea30555c19834a2793231a8e42c217e5c1d055d50ed6a20d372d6302e880a2818bc4ea59b226f
DIST gargoyle-2019.1.1.tar.gz 14700448 BLAKE2B b5e6d43349d01fe3484abc7779cfe3f1e94c3f6d647d338f8acbfe97d160da53b6297273e67f84eb0409623bbb4c0d8e3008d42b16a800d756be71a02538969a SHA512 0d1f2724bd6227142eb67c146557a992a6d62af172398c9961511ce5c080e517d1e12ca9bc6be27c1893e404026256257bf3a04cb05923723c0886f111adc4e3
diff --git a/games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch b/games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch
deleted file mode 100644
index 6b66328da016..000000000000
--- a/games-engines/gargoyle/files/gargoyle-2011.1-desktopfile.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Tue Aug 21 19:06:54 UTC 2012
-Subject: desktop file
-
-fix QA issues:
-
-# desktop-file-validate /usr/share/applications/gargoyle.desktop
-/usr/share/applications/gargoyle.desktop: error: file contains at least one line ending with a carriage return, while lines should only be separated by a line feed character. First such line is: "[Desktop Entry]"
-/usr/share/applications/gargoyle.desktop: error: (will be fatal in the future): value "gargoyle-house.png" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
-
---- garglk/gargoyle.desktop
-+++ garglk/gargoyle.desktop
-@@ -1,9 +1,9 @@
--[Desktop Entry]
--Version=1.0
--Type=Application
--Name=Gargoyle
--GenericName=Interactive Fiction interpreter
--Comment=Interactive Fiction multi-interpreter that supports all major IF formats
--Icon=gargoyle-house.png
--Exec=gargoyle
--Categories=Game;
-+[Desktop Entry]
-+Version=1.0
-+Type=Application
-+Name=Gargoyle
-+GenericName=Interactive Fiction interpreter
-+Comment=Interactive Fiction multi-interpreter that supports all major IF formats
-+Icon=gargoyle-house
-+Exec=gargoyle
-+Categories=Game;
diff --git a/games-engines/gargoyle/gargoyle-2011.1-r1.ebuild b/games-engines/gargoyle/gargoyle-2011.1-r1.ebuild
deleted file mode 100644
index 82e11b237828..000000000000
--- a/games-engines/gargoyle/gargoyle-2011.1-r1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Regarding licenses: libgarglk is licensed under the GPLv2. Bundled
-# interpreters are licensed under GPLv2, BSD or MIT license, except:
-# - glulxe: custom license, see "terps/glulxle/README"
-# - hugo: custom license, see "licenses/HUGO License.txt"
-# Since we don't compile or install any of the bundled fonts, their licenses
-# don't apply. (Fonts are installed through dependencies instead.)
-
-EAPI=6
-inherit eutils flag-o-matic gnome2-utils multilib multiprocessing toolchain-funcs
-
-DESCRIPTION="An Interactive Fiction (IF) player supporting all major formats"
-HOMEPAGE="http://ccxvii.net/gargoyle/"
-SRC_URI="https://garglk.googlecode.com/files/${P}-sources.zip"
-
-LICENSE="BSD GPL-2 MIT Hugo Glulxe"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- media-fonts/libertine
- media-fonts/liberation-fonts
- media-libs/freetype:2
- media-libs/libpng:0
- media-libs/sdl-mixer
- media-libs/sdl-sound[modplug,mp3,vorbis]
- sys-libs/zlib
- virtual/jpeg:0
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-util/ftjam
- virtual/pkgconfig"
-
-S=${WORKDIR}
-
-src_prepare() {
- # Substitute custom CFLAGS/LDFLAGS.
- sed -i -e \
- "/^\s*OPTIM = / {
- s/ \(-O.*\)\? ;/ ;/
- a LINKFLAGS = ${LDFLAGS} ;
- a SHRLINKFLAGS = ${LDFLAGS} ;
- }" Jamrules || die
-
- # Don't link against libraries used indirectly through SDL_sound.
- sed -i -e "/GARGLKLIBS/s/-lsmpeg -lvorbisfile//g" Jamrules || die
-
- # Convert garglk.ini to UNIX format.
- edos2unix garglk/garglk.ini
-
- epatch "${FILESDIR}"/${P}-desktopfile.patch
- append-cflags -std=gnu89 # build with gcc5 (bug #573378)
- append-cxxflags -std=gnu++11 # code assumes C++11 semantics (bug #642996)
- default
-}
-
-src_compile() {
- # build system messes up flags and toolchain completely
- # append flags to compiler commands to have consistent behavior
- jam \
- -sAR="$(tc-getAR) cru" \
- -sCC="$(tc-getCC) ${CFLAGS}" \
- -sCCFLAGS="" \
- -sC++="$(tc-getCXX) ${CXXFLAGS}" \
- -sCXX="$(tc-getCXX) ${CXXFLAGS}" \
- -sC++FLAGS="" \
- -sGARGLKINI="/etc/garglk.ini" \
- -sUSESDL=yes \
- -sBUNDLEFONTS=no \
- -dx \
- -j$(makeopts_jobs) || die
-}
-
-src_install() {
- DESTDIR="${D}" \
- _BINDIR="/usr/libexec/${PN}" \
- _APPDIR="/usr/libexec/${PN}" \
- _LIBDIR="/usr/$(get_libdir)" \
- EXEMODE=755 \
- FILEMODE=755 \
- jam install || die
-
- # Install config file.
- insinto "/etc"
- newins garglk/garglk.ini garglk.ini
-
- # Install application entry and icon.
- domenu garglk/${PN}.desktop
- doicon -s 32 garglk/${PN}-house.png
-
- # Symlink binaries to avoid name clashes.
- for terp in advsys agility alan2 alan3 frotz geas git glulxe hugo jacl \
- level9 magnetic nitfol scare tadsr
- do
- dosym "../libexec/${PN}/${terp}" \
- "/usr/bin/${PN}-${terp}"
- done
-
- # Also symlink the main binary since it resides in libexec.
- dosym "../libexec/${PN}/${PN}" \
- "/usr/bin/${PN}"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}