summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-shell/gnome-shell-3.22.1.ebuild')
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.22.1.ebuild49
1 files changed, 19 insertions, 30 deletions
diff --git a/gnome-base/gnome-shell/gnome-shell-3.22.1.ebuild b/gnome-base/gnome-shell/gnome-shell-3.22.1.ebuild
index c5e7062f9bb9..60739bd6bcf9 100644
--- a/gnome-base/gnome-shell/gnome-shell-3.22.1.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-3.22.1.ebuild
@@ -6,14 +6,14 @@ EAPI=6
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python{3_4,3_5} )
-inherit autotools eutils gnome2 multilib pax-utils python-r1 systemd
+inherit autotools gnome2 multilib pax-utils python-r1 systemd
DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell"
LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
-IUSE="+bluetooth +networkmanager +nls -openrc-force"
+IUSE="+bluetooth +networkmanager nsplugin +nls -openrc-force"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
@@ -30,13 +30,9 @@ COMMON_DEPEND="
>=dev-libs/gobject-introspection-1.49.1:=
dev-libs/libical:=
>=x11-libs/gtk+-3.15.0:3[introspection]
- >=media-libs/clutter-1.21.5:1.0[introspection]
- >=dev-libs/json-glib-0.13.2
>=dev-libs/libcroco-0.6.8:0.6
>=gnome-base/gnome-desktop-3.7.90:3=[introspection]
>=gnome-base/gsettings-desktop-schemas-3.21.3
- >=gnome-base/gnome-keyring-3.3.90
- gnome-base/libgnome-keyring
>=gnome-extra/evolution-data-server-3.17.2:=
>=media-libs/gstreamer-0.11.92:1.0
>=net-im/telepathy-logger-0.2.4[introspection]
@@ -52,14 +48,13 @@ COMMON_DEPEND="
dev-libs/dbus-glib
dev-libs/libxml2:2
- gnome-base/librsvg
media-libs/libcanberra[gtk3]
media-libs/mesa
>=media-sound/pulseaudio-2
>=net-libs/libsoup-2.40:2.4[introspection]
x11-libs/libX11
x11-libs/gdk-pixbuf:2[introspection]
- x11-libs/pango[introspection]
+
x11-apps/mesa-progs
bluetooth? ( >=net-wireless/gnome-bluetooth-3.9[introspection] )
@@ -67,27 +62,27 @@ COMMON_DEPEND="
app-crypt/libsecret
>=gnome-extra/nm-applet-0.9.8
>=net-misc/networkmanager-0.9.8:=[introspection] )
+ nsplugin? ( >=dev-libs/json-glib-0.13.2 )
"
# Runtime-only deps are probably incomplete and approximate.
# Introspection deps generated using:
# grep -roe "imports.gi.*" gnome-shell-* | cut -f2 -d: | sort | uniq
# Each block:
-# 1. Pull in polkit-0.101 for pretty authorization dialogs
-# 2. Introspection stuff needed via imports.gi.*
-# 3. gnome-session is needed for gnome-session-quit
-# 4. Control shell settings
-# 5. Systemd needed for suspending support
-# 6. xdg-utils needed for xdg-open, used by extension tool
-# 7. gnome-icon-theme-symbolic and dejavu font neeed for various icons & arrows
+# 1. Introspection stuff needed via imports.gi.*
+# 2. gnome-session is needed for gnome-session-quit
+# 3. Control shell settings
+# 4. Systemd needed for suspending support
+# 5. xdg-utils needed for xdg-open, used by extension tool
+# 6. adwaita-icon-theme and dejavu font neeed for various icons & arrows
+# 7. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c
# 8. IBus is needed for nls integration
-# 9. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c
RDEPEND="${COMMON_DEPEND}
- >=sys-auth/polkit-0.101[introspection]
-
+ app-accessibility/at-spi2-core:2[introspection]
>=app-accessibility/caribou-0.4.8
- media-libs/cogl[introspection]
+ dev-libs/libgweather:2[introspection]
>=sys-apps/accountsservice-0.6.14[introspection]
>=sys-power/upower-0.99:=[introspection]
+ x11-libs/pango[introspection]
>=gnome-base/gnome-session-2.91.91
>=gnome-base/gnome-settings-daemon-3.8.3
@@ -111,6 +106,7 @@ PDEPEND="
"
DEPEND="${COMMON_DEPEND}
dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.45.3
>=dev-util/gtk-doc-am-1.17
gnome-base/gnome-common
>=sys-devel/gettext-0.19.6
@@ -122,15 +118,13 @@ DEPEND="${COMMON_DEPEND}
src_prepare() {
# Change favorites defaults, bug #479918
- eapply "${FILESDIR}"/${PN}-3.14.0-defaults.patch
+ eapply "${FILESDIR}"/${PN}-3.22.0-defaults.patch
# Fix automagic gnome-bluetooth dep, bug #398145
eapply "${FILESDIR}"/${PN}-3.12-bluetooth-flag.patch
- # Fix silent bluetooth linking failure with ld.gold, bug #503952
- # https://bugzilla.gnome.org/show_bug.cgi?id=726435
- # This shouldn't be needed per upstream
-# epatch "${FILESDIR}"/${PN}-3.14.0-bluetooth-gold.patch
+ # Add missing path to libmutter-clutter when building .gir, bug #597842
+ eapply "${FILESDIR}"/${PN}-3.22.0-gir-build-fix.patch
eautoreconf
gnome2_src_prepare
@@ -144,6 +138,7 @@ src_configure() {
$(use_enable !openrc-force systemd) \
$(use_with bluetooth) \
$(use_enable networkmanager) \
+ $(use_enable nsplugin browser-plugin) \
BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins
}
@@ -178,12 +173,6 @@ pkg_postinst() {
ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
fi
- if ! has_version ">=x11-base/xorg-server-1.11"; then
- ewarn "If you use multiple screens, it is highly recommended that you"
- ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
- ewarn "pointer barriers which will make it easier to use hot corners."
- fi
-
if has_version "<x11-drivers/ati-drivers-12"; then
ewarn "GNOME Shell has been reported to show graphical corruption under"
ewarn "x11-drivers/ati-drivers-11.*; you may want to switch to open-source"