summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/vigra/vigra-1.11.1-r9.ebuild10
-rw-r--r--media-libs/vigra/vigra-9999.ebuild7
2 files changed, 7 insertions, 10 deletions
diff --git a/media-libs/vigra/vigra-1.11.1-r9.ebuild b/media-libs/vigra/vigra-1.11.1-r9.ebuild
index 6e3de6f74804..1be44dbdba2c 100644
--- a/media-libs/vigra/vigra-1.11.1-r9.ebuild
+++ b/media-libs/vigra/vigra-1.11.1-r9.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+),xml(+)"
+
inherit cmake flag-o-matic python-r1
DESCRIPTION="C++ computer vision library emphasizing customizable algorithms and structures"
@@ -26,11 +27,6 @@ REQUIRED_USE="
python? ( hdf5 ${PYTHON_REQUIRED_USE} )
test? ( hdf5 python fftw )"
-BDEPEND="
- test? (
- >=dev-python/nose-1.1.2-r1[${PYTHON_USEDEP}]
- )
-"
# runtime dependency on python is required by the vigra-config script
DEPEND="
fftw? ( sci-libs/fftw:3.0= )
diff --git a/media-libs/vigra/vigra-9999.ebuild b/media-libs/vigra/vigra-9999.ebuild
index 8e668e863ad0..4fee34b87e24 100644
--- a/media-libs/vigra/vigra-9999.ebuild
+++ b/media-libs/vigra/vigra-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+),xml(+)"
+
inherit cmake flag-o-matic python-r1
DESCRIPTION="C++ computer vision library emphasizing customizable algorithms and structures"
@@ -28,7 +29,7 @@ REQUIRED_USE="
BDEPEND="
test? (
- >=dev-python/nose-1.1.2-r1[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
)
"
# runtime dependency on python is required by the vigra-config script